summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnatoliy Odukha <aodukha@gmail.com>2020-10-30 17:03:28 +0200
committerGitHub <noreply@github.com>2020-10-30 17:03:28 +0200
commit1479cef47264fb2548efa4a8900353bc8592a7f7 (patch)
treefc51add5a6ee0b390b399e66ff01ae5b5c852654
parent69a19e86f9aa57369c104d19adf728ca3cc0ec4f (diff)
parente5325ff58540674d2402b9ce72a34ac65b52c71d (diff)
downloadmeta-updater-1479cef47264fb2548efa4a8900353bc8592a7f7.tar.gz
Merge pull request #781 from advancedtelematic/feat/dunfell/2020.10
aktualizr: Upgrade dunfell to 2020.10 release
-rw-r--r--classes/image_types_ostree.bbclass8
-rw-r--r--classes/sota.bbclass3
-rw-r--r--recipes-sota/aktualizr/aktualizr_git.bb8
-rw-r--r--recipes-sota/ostree-kernel-initramfs/ostree-kernel-initramfs_0.0.1.bb8
4 files changed, 16 insertions, 11 deletions
diff --git a/classes/image_types_ostree.bbclass b/classes/image_types_ostree.bbclass
index 0b928a3..e66956a 100644
--- a/classes/image_types_ostree.bbclass
+++ b/classes/image_types_ostree.bbclass
@@ -87,7 +87,7 @@ IMAGE_CMD_ostree () {
87 if [ -n "${SYSTEMD_USED}" ]; then 87 if [ -n "${SYSTEMD_USED}" ]; then
88 echo "d /var/rootdirs/${dir} 0755 root root -" >>${tmpfiles_conf} 88 echo "d /var/rootdirs/${dir} 0755 root root -" >>${tmpfiles_conf}
89 else 89 else
90 echo "mkdir -p /var/rootdirs/${dir}; chown 755 /var/rootdirs/${dir}" >>${tmpfiles_conf} 90 echo "mkdir -p /var/rootdirs/${dir}; chmod 755 /var/rootdirs/${dir}" >>${tmpfiles_conf}
91 fi 91 fi
92 ln -sf var/rootdirs/${dir} ${dir} 92 ln -sf var/rootdirs/${dir} ${dir}
93 done 93 done
@@ -100,7 +100,7 @@ IMAGE_CMD_ostree () {
100 if [ -n "${SYSTEMD_USED}" ]; then 100 if [ -n "${SYSTEMD_USED}" ]; then
101 echo "d /var/roothome 0700 root root -" >>${tmpfiles_conf} 101 echo "d /var/roothome 0700 root root -" >>${tmpfiles_conf}
102 else 102 else
103 echo "mkdir -p /var/roothome; chown 700 /var/roothome" >>${tmpfiles_conf} 103 echo "mkdir -p /var/roothome; chmod 700 /var/roothome" >>${tmpfiles_conf}
104 fi 104 fi
105 105
106 rm -rf root 106 rm -rf root
@@ -117,7 +117,7 @@ IMAGE_CMD_ostree () {
117 if [ -n "${SYSTEMD_USED}" ]; then 117 if [ -n "${SYSTEMD_USED}" ]; then
118 echo "d /var/usrlocal 0755 root root -" >>${tmpfiles_conf} 118 echo "d /var/usrlocal 0755 root root -" >>${tmpfiles_conf}
119 else 119 else
120 echo "mkdir -p /var/usrlocal; chown 755 /var/usrlocal" >>${tmpfiles_conf} 120 echo "mkdir -p /var/usrlocal; chmod 755 /var/usrlocal" >>${tmpfiles_conf}
121 fi 121 fi
122 122
123 dirs="bin etc games include lib man sbin share src" 123 dirs="bin etc games include lib man sbin share src"
@@ -126,7 +126,7 @@ IMAGE_CMD_ostree () {
126 if [ -n "${SYSTEMD_USED}" ]; then 126 if [ -n "${SYSTEMD_USED}" ]; then
127 echo "d /var/usrlocal/${dir} 0755 root root -" >>${tmpfiles_conf} 127 echo "d /var/usrlocal/${dir} 0755 root root -" >>${tmpfiles_conf}
128 else 128 else
129 echo "mkdir -p /var/usrlocal/${dir}; chown 755 /var/usrlocal/${dir}" >>${tmpfiles_conf} 129 echo "mkdir -p /var/usrlocal/${dir}; chmod 755 /var/usrlocal/${dir}" >>${tmpfiles_conf}
130 fi 130 fi
131 done 131 done
132 132
diff --git a/classes/sota.bbclass b/classes/sota.bbclass
index e6a0f8b..8f3f5d7 100644
--- a/classes/sota.bbclass
+++ b/classes/sota.bbclass
@@ -6,8 +6,7 @@ SOTA_HARDWARE_ID ??= "${MACHINE}"
6 6
7IMAGE_CLASSES += " image_types_ostree image_types_ota image_repo_manifest" 7IMAGE_CLASSES += " image_types_ostree image_types_ota image_repo_manifest"
8IMAGE_INSTALL_append_sota = " aktualizr aktualizr-info ${SOTA_CLIENT_PROV} \ 8IMAGE_INSTALL_append_sota = " aktualizr aktualizr-info ${SOTA_CLIENT_PROV} \
9 ostree os-release ostree-kernel \ 9 ostree os-release ostree-kernel ostree-initramfs \
10 ${@'ostree-initramfs' if d.getVar('KERNEL_IMAGETYPE') != 'fitImage' else ''} \
11 ${@'ostree-devicetrees' if oe.types.boolean('${OSTREE_DEPLOY_DEVICETREE}') else ''}" 10 ${@'ostree-devicetrees' if oe.types.boolean('${OSTREE_DEPLOY_DEVICETREE}') else ''}"
12 11
13IMAGE_FSTYPES += "${@bb.utils.contains('DISTRO_FEATURES', 'sota', 'ostreepush garagesign garagecheck ota-ext4 wic', ' ', d)}" 12IMAGE_FSTYPES += "${@bb.utils.contains('DISTRO_FEATURES', 'sota', 'ostreepush garagesign garagecheck ota-ext4 wic', ' ', d)}"
diff --git a/recipes-sota/aktualizr/aktualizr_git.bb b/recipes-sota/aktualizr/aktualizr_git.bb
index d7d9392..c09e7cb 100644
--- a/recipes-sota/aktualizr/aktualizr_git.bb
+++ b/recipes-sota/aktualizr/aktualizr_git.bb
@@ -16,7 +16,7 @@ PRIVATE_LIBS_${PN}-ptest = "libaktualizr.so libaktualizr_secondary.so"
16PV = "1.0+git${SRCPV}" 16PV = "1.0+git${SRCPV}"
17PR = "7" 17PR = "7"
18 18
19GARAGE_SIGN_PV = "0.7.1-22-g1d0d714" 19GARAGE_SIGN_PV = "0.7.2-9-g80ae114"
20 20
21SRC_URI = " \ 21SRC_URI = " \
22 gitsm://github.com/advancedtelematic/aktualizr;branch=${BRANCH};name=aktualizr \ 22 gitsm://github.com/advancedtelematic/aktualizr;branch=${BRANCH};name=aktualizr \
@@ -28,10 +28,10 @@ SRC_URI = " \
28 ${@ d.expand("https://tuf-cli-releases.ota.here.com/cli-${GARAGE_SIGN_PV}.tgz;unpack=0;name=garagesign") if not oe.types.boolean(d.getVar('GARAGE_SIGN_AUTOVERSION')) else ''} \ 28 ${@ d.expand("https://tuf-cli-releases.ota.here.com/cli-${GARAGE_SIGN_PV}.tgz;unpack=0;name=garagesign") if not oe.types.boolean(d.getVar('GARAGE_SIGN_AUTOVERSION')) else ''} \
29 " 29 "
30 30
31SRC_URI[garagesign.md5sum] = "7be214beb64ce4ae443f7a4288b6d491" 31SRC_URI[garagesign.md5sum] = "2598ce3a468c40a58df3304fb71ea14b"
32SRC_URI[garagesign.sha256sum] = "b8524a03bb31551889790eca4ed44070f679d33a98b09e8220d7e0e965de68d8" 32SRC_URI[garagesign.sha256sum] = "acbc814a9ed962a0d3b5bc397b14fef6a139e874e6cc3075671dab69bc8541fd"
33 33
34SRCREV = "d4811f900c765f3b4e5b9ea76531bad7d830a691" 34SRCREV = "1255aa24fe55f99b606027c8acc8cd80db29a282"
35BRANCH ?= "master" 35BRANCH ?= "master"
36 36
37S = "${WORKDIR}/git" 37S = "${WORKDIR}/git"
diff --git a/recipes-sota/ostree-kernel-initramfs/ostree-kernel-initramfs_0.0.1.bb b/recipes-sota/ostree-kernel-initramfs/ostree-kernel-initramfs_0.0.1.bb
index 9ac90b9..9a229ba 100644
--- a/recipes-sota/ostree-kernel-initramfs/ostree-kernel-initramfs_0.0.1.bb
+++ b/recipes-sota/ostree-kernel-initramfs/ostree-kernel-initramfs_0.0.1.bb
@@ -36,7 +36,13 @@ do_install() {
36 36
37 cp ${DEPLOY_DIR_IMAGE}/${OSTREE_KERNEL} $kerneldir/vmlinuz 37 cp ${DEPLOY_DIR_IMAGE}/${OSTREE_KERNEL} $kerneldir/vmlinuz
38 38
39 if [ "${KERNEL_IMAGETYPE}" != "fitImage" ]; then 39 if [ "${KERNEL_IMAGETYPE}" = "fitImage" ]; then
40 if [ -n "${INITRAMFS_IMAGE}" ]; then
41 # this is a hack for ostree not to override init= in kernel cmdline -
42 # make it think that the initramfs is present (while it is in FIT image)
43 touch $kerneldir/initramfs.img
44 fi
45 else
40 if [ -n "${INITRAMFS_IMAGE}" ]; then 46 if [ -n "${INITRAMFS_IMAGE}" ]; then
41 cp ${DEPLOY_DIR_IMAGE}/${INITRAMFS_IMAGE}-${MACHINE}.${INITRAMFS_FSTYPES} $kerneldir/initramfs.img 47 cp ${DEPLOY_DIR_IMAGE}/${INITRAMFS_IMAGE}-${MACHINE}.${INITRAMFS_FSTYPES} $kerneldir/initramfs.img
42 fi 48 fi