summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Vacek <patrickvacek@gmail.com>2020-03-25 14:09:16 +0100
committerGitHub <noreply@github.com>2020-03-25 14:09:16 +0100
commit36c0d42d38120b6d154e6fd44343d23ee634a9e4 (patch)
tree25585aa83b09b7e2672a4d5f7a2434b6a32371b3
parent1d581dd2fc4f8e1082ac20fc11153664ceec5963 (diff)
parent68820877358c54a232ef959a30af5ad8af1f3294 (diff)
downloadmeta-updater-36c0d42d38120b6d154e6fd44343d23ee634a9e4.tar.gz
Merge pull request #699 from advancedtelematic/feat/2020.4
aktualizr: Bump to latest along with garage-sign.
-rw-r--r--lib/oeqa/selftest/cases/testutils.py4
-rw-r--r--recipes-sota/aktualizr/aktualizr_git.bb8
2 files changed, 6 insertions, 6 deletions
diff --git a/lib/oeqa/selftest/cases/testutils.py b/lib/oeqa/selftest/cases/testutils.py
index 3455fa8..3abfa5e 100644
--- a/lib/oeqa/selftest/cases/testutils.py
+++ b/lib/oeqa/selftest/cases/testutils.py
@@ -139,10 +139,10 @@ def verifyProvisioned(testInst, machine, hwid=''):
139 testInst.assertEqual(stderr, b'', 'aktualizr-info failed: ' + stderr.decode() + stdout.decode()) 139 testInst.assertEqual(stderr, b'', 'aktualizr-info failed: ' + stderr.decode() + stdout.decode())
140 testInst.assertIn(b'Device ID: ', stdout, 'Provisioning failed: ' + stderr.decode() + stdout.decode()) 140 testInst.assertIn(b'Device ID: ', stdout, 'Provisioning failed: ' + stderr.decode() + stdout.decode())
141 if hwid == '': 141 if hwid == '':
142 testInst.assertIn(b'Primary ecu hardware ID: ' + machine.encode(), stdout, 142 testInst.assertIn(b'Primary ECU hardware ID: ' + machine.encode(), stdout,
143 'Provisioning failed: ' + stderr.decode() + stdout.decode()) 143 'Provisioning failed: ' + stderr.decode() + stdout.decode())
144 else: 144 else:
145 testInst.assertIn(b'Primary ecu hardware ID: ' + hwid.encode(), stdout, 145 testInst.assertIn(b'Primary ECU hardware ID: ' + hwid.encode(), stdout,
146 'Provisioning failed: ' + stderr.decode() + stdout.decode()) 146 'Provisioning failed: ' + stderr.decode() + stdout.decode())
147 testInst.assertIn(b'Fetched metadata: yes', stdout, 'Provisioning failed: ' + stderr.decode() + stdout.decode()) 147 testInst.assertIn(b'Fetched metadata: yes', stdout, 'Provisioning failed: ' + stderr.decode() + stdout.decode())
148 p = re.compile(r'Device ID: ([a-z0-9-]*)\n') 148 p = re.compile(r'Device ID: ([a-z0-9-]*)\n')
diff --git a/recipes-sota/aktualizr/aktualizr_git.bb b/recipes-sota/aktualizr/aktualizr_git.bb
index 80cf3eb..a0c2713 100644
--- a/recipes-sota/aktualizr/aktualizr_git.bb
+++ b/recipes-sota/aktualizr/aktualizr_git.bb
@@ -17,7 +17,7 @@ PRIVATE_LIBS_${PN}-ptest = "libaktualizr.so libaktualizr_secondary.so"
17PV = "1.0+git${SRCPV}" 17PV = "1.0+git${SRCPV}"
18PR = "7" 18PR = "7"
19 19
20GARAGE_SIGN_PV = "0.7.0-70-g3adf982" 20GARAGE_SIGN_PV = "0.7.0-87-g905dc3c"
21 21
22SRC_URI = " \ 22SRC_URI = " \
23 gitsm://github.com/advancedtelematic/aktualizr;branch=${BRANCH};name=aktualizr \ 23 gitsm://github.com/advancedtelematic/aktualizr;branch=${BRANCH};name=aktualizr \
@@ -29,10 +29,10 @@ SRC_URI = " \
29 ${@ d.expand("https://ats-tuf-cli-releases.s3-eu-central-1.amazonaws.com/cli-${GARAGE_SIGN_PV}.tgz;unpack=0;name=garagesign") if d.getVar('GARAGE_SIGN_AUTOVERSION') != '1' else ''} \ 29 ${@ d.expand("https://ats-tuf-cli-releases.s3-eu-central-1.amazonaws.com/cli-${GARAGE_SIGN_PV}.tgz;unpack=0;name=garagesign") if d.getVar('GARAGE_SIGN_AUTOVERSION') != '1' else ''} \
30 " 30 "
31 31
32SRC_URI[garagesign.md5sum] = "7c4cbeacefd97eae69104d29cf5ff37a" 32SRC_URI[garagesign.md5sum] = "064b408c60676dcf282aa9209bff7dac"
33SRC_URI[garagesign.sha256sum] = "e9a9b68eaa1ce4104eb2ab7f1f59d99742d50805e93216fb5b21d1f212aa3d82" 33SRC_URI[garagesign.sha256sum] = "75c9b3cf24eb31dacb127d3b3d073359082e2b4ee4eeb27d75e792664800ba82"
34 34
35SRCREV = "ba10c86befef02ee24f9bad5251265d7f0dc4376" 35SRCREV = "f90e8996e826d130976a7b7f1835947b7e631025"
36BRANCH ?= "master" 36BRANCH ?= "master"
37 37
38S = "${WORKDIR}/git" 38S = "${WORKDIR}/git"