summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Vacek <patrickvacek@gmail.com>2019-10-16 16:54:55 +0200
committerPatrick Vacek <patrickvacek@gmail.com>2019-10-21 13:22:04 +0200
commit4bcb164063a1a12f1cc12165934bcaeaa81732a7 (patch)
tree115ea4820e279f1d2ede0eed6b74ef39b6e6ebe9
parent3b2b6e485c4ade61296322f4e1efae09c04e396a (diff)
downloadmeta-updater-4bcb164063a1a12f1cc12165934bcaeaa81732a7.tar.gz
Specify more configs as MACHINE_ARCH.
If they depend on MACHINE, that's what we gotta do. Still haven't sorted out aktualizr-device-prov-creds, though. Signed-off-by: Patrick Vacek <patrickvacek@gmail.com>
-rw-r--r--recipes-sota/aktualizr/aktualizr-hwid.bb1
-rw-r--r--recipes-test/demo-config/secondary-config.bb3
-rw-r--r--recipes-test/demo-network-config/network-config.inc3
3 files changed, 7 insertions, 0 deletions
diff --git a/recipes-sota/aktualizr/aktualizr-hwid.bb b/recipes-sota/aktualizr/aktualizr-hwid.bb
index 64b1bda..fd3e395 100644
--- a/recipes-sota/aktualizr/aktualizr-hwid.bb
+++ b/recipes-sota/aktualizr/aktualizr-hwid.bb
@@ -4,6 +4,7 @@ SECTION = "base"
4LICENSE = "MPL-2.0" 4LICENSE = "MPL-2.0"
5LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7f619bab123dad" 5LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7f619bab123dad"
6 6
7# Because of the dependency on MACHINE.
7PACKAGE_ARCH = "${MACHINE_ARCH}" 8PACKAGE_ARCH = "${MACHINE_ARCH}"
8 9
9SRC_URI = "" 10SRC_URI = ""
diff --git a/recipes-test/demo-config/secondary-config.bb b/recipes-test/demo-config/secondary-config.bb
index 55358b7..ddbed89 100644
--- a/recipes-test/demo-config/secondary-config.bb
+++ b/recipes-test/demo-config/secondary-config.bb
@@ -4,6 +4,9 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7
4 4
5require shared-conf.inc 5require shared-conf.inc
6 6
7# Because of the dependency on MACHINE.
8PACKAGE_ARCH = "${MACHINE_ARCH}"
9
7SECONDARY_SERIAL_ID ?= "" 10SECONDARY_SERIAL_ID ?= ""
8SOTA_HARDWARE_ID ?= "${MACHINE}-sndry" 11SOTA_HARDWARE_ID ?= "${MACHINE}-sndry"
9SECONDARY_HARDWARE_ID ?= "${SOTA_HARDWARE_ID}" 12SECONDARY_HARDWARE_ID ?= "${SOTA_HARDWARE_ID}"
diff --git a/recipes-test/demo-network-config/network-config.inc b/recipes-test/demo-network-config/network-config.inc
index a231a24..b023f51 100644
--- a/recipes-test/demo-network-config/network-config.inc
+++ b/recipes-test/demo-network-config/network-config.inc
@@ -2,6 +2,9 @@ SRC_URI_append = "\
2 file://26-${CONF_TYPE}-client.network \ 2 file://26-${CONF_TYPE}-client.network \
3 " 3 "
4 4
5# Because of the dependency on MACHINE.
6PACKAGE_ARCH = "${MACHINE_ARCH}"
7
5SECONDARY_INTERFACE ?= "${@ 'eth0' if d.getVar('MACHINE') == 'raspberrypi3' else 'enp0s5'}" 8SECONDARY_INTERFACE ?= "${@ 'eth0' if d.getVar('MACHINE') == 'raspberrypi3' else 'enp0s5'}"
6 9
7do_install_append() { 10do_install_append() {