summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRicardo Salveti <ricardo@opensourcefoundries.com>2018-02-08 18:47:27 -0200
committerRicardo Salveti <ricardo@opensourcefoundries.com>2018-02-09 00:32:03 -0200
commit84913d17a11cbc3ec357ed91bdc725db6b639469 (patch)
treee7f6fa1754547af07be79668aeac201bb4f5ea40
parentef9513db1ad17173409364c44a724623b5b802d8 (diff)
downloadmeta-updater-84913d17a11cbc3ec357ed91bdc725db6b639469.tar.gz
Replace INITRAMFS_FSTYPES with OSTREE_INITRAMFS_FSTYPES
User is able to customize the init script via OSTREE_INITRAMFS_IMAGE but there is no way to set INITRAMFS_FSTYPES as it gets defined by sota.bbclass. Create a new variable called OSTREE_INITRAMFS_IMAGE to handle the INITRAMFS_FSTYPES update, and also allow the user to override it. Signed-off-by: Ricardo Salveti <ricardo@opensourcefoundries.com>
-rw-r--r--classes/image_types_ostree.bbclass2
-rw-r--r--classes/sota.bbclass2
-rw-r--r--recipes-core/images/initramfs-ostree-image.bb2
3 files changed, 3 insertions, 3 deletions
diff --git a/classes/image_types_ostree.bbclass b/classes/image_types_ostree.bbclass
index 904db96..5893e8d 100644
--- a/classes/image_types_ostree.bbclass
+++ b/classes/image_types_ostree.bbclass
@@ -10,7 +10,7 @@ do_image_ostree[depends] += "ostree-native:do_populate_sysroot \
10export OSTREE_REPO 10export OSTREE_REPO
11export OSTREE_BRANCHNAME 11export OSTREE_BRANCHNAME
12 12
13RAMDISK_EXT ?= ".${INITRAMFS_FSTYPES}" 13RAMDISK_EXT ?= ".${OSTREE_INITRAMFS_FSTYPES}"
14export GARAGE_TARGET_NAME 14export GARAGE_TARGET_NAME
15 15
16OSTREE_KERNEL ??= "${KERNEL_IMAGETYPE}" 16OSTREE_KERNEL ??= "${KERNEL_IMAGETYPE}"
diff --git a/classes/sota.bbclass b/classes/sota.bbclass
index 2a12e8f..6531809 100644
--- a/classes/sota.bbclass
+++ b/classes/sota.bbclass
@@ -20,7 +20,7 @@ WKS_FILE_sota ?= "sdimage-sota.wks"
20 20
21EXTRA_IMAGEDEPENDS_append_sota = " parted-native mtools-native dosfstools-native" 21EXTRA_IMAGEDEPENDS_append_sota = " parted-native mtools-native dosfstools-native"
22 22
23INITRAMFS_FSTYPES = "${@oe.utils.ifelse(d.getVar('OSTREE_BOOTLOADER', True) == 'u-boot', 'ext4.gz.u-boot', 'ext4.gz')}" 23OSTREE_INITRAMFS_FSTYPES ?= "${@oe.utils.ifelse(d.getVar('OSTREE_BOOTLOADER', True) == 'u-boot', 'ext4.gz.u-boot', 'ext4.gz')}"
24 24
25# Please redefine OSTREE_REPO in order to have a persistent OSTree repo 25# Please redefine OSTREE_REPO in order to have a persistent OSTree repo
26OSTREE_REPO ?= "${DEPLOY_DIR_IMAGE}/ostree_repo" 26OSTREE_REPO ?= "${DEPLOY_DIR_IMAGE}/ostree_repo"
diff --git a/recipes-core/images/initramfs-ostree-image.bb b/recipes-core/images/initramfs-ostree-image.bb
index e77499e..b2d9e27 100644
--- a/recipes-core/images/initramfs-ostree-image.bb
+++ b/recipes-core/images/initramfs-ostree-image.bb
@@ -13,7 +13,7 @@ IMAGE_LINGUAS = ""
13 13
14LICENSE = "MIT" 14LICENSE = "MIT"
15 15
16IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}" 16IMAGE_FSTYPES = "${OSTREE_INITRAMFS_FSTYPES}"
17 17
18inherit core-image 18inherit core-image
19 19