summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Vacek <patrickvacek@gmail.com>2019-10-14 12:06:23 +0200
committerPatrick Vacek <patrickvacek@gmail.com>2019-10-21 13:02:11 +0200
commit0f25771be55a3c7daf9eded720bf2868b04becde (patch)
tree97639c172f2fe89e3ed25c4443f687c099ddfaa6
parent1f7ff1fa5b72a20471eb9deb13d3ff5b06ec446d (diff)
downloadmeta-updater-0f25771be55a3c7daf9eded720bf2868b04becde.tar.gz
aktualizr: use SIGGEN_EXCLUDE_SAFE_RECIPE_DEPS for config recipes.
This is a bit of a compromise. These recipes are allarch, since they do not depend on an architecture, but they depend on aktualizr, which is definitely not allarch. Therefore, we must tell bitbake not to treat the aktualizr architecture as a dependency of these recipes. However, this means that if one of the config files changes in the aktualizr repo, we need to bump the version of the recipe that uses it to make sure bitbake picks up that change. Signed-off-by: Patrick Vacek <patrickvacek@gmail.com>
-rw-r--r--conf/layer.conf9
-rw-r--r--recipes-sota/aktualizr/aktualizr-device-prov-creds.bb5
-rw-r--r--recipes-sota/aktualizr/aktualizr-device-prov-hsm.bb5
-rw-r--r--recipes-sota/aktualizr/aktualizr-device-prov.bb4
-rw-r--r--recipes-sota/aktualizr/aktualizr-shared-prov-creds.bb7
-rw-r--r--recipes-sota/aktualizr/aktualizr-shared-prov.bb3
-rw-r--r--recipes-sota/aktualizr/aktualizr-uboot-env-rollback.bb5
7 files changed, 37 insertions, 1 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index 627a1b8..27faa0f 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -11,3 +11,12 @@ BBFILE_PRIORITY_sota = "7"
11 11
12LAYERDEPENDS_sota = "filesystems-layer" 12LAYERDEPENDS_sota = "filesystems-layer"
13LAYERSERIES_COMPAT_sota = "thud" 13LAYERSERIES_COMPAT_sota = "thud"
14
15SIGGEN_EXCLUDE_SAFE_RECIPE_DEPS += " \
16 aktualizr-device-prov->aktualizr \
17 aktualizr-device-prov-creds->aktualizr \
18 aktualizr-device-prov-hsm->aktualizr \
19 aktualizr-shared-prov->aktualizr \
20 aktualizr-shared-prov-creds->aktualizr \
21 aktualizr-uboot-env-rollback->aktualizr \
22"
diff --git a/recipes-sota/aktualizr/aktualizr-device-prov-creds.bb b/recipes-sota/aktualizr/aktualizr-device-prov-creds.bb
index d8b29b4..a3c7d66 100644
--- a/recipes-sota/aktualizr/aktualizr-device-prov-creds.bb
+++ b/recipes-sota/aktualizr/aktualizr-device-prov-creds.bb
@@ -15,6 +15,11 @@ inherit allarch
15DEPENDS = "aktualizr aktualizr-native openssl-native" 15DEPENDS = "aktualizr aktualizr-native openssl-native"
16ALLOW_EMPTY_${PN} = "1" 16ALLOW_EMPTY_${PN} = "1"
17 17
18# If the config file from aktualizr used here is changed, you will need to bump
19# the version here because of SIGGEN_EXCLUDE_SAFE_RECIPE_DEPS!
20PV = "1.0"
21PR = "1"
22
18SRC_URI = " \ 23SRC_URI = " \
19 file://ca.cnf \ 24 file://ca.cnf \
20 " 25 "
diff --git a/recipes-sota/aktualizr/aktualizr-device-prov-hsm.bb b/recipes-sota/aktualizr/aktualizr-device-prov-hsm.bb
index e8ef513..8d4bc9c 100644
--- a/recipes-sota/aktualizr/aktualizr-device-prov-hsm.bb
+++ b/recipes-sota/aktualizr/aktualizr-device-prov-hsm.bb
@@ -12,10 +12,13 @@ inherit allarch
12DEPENDS = "aktualizr" 12DEPENDS = "aktualizr"
13RDEPENDS_${PN}_append = "${@' aktualizr-device-prov-creds softhsm-testtoken' if d.getVar('SOTA_DEPLOY_CREDENTIALS') == '1' else ''}" 13RDEPENDS_${PN}_append = "${@' aktualizr-device-prov-creds softhsm-testtoken' if d.getVar('SOTA_DEPLOY_CREDENTIALS') == '1' else ''}"
14 14
15SRC_URI = "" 15# If the config file from aktualizr used here is changed, you will need to bump
16# the version here because of SIGGEN_EXCLUDE_SAFE_RECIPE_DEPS!
16PV = "1.0" 17PV = "1.0"
17PR = "6" 18PR = "6"
18 19
20SRC_URI = ""
21
19do_install() { 22do_install() {
20 install -m 0700 -d ${D}${libdir}/sota/conf.d 23 install -m 0700 -d ${D}${libdir}/sota/conf.d
21 install -m 0644 ${STAGING_DIR_HOST}${libdir}/sota/sota-device-cred-hsm.toml \ 24 install -m 0644 ${STAGING_DIR_HOST}${libdir}/sota/sota-device-cred-hsm.toml \
diff --git a/recipes-sota/aktualizr/aktualizr-device-prov.bb b/recipes-sota/aktualizr/aktualizr-device-prov.bb
index fbe29a1..e8c75bb 100644
--- a/recipes-sota/aktualizr/aktualizr-device-prov.bb
+++ b/recipes-sota/aktualizr/aktualizr-device-prov.bb
@@ -12,9 +12,13 @@ inherit allarch
12DEPENDS = "aktualizr" 12DEPENDS = "aktualizr"
13RDEPENDS_${PN}_append = "${@' aktualizr-device-prov-creds' if d.getVar('SOTA_DEPLOY_CREDENTIALS') == '1' else ''}" 13RDEPENDS_${PN}_append = "${@' aktualizr-device-prov-creds' if d.getVar('SOTA_DEPLOY_CREDENTIALS') == '1' else ''}"
14 14
15# If the config file from aktualizr used here is changed, you will need to bump
16# the version here because of SIGGEN_EXCLUDE_SAFE_RECIPE_DEPS!
15PV = "1.0" 17PV = "1.0"
16PR = "1" 18PR = "1"
17 19
20SRC_URI = ""
21
18do_install() { 22do_install() {
19 install -m 0700 -d ${D}${libdir}/sota/conf.d 23 install -m 0700 -d ${D}${libdir}/sota/conf.d
20 install -m 0644 ${STAGING_DIR_HOST}${libdir}/sota/sota-device-cred.toml \ 24 install -m 0644 ${STAGING_DIR_HOST}${libdir}/sota/sota-device-cred.toml \
diff --git a/recipes-sota/aktualizr/aktualizr-shared-prov-creds.bb b/recipes-sota/aktualizr/aktualizr-shared-prov-creds.bb
index b3b539d..9c6f0dd 100644
--- a/recipes-sota/aktualizr/aktualizr-shared-prov-creds.bb
+++ b/recipes-sota/aktualizr/aktualizr-shared-prov-creds.bb
@@ -9,6 +9,13 @@ inherit allarch
9DEPENDS = "zip-native" 9DEPENDS = "zip-native"
10ALLOW_EMPTY_${PN} = "1" 10ALLOW_EMPTY_${PN} = "1"
11 11
12# If the config file from aktualizr used here is changed, you will need to bump
13# the version here because of SIGGEN_EXCLUDE_SAFE_RECIPE_DEPS!
14PV = "1.0"
15PR = "1"
16
17SRC_URI = ""
18
12require credentials.inc 19require credentials.inc
13 20
14do_install() { 21do_install() {
diff --git a/recipes-sota/aktualizr/aktualizr-shared-prov.bb b/recipes-sota/aktualizr/aktualizr-shared-prov.bb
index 00588dc..2ee47a1 100644
--- a/recipes-sota/aktualizr/aktualizr-shared-prov.bb
+++ b/recipes-sota/aktualizr/aktualizr-shared-prov.bb
@@ -11,6 +11,9 @@ inherit allarch
11# the aktualizr (target) recipe. 11# the aktualizr (target) recipe.
12DEPENDS = "aktualizr" 12DEPENDS = "aktualizr"
13RDEPENDS_${PN}_append = "${@' aktualizr-shared-prov-creds' if d.getVar('SOTA_DEPLOY_CREDENTIALS') == '1' else ''}" 13RDEPENDS_${PN}_append = "${@' aktualizr-shared-prov-creds' if d.getVar('SOTA_DEPLOY_CREDENTIALS') == '1' else ''}"
14
15# If the config file from aktualizr used here is changed, you will need to bump
16# the version here because of SIGGEN_EXCLUDE_SAFE_RECIPE_DEPS!
14PV = "1.0" 17PV = "1.0"
15PR = "6" 18PR = "6"
16 19
diff --git a/recipes-sota/aktualizr/aktualizr-uboot-env-rollback.bb b/recipes-sota/aktualizr/aktualizr-uboot-env-rollback.bb
index 5a49d16..2895e5c 100644
--- a/recipes-sota/aktualizr/aktualizr-uboot-env-rollback.bb
+++ b/recipes-sota/aktualizr/aktualizr-uboot-env-rollback.bb
@@ -8,6 +8,11 @@ inherit allarch
8 8
9DEPENDS = "aktualizr" 9DEPENDS = "aktualizr"
10 10
11# If the config file from aktualizr used here is changed, you will need to bump
12# the version here because of SIGGEN_EXCLUDE_SAFE_RECIPE_DEPS!
13PV = "1.0"
14PR = "1"
15
11SRC_URI = "" 16SRC_URI = ""
12 17
13do_install() { 18do_install() {