summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Agner <stefan.agner@toradex.com>2019-03-09 09:13:00 +0100
committerStefan Agner <stefan.agner@toradex.com>2019-03-09 09:13:00 +0100
commit10ac9ffe0582b32e46b56c47458bbbf627052aa7 (patch)
tree41356ef6e77716fcd5128b812dd4389d3618a514
parent4e75e09db5c40a1a02044192a28381ac20ca84e7 (diff)
downloadmeta-updater-10ac9ffe0582b32e46b56c47458bbbf627052aa7.tar.gz
aktualizr: use echo -e when using escape sequences
Some shell require the -e argument when using escape sequences in echo. This has been observed when building images on a Fedora machine, where the configuration files ended up including "\n" sequences instead of newlines. Signed-off-by: Stefan Agner <stefan.agner@toradex.com>
-rwxr-xr-xrecipes-sota/aktualizr/aktualizr_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-sota/aktualizr/aktualizr_git.bb b/recipes-sota/aktualizr/aktualizr_git.bb
index 0354fa0..2c27935 100755
--- a/recipes-sota/aktualizr/aktualizr_git.bb
+++ b/recipes-sota/aktualizr/aktualizr_git.bb
@@ -69,14 +69,14 @@ do_install_append () {
69 install -m 0700 -d ${D}${sysconfdir}/sota/conf.d 69 install -m 0700 -d ${D}${sysconfdir}/sota/conf.d
70 70
71 if [ -n "${SOTA_HARDWARE_ID}" ]; then 71 if [ -n "${SOTA_HARDWARE_ID}" ]; then
72 echo "[provision]\nprimary_ecu_hardware_id = ${SOTA_HARDWARE_ID}\n" > ${D}${libdir}/sota/conf.d/40-hardware-id.toml 72 echo -e "[provision]\nprimary_ecu_hardware_id = ${SOTA_HARDWARE_ID}\n" > ${D}${libdir}/sota/conf.d/40-hardware-id.toml
73 fi 73 fi
74 74
75 if [ -n "${SOTA_SECONDARY_CONFIG_DIR}" ]; then 75 if [ -n "${SOTA_SECONDARY_CONFIG_DIR}" ]; then
76 if [ -d "${SOTA_SECONDARY_CONFIG_DIR}" ]; then 76 if [ -d "${SOTA_SECONDARY_CONFIG_DIR}" ]; then
77 install -m 0700 -d ${D}${sysconfdir}/sota/ecus 77 install -m 0700 -d ${D}${sysconfdir}/sota/ecus
78 install -m 0644 "${SOTA_SECONDARY_CONFIG_DIR}"/* ${D}${sysconfdir}/sota/ecus/ 78 install -m 0644 "${SOTA_SECONDARY_CONFIG_DIR}"/* ${D}${sysconfdir}/sota/ecus/
79 echo "[uptane]\nsecondary_configs_dir = /etc/sota/ecus/\n" > ${D}${libdir}/sota/conf.d/30-secondary-configs-dir.toml 79 echo -e "[uptane]\nsecondary_configs_dir = /etc/sota/ecus/\n" > ${D}${libdir}/sota/conf.d/30-secondary-configs-dir.toml
80 else 80 else
81 bbwarn "SOTA_SECONDARY_CONFIG_DIR is set to an invalid directory (${SOTA_SECONDARY_CONFIG_DIR})" 81 bbwarn "SOTA_SECONDARY_CONFIG_DIR is set to an invalid directory (${SOTA_SECONDARY_CONFIG_DIR})"
82 fi 82 fi