summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorcajun-rat <philip.wise@here.com>2018-06-26 15:56:47 +0200
committerGitHub <noreply@github.com>2018-06-26 15:56:47 +0200
commit620b412923cf055a0fddb6214f63be6cbdde5701 (patch)
treec1889c842d36318fc9c2f5967519f4741d122d31
parentde3ff91932d73199e1bfd15ed3b9caa54fbff3af (diff)
parent94e675eb2308e1b2a58a12e4447531bdb6be7607 (diff)
downloadmeta-updater-620b412923cf055a0fddb6214f63be6cbdde5701.tar.gz
Merge pull request #340 from advancedtelematic/bugfix/typos_and_comments_rocko
Bugfix/typos and comments rocko
-rw-r--r--CONTRIBUTING.adoc3
-rw-r--r--classes/sota.bbclass1
-rw-r--r--lib/oeqa/selftest/cases/updater.py14
-rw-r--r--recipes-sota/aktualizr/aktualizr-auto-prov.bb4
4 files changed, 11 insertions, 11 deletions
diff --git a/CONTRIBUTING.adoc b/CONTRIBUTING.adoc
index df7a717..93a0815 100644
--- a/CONTRIBUTING.adoc
+++ b/CONTRIBUTING.adoc
@@ -1,4 +1,5 @@
1= Contributing 1= Contributing
2 2
3We welcome pull requests from everyone. It may be helpful to read the README and other documentation for link:README.adoc[this repo], https://github.com/advancedtelematic/aktualizr[aktualizr], and the https://github.com/advancedtelematic/updater-repo/[updater-repo], particularly the sections and development and debugging. 3We welcome pull requests from anyone. The master branch is the primary branch for development, and if you wish to add new functionality, it probably belongs there. We attempt to maintain recent previous branches and welcome bug fixes and backports for those. Currently, the actively maintained branches are sumo, rocko, and pyro. Previously, morty was also a stable branch, but it has not been updated or actively maintained for a while.
4 4
5If you are developing with meta-updater, it may be helpful to read the README and other documentation for link:README.adoc[this repo], https://github.com/advancedtelematic/aktualizr[aktualizr], and the https://github.com/advancedtelematic/updater-repo/[updater-repo], particularly the sections about development and debugging.
diff --git a/classes/sota.bbclass b/classes/sota.bbclass
index 38d4ce5..e1c5ecd 100644
--- a/classes/sota.bbclass
+++ b/classes/sota.bbclass
@@ -24,7 +24,6 @@ OSTREE_INITRAMFS_FSTYPES ??= "${@oe.utils.ifelse(d.getVar('OSTREE_BOOTLOADER', T
24 24
25# Please redefine OSTREE_REPO in order to have a persistent OSTree repo 25# Please redefine OSTREE_REPO in order to have a persistent OSTree repo
26OSTREE_REPO ?= "${DEPLOY_DIR_IMAGE}/ostree_repo" 26OSTREE_REPO ?= "${DEPLOY_DIR_IMAGE}/ostree_repo"
27# For UPTANE operation, OSTREE_BRANCHNAME must start with "${MACHINE}-"
28OSTREE_BRANCHNAME ?= "${MACHINE}" 27OSTREE_BRANCHNAME ?= "${MACHINE}"
29OSTREE_OSNAME ?= "poky" 28OSTREE_OSNAME ?= "poky"
30OSTREE_INITRAMFS_IMAGE ?= "initramfs-ostree-image" 29OSTREE_INITRAMFS_IMAGE ?= "initramfs-ostree-image"
diff --git a/lib/oeqa/selftest/cases/updater.py b/lib/oeqa/selftest/cases/updater.py
index f55bc34..190d85d 100644
--- a/lib/oeqa/selftest/cases/updater.py
+++ b/lib/oeqa/selftest/cases/updater.py
@@ -141,7 +141,7 @@ class AutoProvTests(OESelftestTestCase):
141 if re.search(layer, result.output) is None: 141 if re.search(layer, result.output) is None:
142 # Assume the directory layout for finding other layers. We could also 142 # Assume the directory layout for finding other layers. We could also
143 # make assumptions by using 'show-layers', but either way, if the 143 # make assumptions by using 'show-layers', but either way, if the
144 # layers we need aren't where we expect them, we are out of like. 144 # layers we need aren't where we expect them, we are out of luck.
145 path = os.path.abspath(os.path.dirname(__file__)) 145 path = os.path.abspath(os.path.dirname(__file__))
146 metadir = path + "/../../../../../" 146 metadir = path + "/../../../../../"
147 self.meta_qemu = metadir + layer 147 self.meta_qemu = metadir + layer
@@ -204,7 +204,7 @@ class RpiTests(OESelftestTestCase):
204 result = runCmd('bitbake-layers show-layers') 204 result = runCmd('bitbake-layers show-layers')
205 # Assume the directory layout for finding other layers. We could also 205 # Assume the directory layout for finding other layers. We could also
206 # make assumptions by using 'show-layers', but either way, if the 206 # make assumptions by using 'show-layers', but either way, if the
207 # layers we need aren't where we expect them, we are out of like. 207 # layers we need aren't where we expect them, we are out of luck.
208 path = os.path.abspath(os.path.dirname(__file__)) 208 path = os.path.abspath(os.path.dirname(__file__))
209 metadir = path + "/../../../../../" 209 metadir = path + "/../../../../../"
210 if re.search(layer_python, result.output) is None: 210 if re.search(layer_python, result.output) is None:
@@ -277,7 +277,7 @@ class GrubTests(OESelftestTestCase):
277 result = runCmd('bitbake-layers show-layers') 277 result = runCmd('bitbake-layers show-layers')
278 # Assume the directory layout for finding other layers. We could also 278 # Assume the directory layout for finding other layers. We could also
279 # make assumptions by using 'show-layers', but either way, if the 279 # make assumptions by using 'show-layers', but either way, if the
280 # layers we need aren't where we expect them, we are out of like. 280 # layers we need aren't where we expect them, we are out of luck.
281 path = os.path.abspath(os.path.dirname(__file__)) 281 path = os.path.abspath(os.path.dirname(__file__))
282 metadir = path + "/../../../../../" 282 metadir = path + "/../../../../../"
283 if re.search(layer_intel, result.output) is None: 283 if re.search(layer_intel, result.output) is None:
@@ -339,7 +339,7 @@ class ImplProvTests(OESelftestTestCase):
339 if re.search(layer, result.output) is None: 339 if re.search(layer, result.output) is None:
340 # Assume the directory layout for finding other layers. We could also 340 # Assume the directory layout for finding other layers. We could also
341 # make assumptions by using 'show-layers', but either way, if the 341 # make assumptions by using 'show-layers', but either way, if the
342 # layers we need aren't where we expect them, we are out of like. 342 # layers we need aren't where we expect them, we are out of luck.
343 path = os.path.abspath(os.path.dirname(__file__)) 343 path = os.path.abspath(os.path.dirname(__file__))
344 metadir = path + "/../../../../../" 344 metadir = path + "/../../../../../"
345 self.meta_qemu = metadir + layer 345 self.meta_qemu = metadir + layer
@@ -409,7 +409,7 @@ class HsmTests(OESelftestTestCase):
409 if re.search(layer, result.output) is None: 409 if re.search(layer, result.output) is None:
410 # Assume the directory layout for finding other layers. We could also 410 # Assume the directory layout for finding other layers. We could also
411 # make assumptions by using 'show-layers', but either way, if the 411 # make assumptions by using 'show-layers', but either way, if the
412 # layers we need aren't where we expect them, we are out of like. 412 # layers we need aren't where we expect them, we are out of luck.
413 path = os.path.abspath(os.path.dirname(__file__)) 413 path = os.path.abspath(os.path.dirname(__file__))
414 metadir = path + "/../../../../../" 414 metadir = path + "/../../../../../"
415 self.meta_qemu = metadir + layer 415 self.meta_qemu = metadir + layer
@@ -527,7 +527,7 @@ class SecondaryTests(OESelftestTestCase):
527 if re.search(layer, result.output) is None: 527 if re.search(layer, result.output) is None:
528 # Assume the directory layout for finding other layers. We could also 528 # Assume the directory layout for finding other layers. We could also
529 # make assumptions by using 'show-layers', but either way, if the 529 # make assumptions by using 'show-layers', but either way, if the
530 # layers we need aren't where we expect them, we are out of like. 530 # layers we need aren't where we expect them, we are out of luck.
531 path = os.path.abspath(os.path.dirname(__file__)) 531 path = os.path.abspath(os.path.dirname(__file__))
532 metadir = path + "/../../../../../" 532 metadir = path + "/../../../../../"
533 self.meta_qemu = metadir + layer 533 self.meta_qemu = metadir + layer
@@ -572,7 +572,7 @@ class PrimaryTests(OESelftestTestCase):
572 if re.search(layer, result.output) is None: 572 if re.search(layer, result.output) is None:
573 # Assume the directory layout for finding other layers. We could also 573 # Assume the directory layout for finding other layers. We could also
574 # make assumptions by using 'show-layers', but either way, if the 574 # make assumptions by using 'show-layers', but either way, if the
575 # layers we need aren't where we expect them, we are out of like. 575 # layers we need aren't where we expect them, we are out of luck.
576 path = os.path.abspath(os.path.dirname(__file__)) 576 path = os.path.abspath(os.path.dirname(__file__))
577 metadir = path + "/../../../../../" 577 metadir = path + "/../../../../../"
578 self.meta_qemu = metadir + layer 578 self.meta_qemu = metadir + layer
diff --git a/recipes-sota/aktualizr/aktualizr-auto-prov.bb b/recipes-sota/aktualizr/aktualizr-auto-prov.bb
index 7f4f2e4..77f8f22 100644
--- a/recipes-sota/aktualizr/aktualizr-auto-prov.bb
+++ b/recipes-sota/aktualizr/aktualizr-auto-prov.bb
@@ -36,7 +36,7 @@ do_install() {
36 aktualizr_toml=${@bb.utils.contains('SOTA_CLIENT_FEATURES', 'secondary-network', 'sota_autoprov_primary.toml', 'sota_autoprov.toml', d)} 36 aktualizr_toml=${@bb.utils.contains('SOTA_CLIENT_FEATURES', 'secondary-network', 'sota_autoprov_primary.toml', 'sota_autoprov.toml', d)}
37 37
38 install -m 0644 ${STAGING_DIR_NATIVE}${libdir}/sota/${aktualizr_toml} \ 38 install -m 0644 ${STAGING_DIR_NATIVE}${libdir}/sota/${aktualizr_toml} \
39 ${D}${libdir}/sota/conf.d/20-${aktualizr_toml}.toml 39 ${D}${libdir}/sota/conf.d/20-${aktualizr_toml}
40 40
41 # deploy SOTA credentials 41 # deploy SOTA credentials
42 if [ -e ${SOTA_PACKED_CREDENTIALS} ]; then 42 if [ -e ${SOTA_PACKED_CREDENTIALS} ]; then
@@ -49,7 +49,7 @@ do_install() {
49 49
50FILES_${PN} = " \ 50FILES_${PN} = " \
51 ${libdir}/sota/conf.d \ 51 ${libdir}/sota/conf.d \
52 ${libdir}/sota/conf.d/20-${aktualizr_toml}.toml \ 52 ${libdir}/sota/conf.d/20-${aktualizr_toml} \
53 ${localstatedir}/sota \ 53 ${localstatedir}/sota \
54 ${localstatedir}/sota/sota_provisioning_credentials.zip \ 54 ${localstatedir}/sota/sota_provisioning_credentials.zip \
55 " 55 "