summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Vacek <patrickvacek@gmail.com>2020-09-04 09:45:51 +0200
committerGitHub <noreply@github.com>2020-09-04 09:45:51 +0200
commit805e2c6f15cebc3dba2431f362b52c508eda8c5f (patch)
tree19677c1d3145d064da883c2211a7c0da56f7fbf9
parentaf3b1dbd6cef901a2a0db8686231b037758d4c86 (diff)
parent79dc91f40bd90b16d2e06e7c9dccf99560db54c9 (diff)
downloadmeta-updater-805e2c6f15cebc3dba2431f362b52c508eda8c5f.tar.gz
Merge pull request #767 from advancedtelematic/feat/dunfell/2020.9
Feat/dunfell/2020.9
-rw-r--r--classes/image_repo_manifest.bbclass7
-rw-r--r--conf/distro/sota.conf.inc2
-rw-r--r--recipes-sota/aktualizr/aktualizr_git.bb8
-rw-r--r--recipes-test/big-update/big-update_1.0.bb2
-rw-r--r--recipes-test/big-update/big-update_2.0.bb2
-rw-r--r--scripts/qemucommand.py5
6 files changed, 18 insertions, 8 deletions
diff --git a/classes/image_repo_manifest.bbclass b/classes/image_repo_manifest.bbclass
index 72dc28f..12f56f0 100644
--- a/classes/image_repo_manifest.bbclass
+++ b/classes/image_repo_manifest.bbclass
@@ -9,10 +9,13 @@
9# For more information, see: 9# For more information, see:
10# https://web.archive.org/web/20161224194009/https://wiki.cyanogenmod.org/w/Doc:_Using_manifests 10# https://web.archive.org/web/20161224194009/https://wiki.cyanogenmod.org/w/Doc:_Using_manifests
11 11
12inherit python3native
13
12# Write build information to target filesystem 14# Write build information to target filesystem
13buildinfo_manifest () { 15buildinfo_manifest () {
14 if [ $(which repo) ]; then 16 repotool=`which repo || true`
15 repo manifest --revision-as-HEAD -o ${IMAGE_ROOTFS}${sysconfdir}/manifest.xml || bbwarn "Android repo tool failed to run; manifest not copied" 17 if [ -n "$repotool" ]; then
18 python3 $repotool manifest --revision-as-HEAD -o ${IMAGE_ROOTFS}${sysconfdir}/manifest.xml || bbwarn "Android repo tool failed to run; manifest not copied"
16 else 19 else
17 bbwarn "Android repo tool not found; manifest not copied." 20 bbwarn "Android repo tool not found; manifest not copied."
18 fi 21 fi
diff --git a/conf/distro/sota.conf.inc b/conf/distro/sota.conf.inc
index 9804694..99035de 100644
--- a/conf/distro/sota.conf.inc
+++ b/conf/distro/sota.conf.inc
@@ -18,4 +18,4 @@ export SOURCE_DATE_EPOCH = "0"
18REPRODUCIBLE_TIMESTAMP_ROOTFS = "0" 18REPRODUCIBLE_TIMESTAMP_ROOTFS = "0"
19 19
20HOSTTOOLS += "git sync sha256sum" 20HOSTTOOLS += "git sync sha256sum"
21HOSTTOOLS_NONFATAL += "java repo python" 21HOSTTOOLS_NONFATAL += "java repo"
diff --git a/recipes-sota/aktualizr/aktualizr_git.bb b/recipes-sota/aktualizr/aktualizr_git.bb
index c01a30f..69beb4b 100644
--- a/recipes-sota/aktualizr/aktualizr_git.bb
+++ b/recipes-sota/aktualizr/aktualizr_git.bb
@@ -17,7 +17,7 @@ PRIVATE_LIBS_${PN}-ptest = "libaktualizr.so libaktualizr_secondary.so"
17PV = "1.0+git${SRCPV}" 17PV = "1.0+git${SRCPV}"
18PR = "7" 18PR = "7"
19 19
20GARAGE_SIGN_PV = "0.7.1-10-ga0a099a" 20GARAGE_SIGN_PV = "0.7.1-22-g1d0d714"
21 21
22SRC_URI = " \ 22SRC_URI = " \
23 gitsm://github.com/advancedtelematic/aktualizr;branch=${BRANCH};name=aktualizr \ 23 gitsm://github.com/advancedtelematic/aktualizr;branch=${BRANCH};name=aktualizr \
@@ -29,10 +29,10 @@ SRC_URI = " \
29 ${@ d.expand("https://tuf-cli-releases.ota.here.com/cli-${GARAGE_SIGN_PV}.tgz;unpack=0;name=garagesign") if not oe.types.boolean(d.getVar('GARAGE_SIGN_AUTOVERSION')) else ''} \ 29 ${@ d.expand("https://tuf-cli-releases.ota.here.com/cli-${GARAGE_SIGN_PV}.tgz;unpack=0;name=garagesign") if not oe.types.boolean(d.getVar('GARAGE_SIGN_AUTOVERSION')) else ''} \
30 " 30 "
31 31
32SRC_URI[garagesign.md5sum] = "e2354fb75ae56c2d253be26617b2bd10" 32SRC_URI[garagesign.md5sum] = "7be214beb64ce4ae443f7a4288b6d491"
33SRC_URI[garagesign.sha256sum] = "2ddb26b19090a42d7aeeda287ed40123ffa3ab55b5dcc4ea4c9320d0a0fd59a0" 33SRC_URI[garagesign.sha256sum] = "b8524a03bb31551889790eca4ed44070f679d33a98b09e8220d7e0e965de68d8"
34 34
35SRCREV = "753c2d73c36e3221f5e7800727d94b5c74c01499" 35SRCREV = "d4811f900c765f3b4e5b9ea76531bad7d830a691"
36BRANCH ?= "master" 36BRANCH ?= "master"
37 37
38S = "${WORKDIR}/git" 38S = "${WORKDIR}/git"
diff --git a/recipes-test/big-update/big-update_1.0.bb b/recipes-test/big-update/big-update_1.0.bb
index 3b1d652..dfb3a96 100644
--- a/recipes-test/big-update/big-update_1.0.bb
+++ b/recipes-test/big-update/big-update_1.0.bb
@@ -7,6 +7,8 @@ FILES_${PN} = "/usr/lib/big-update"
7 7
8DEPENDS = "coreutils-native" 8DEPENDS = "coreutils-native"
9 9
10inherit python3native
11
10do_install() { 12do_install() {
11 install -d ${D}/usr/lib/big-update 13 install -d ${D}/usr/lib/big-update
12 python ${S}/../rand_file.py ${D}/usr/lib/big-update/a-big-file $(numfmt --from=iec 10M) 14 python ${S}/../rand_file.py ${D}/usr/lib/big-update/a-big-file $(numfmt --from=iec 10M)
diff --git a/recipes-test/big-update/big-update_2.0.bb b/recipes-test/big-update/big-update_2.0.bb
index 7cb6e94..6fffbc1 100644
--- a/recipes-test/big-update/big-update_2.0.bb
+++ b/recipes-test/big-update/big-update_2.0.bb
@@ -7,6 +7,8 @@ FILES_${PN} = "/usr/lib/big-update"
7 7
8DEPENDS = "coreutils-native" 8DEPENDS = "coreutils-native"
9 9
10inherit python3native
11
10do_install() { 12do_install() {
11 install -d ${D}/usr/lib/big-update 13 install -d ${D}/usr/lib/big-update
12 python ${S}/../rand_file.py ${D}/usr/lib/big-update/a-big-file $(numfmt --from=iec 12M) 14 python ${S}/../rand_file.py ${D}/usr/lib/big-update/a-big-file $(numfmt --from=iec 12M)
diff --git a/scripts/qemucommand.py b/scripts/qemucommand.py
index 30929ac..9658fcd 100644
--- a/scripts/qemucommand.py
+++ b/scripts/qemucommand.py
@@ -75,7 +75,10 @@ class QemuCommand(object):
75 if args.efi: 75 if args.efi:
76 self.bios = 'OVMF.fd' 76 self.bios = 'OVMF.fd'
77 elif self.enable_u_boot: 77 elif self.enable_u_boot:
78 uboot_path = abspath(join(args.dir, self.machine, 'u-boot-qemux86-64.rom')) 78 if args.bootloader:
79 uboot_path = args.bootloader
80 else:
81 uboot_path = abspath(join(args.dir, self.machine, 'u-boot-qemux86-64.rom'))
79 if self.overlay: 82 if self.overlay:
80 new_uboot_path = self.overlay + '.u-boot.rom' 83 new_uboot_path = self.overlay + '.u-boot.rom'
81 if not exists(self.overlay): 84 if not exists(self.overlay):