summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Vacek <patrickvacek@gmail.com>2018-06-01 15:04:00 +0200
committerPatrick Vacek <patrickvacek@gmail.com>2018-06-04 10:06:06 +0200
commitc1895c1d89dc4cc91cfeb7630239e941e405b64f (patch)
tree2607bad9d924ac0eb895f0eac61c44057fa489eb
parente393c71f6a79825b1e0386fb140272663762dce8 (diff)
parent4c4f51f6269c0bd6243dce81eea049e4a073de30 (diff)
downloadmeta-updater-c1895c1d89dc4cc91cfeb7630239e941e405b64f.tar.gz
Merge remote-tracking branch 'ats/rocko' into bugfix/implicit-and-certs-sumo
-rw-r--r--README.adoc6
-rw-r--r--classes/sota_qemux86-64.bbclass3
-rwxr-xr-xrecipes-sota/aktualizr/aktualizr_git.bb1
-rw-r--r--recipes-sota/ostree/ostree_git.bb6
4 files changed, 7 insertions, 9 deletions
diff --git a/README.adoc b/README.adoc
index c47dd1d..75ee9ae 100644
--- a/README.adoc
+++ b/README.adoc
@@ -53,12 +53,6 @@ Although `aglsetup.sh` hooks provide reasonable defaults for SOTA-related variab
53 53
54=== Build problems 54=== Build problems
55 55
56Multilib systems may require adding this line to `local.conf`:
57
58....
59HOSTTOOLS += "x86_64-linux-gnu-gcc"
60....
61
62Ubuntu users that encounter an error due to missing `Python.h` should install `libpython2.7-dev` on their host machine. 56Ubuntu users that encounter an error due to missing `Python.h` should install `libpython2.7-dev` on their host machine.
63 57
64== Supported boards 58== Supported boards
diff --git a/classes/sota_qemux86-64.bbclass b/classes/sota_qemux86-64.bbclass
index 15b2043..82efe52 100644
--- a/classes/sota_qemux86-64.bbclass
+++ b/classes/sota_qemux86-64.bbclass
@@ -9,3 +9,6 @@ OSTREE_INITRAMFS_FSTYPES ?= "ext4.gz"
9OSTREE_KERNEL_ARGS ?= "ramdisk_size=16384 rw rootfstype=ext4 rootwait rootdelay=2 ostree_root=/dev/hda" 9OSTREE_KERNEL_ARGS ?= "ramdisk_size=16384 rw rootfstype=ext4 rootwait rootdelay=2 ostree_root=/dev/hda"
10 10
11IMAGE_ROOTFS_EXTRA_SPACE = "${@bb.utils.contains('DISTRO_FEATURES', 'sota', '65536', '', d)}" 11IMAGE_ROOTFS_EXTRA_SPACE = "${@bb.utils.contains('DISTRO_FEATURES', 'sota', '65536', '', d)}"
12
13# fix for u-boot/swig build issue
14HOSTTOOLS_NONFATAL += "x86_64-linux-gnu-gcc"
diff --git a/recipes-sota/aktualizr/aktualizr_git.bb b/recipes-sota/aktualizr/aktualizr_git.bb
index 3a3ca56..8dc4b31 100755
--- a/recipes-sota/aktualizr/aktualizr_git.bb
+++ b/recipes-sota/aktualizr/aktualizr_git.bb
@@ -99,6 +99,7 @@ FILES_${PN}-examples = " \
99 " 99 "
100 100
101FILES_${PN}-host-tools = " \ 101FILES_${PN}-host-tools = " \
102 ${bindir}/aktualizr-repo \
102 ${bindir}/aktualizr_cert_provider \ 103 ${bindir}/aktualizr_cert_provider \
103 ${bindir}/aktualizr_implicit_writer \ 104 ${bindir}/aktualizr_implicit_writer \
104 ${bindir}/garage-deploy \ 105 ${bindir}/garage-deploy \
diff --git a/recipes-sota/ostree/ostree_git.bb b/recipes-sota/ostree/ostree_git.bb
index cdcb485..afb767f 100644
--- a/recipes-sota/ostree/ostree_git.bb
+++ b/recipes-sota/ostree/ostree_git.bb
@@ -2,7 +2,7 @@ SUMMARY = "Tool for managing bootable, immutable, versioned filesystem trees"
2LICENSE = "GPLv2+" 2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2" 3LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
4 4
5inherit autotools-brokensep pkgconfig systemd gobject-introspection 5inherit autotools pkgconfig systemd gobject-introspection
6 6
7INHERIT_remove_class-native = "systemd" 7INHERIT_remove_class-native = "systemd"
8 8
@@ -11,7 +11,7 @@ SRC_URI = "gitsm://github.com/ostreedev/ostree.git;branch=master"
11SRCREV="854a823e05d6fe8b610c02c2a71eaeb2bf1e98a6" 11SRCREV="854a823e05d6fe8b610c02c2a71eaeb2bf1e98a6"
12 12
13PV = "v2017.13" 13PV = "v2017.13"
14PR = "1" 14PR = "2"
15 15
16S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
17 17
@@ -49,7 +49,7 @@ export STAGING_LIBDIR
49 49
50do_configure() { 50do_configure() {
51 unset docdir 51 unset docdir
52 NOCONFIGURE=1 ./autogen.sh 52 NOCONFIGURE=1 "${S}/autogen.sh"
53 oe_runconf 53 oe_runconf
54} 54}
55 55