diff options
author | antznin <agodard@witekio.com> | 2020-07-03 15:07:36 +0200 |
---|---|---|
committer | antznin <agodard@witekio.com> | 2020-07-03 15:33:18 +0200 |
commit | 1d358ad5344aa40f648f4f5604e2e70848012741 (patch) | |
tree | cb9583787eefc362d67daa8cb342cfa775307863 | |
parent | b75914c3a82148661f4ce36a64e53d5a0d77c324 (diff) | |
download | meta-updater-1d358ad5344aa40f648f4f5604e2e70848012741.tar.gz |
ostree-kernel-initramfs: fix devicetree deployment
Following the changes in ostree's deployment of the kernel, initramfs
and devicetree in /lib/modules/$kver, the deployment method of the
device tree also changed. Instead of picking the first device tree it
finds at a given location, ostree looks at a file named devicetree, next
to kernel and initramfs in /lib/modules/$kver.
This commit modifies ostree-kernel-initramfs to deploy the devicetree
from the sota-defined variable OSTREE_DEVICETREE. It will pick the
first one from the list of device trees that OSTREE_DEVICETREE defines,
and copy it to /lib/modules/$kver. Note that since OSTREE_DEVICETREE
equals to KERNEL_DEVICETREE when it isn't explicitly defined, it could
indeed be a list of device trees.
Signed-off-by: antznin <agodard@witekio.com>
-rw-r--r-- | recipes-sota/ostree-kernel-initramfs/ostree-kernel-initramfs_0.0.1.bb | 5 |
1 files changed, 4 insertions, 1 deletions
diff --git a/recipes-sota/ostree-kernel-initramfs/ostree-kernel-initramfs_0.0.1.bb b/recipes-sota/ostree-kernel-initramfs/ostree-kernel-initramfs_0.0.1.bb index 6159f00..136bb22 100644 --- a/recipes-sota/ostree-kernel-initramfs/ostree-kernel-initramfs_0.0.1.bb +++ b/recipes-sota/ostree-kernel-initramfs/ostree-kernel-initramfs_0.0.1.bb | |||
@@ -14,7 +14,9 @@ ALLOW_EMPTY_ostree-devicetrees = "1" | |||
14 | 14 | ||
15 | FILES_ostree-kernel = "${nonarch_base_libdir}/modules/*/vmlinuz" | 15 | FILES_ostree-kernel = "${nonarch_base_libdir}/modules/*/vmlinuz" |
16 | FILES_ostree-initramfs = "${nonarch_base_libdir}/modules/*/initramfs.img" | 16 | FILES_ostree-initramfs = "${nonarch_base_libdir}/modules/*/initramfs.img" |
17 | FILES_ostree-devicetrees = "${nonarch_base_libdir}/modules/*/dtb/*" | 17 | FILES_ostree-devicetrees = "${nonarch_base_libdir}/modules/*/dtb/* \ |
18 | ${nonarch_base_libdir}/modules/*/devicetree \ | ||
19 | " | ||
18 | 20 | ||
19 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 21 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
20 | 22 | ||
@@ -45,6 +47,7 @@ do_install() { | |||
45 | dts_file_basename=$(basename $dts_file) | 47 | dts_file_basename=$(basename $dts_file) |
46 | cp ${DEPLOY_DIR_IMAGE}/$dts_file_basename $kerneldir/dtb/$dts_file_basename | 48 | cp ${DEPLOY_DIR_IMAGE}/$dts_file_basename $kerneldir/dtb/$dts_file_basename |
47 | done | 49 | done |
50 | cp $kerneldir/dtb/$(basename $(echo ${OSTREE_DEVICETREE} | awk '{print $1}')) $kerneldir/devicetree | ||
48 | fi | 51 | fi |
49 | fi | 52 | fi |
50 | } | 53 | } |