diff options
author | cajun-rat <p@beta16.co.uk> | 2017-04-24 09:39:01 +0200 |
---|---|---|
committer | GitHub <noreply@github.com> | 2017-04-24 09:39:01 +0200 |
commit | 4f1a20b93657c68ed60b181369a421f27289714d (patch) | |
tree | b918d83a006c03b46a4f536ccf7f10d8a8ca51b8 | |
parent | 39049ace3ce0636174f606626aa5e366c7033b35 (diff) | |
parent | fe58cc2394283801d7fecc329a8d6e278373938a (diff) | |
download | meta-updater-4f1a20b93657c68ed60b181369a421f27289714d.tar.gz |
Merge pull request #55 from advancedtelematic/switchupdater
Merge changes required by AGL
-rw-r--r-- | classes/image_types_ota.bbclass | 2 | ||||
-rw-r--r-- | conf/distro/sota.conf.inc | 13 | ||||
-rw-r--r-- | recipes-core/images/initramfs-ostree-image.bb | 1 |
3 files changed, 8 insertions, 8 deletions
diff --git a/classes/image_types_ota.bbclass b/classes/image_types_ota.bbclass index 819a83c..cb71899 100644 --- a/classes/image_types_ota.bbclass +++ b/classes/image_types_ota.bbclass | |||
@@ -9,6 +9,8 @@ | |||
9 | 9 | ||
10 | inherit image | 10 | inherit image |
11 | 11 | ||
12 | OSTREE_BOOTLOADER ??= 'u-boot' | ||
13 | |||
12 | IMAGE_DEPENDS_otaimg = "e2fsprogs-native:do_populate_sysroot \ | 14 | IMAGE_DEPENDS_otaimg = "e2fsprogs-native:do_populate_sysroot \ |
13 | ${@'grub:do_populate_sysroot' if d.getVar('OSTREE_BOOTLOADER', True) == 'grub' else ''} \ | 15 | ${@'grub:do_populate_sysroot' if d.getVar('OSTREE_BOOTLOADER', True) == 'grub' else ''} \ |
14 | ${@'virtual/bootloader:do_deploy' if d.getVar('OSTREE_BOOTLOADER', True) == 'u-boot' else ''}" | 16 | ${@'virtual/bootloader:do_deploy' if d.getVar('OSTREE_BOOTLOADER', True) == 'u-boot' else ''}" |
diff --git a/conf/distro/sota.conf.inc b/conf/distro/sota.conf.inc index a7d3aae..e334df0 100644 --- a/conf/distro/sota.conf.inc +++ b/conf/distro/sota.conf.inc | |||
@@ -5,19 +5,16 @@ IMAGE_INSTALL_append = " ostree os-release rvi-sota-client" | |||
5 | 5 | ||
6 | # live image for OSTree-enabled systems | 6 | # live image for OSTree-enabled systems |
7 | IMAGE_CLASSES += "image_types_ostree image_types_ota" | 7 | IMAGE_CLASSES += "image_types_ostree image_types_ota" |
8 | IMAGE_FSTYPES += "ostreepush otaimg wic" | 8 | IMAGE_FSTYPES += "ostreepush otaimg" |
9 | |||
10 | # if don't build wic image unless IMAGE_BOOT_FILES is set. Prevents build from failing | ||
11 | # on machines that don't support updater yet | ||
12 | IMAGE_FSTYPES += "${@' wic' if (d.getVar("IMAGE_BOOT_FILES", True)) else ''}" | ||
9 | WKS_FILE ?= "sdimage-sota.wks" | 13 | WKS_FILE ?= "sdimage-sota.wks" |
10 | do_image_wic[depends] += "${IMAGE_BASENAME}:do_image_otaimg" | 14 | do_image_wic[depends] += "${IMAGE_BASENAME}:do_image_otaimg" |
11 | 15 | ||
12 | EXTRA_IMAGEDEPENDS += " parted-native mtools-native dosfstools-native" | 16 | EXTRA_IMAGEDEPENDS += " parted-native mtools-native dosfstools-native" |
13 | 17 | ||
14 | # No working WKS for Raspberry Pi yet | ||
15 | IMAGE_FSTYPES_remove_raspberrypi3 = "wic" | ||
16 | IMAGE_FSTYPES_remove_raspberrypi2 = "wic" | ||
17 | |||
18 | # QEMU emulation uses plain otaimg, no wic needed | ||
19 | IMAGE_FSTYPES_remove_qemux86-64 = "wic" | ||
20 | |||
21 | # Please redefine OSTREE_REPO in order to have a persistent OSTree repo | 18 | # Please redefine OSTREE_REPO in order to have a persistent OSTree repo |
22 | OSTREE_REPO ?= "${DEPLOY_DIR_IMAGE}/ostree_repo" | 19 | OSTREE_REPO ?= "${DEPLOY_DIR_IMAGE}/ostree_repo" |
23 | OSTREE_BRANCHNAME ?= "ota-${MACHINE}" | 20 | OSTREE_BRANCHNAME ?= "ota-${MACHINE}" |
diff --git a/recipes-core/images/initramfs-ostree-image.bb b/recipes-core/images/initramfs-ostree-image.bb index 8eea07c..509b74d 100644 --- a/recipes-core/images/initramfs-ostree-image.bb +++ b/recipes-core/images/initramfs-ostree-image.bb | |||
@@ -15,6 +15,7 @@ LICENSE = "MIT" | |||
15 | 15 | ||
16 | IMAGE_FSTYPES = "ext4.gz" | 16 | IMAGE_FSTYPES = "ext4.gz" |
17 | IMAGE_FSTYPES_append_arm = " ext4.gz.u-boot" | 17 | IMAGE_FSTYPES_append_arm = " ext4.gz.u-boot" |
18 | IMAGE_CLASSES_append_arm = " image_types_uboot" | ||
18 | 19 | ||
19 | inherit core-image | 20 | inherit core-image |
20 | 21 | ||