diff options
author | cajun-rat <p@beta16.co.uk> | 2017-06-12 17:19:08 +0200 |
---|---|---|
committer | GitHub <noreply@github.com> | 2017-06-12 17:19:08 +0200 |
commit | 2d49a25a814e52d114c403b7033e6e31b553004b (patch) | |
tree | 911aedef1c2a56460271adcd9637d4831d079d3f | |
parent | c1d3335e548c4d54414791cc8197b652da84e9a3 (diff) | |
parent | 1e068cd654bc56833b471d2157ce5b53837ebe96 (diff) | |
download | meta-updater-2d49a25a814e52d114c403b7033e6e31b553004b.tar.gz |
Merge pull request #81 from chbae/pyro
Arrange recipe for pyro
-rw-r--r-- | recipes-bsp/u-boot/u-boot_2016.11.bb | 13 | ||||
-rw-r--r-- | scripts/lib/wic/plugins/source/otaimage.py | 11 |
2 files changed, 6 insertions, 18 deletions
diff --git a/recipes-bsp/u-boot/u-boot_2016.11.bb b/recipes-bsp/u-boot/u-boot_2016.11.bb deleted file mode 100644 index e6e1fcf..0000000 --- a/recipes-bsp/u-boot/u-boot_2016.11.bb +++ /dev/null | |||
@@ -1,13 +0,0 @@ | |||
1 | require recipes-bsp/u-boot/u-boot.inc | ||
2 | |||
3 | DEPENDS += "dtc-native" | ||
4 | |||
5 | SRCREV = "5ea3e51fc481613a8dee8c02848d1b42c81ad892" | ||
6 | |||
7 | PV = "v2016.11+git${SRCPV}" | ||
8 | |||
9 | #This patch is not compliant with u-boot 2016.11 | ||
10 | #Version of u-boot from yocto 2.2 Morty is 2016.03 from: | ||
11 | # meta/recipes-bsp/u-boot/u-boot_2016.03.bb | ||
12 | SRC_URI_remove_raspberrypi3 = "file://0003-Include-lowlevel_init.o-for-rpi2.patch" | ||
13 | SRC_URI_remove_raspberrypi2 = "file://0003-Include-lowlevel_init.o-for-rpi2.patch" | ||
diff --git a/scripts/lib/wic/plugins/source/otaimage.py b/scripts/lib/wic/plugins/source/otaimage.py index dc507a8..eef0bb4 100644 --- a/scripts/lib/wic/plugins/source/otaimage.py +++ b/scripts/lib/wic/plugins/source/otaimage.py | |||
@@ -15,11 +15,12 @@ | |||
15 | # 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA. | 15 | # 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA. |
16 | # | 16 | # |
17 | 17 | ||
18 | import logging | ||
18 | import os | 19 | import os |
20 | import sys | ||
19 | 21 | ||
20 | from wic import msger | ||
21 | from wic.pluginbase import SourcePlugin | 22 | from wic.pluginbase import SourcePlugin |
22 | from wic.utils.oe.misc import get_bitbake_var | 23 | from wic.utils.misc import get_bitbake_var |
23 | 24 | ||
24 | class OTAImagePlugin(SourcePlugin): | 25 | class OTAImagePlugin(SourcePlugin): |
25 | """ | 26 | """ |
@@ -57,12 +58,12 @@ class OTAImagePlugin(SourcePlugin): | |||
57 | """ | 58 | """ |
58 | bootimg_dir = get_bitbake_var("DEPLOY_DIR_IMAGE") | 59 | bootimg_dir = get_bitbake_var("DEPLOY_DIR_IMAGE") |
59 | if not bootimg_dir: | 60 | if not bootimg_dir: |
60 | msger.error("Couldn't find DEPLOY_DIR_IMAGE, exiting\n") | 61 | logger.error("Couldn't find DEPLOY_DIR_IMAGE, exiting\n") |
61 | 62 | ||
62 | msger.debug('Bootimg dir: %s' % bootimg_dir) | 63 | logger.debug('Bootimg dir: %s' % bootimg_dir) |
63 | 64 | ||
64 | src = bootimg_dir + "/" + get_bitbake_var("IMAGE_LINK_NAME") + ".otaimg" | 65 | src = bootimg_dir + "/" + get_bitbake_var("IMAGE_LINK_NAME") + ".otaimg" |
65 | 66 | ||
66 | msger.debug('Preparing partition using image %s' % (src)) | 67 | logger.debug('Preparing partition using image %s' % (src)) |
67 | part.prepare_rootfs_from_fs_image(cr_workdir, src, "") | 68 | part.prepare_rootfs_from_fs_image(cr_workdir, src, "") |
68 | 69 | ||