summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Vacek <patrickvacek@gmail.com>2018-04-27 12:08:25 +0200
committerPatrick Vacek <patrickvacek@gmail.com>2018-05-03 10:55:39 +0200
commit3f4856c1aabdc04935020f51fa18dd510f84a69c (patch)
treec6143af7966db6135626e5e808215aaba254331c
parent1f3231cbc3257eaebbf100df10b2ac2e70dd6671 (diff)
downloadmeta-updater-3f4856c1aabdc04935020f51fa18dd510f84a69c.tar.gz
Provide recipe to disable sending ip (PRO-5297).
Obviates the need for SOTA_CLIENT_FEATURES = "disable_send_ip".
-rw-r--r--recipes-sota/config/aktualizr-disable-send-ip.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-sota/config/aktualizr-disable-send-ip.bb b/recipes-sota/config/aktualizr-disable-send-ip.bb
new file mode 100644
index 0000000..32c55f3
--- /dev/null
+++ b/recipes-sota/config/aktualizr-disable-send-ip.bb
@@ -0,0 +1,23 @@
1SUMMARY = "Disable IP reporting in Aktualizr"
2DESCRIPTION = "Configures aktualizr to disable IP reporting to the server"
3HOMEPAGE = "https://github.com/advancedtelematic/aktualizr"
4SECTION = "base"
5LICENSE = "MPL-2.0"
6LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE;md5=9741c346eef56131163e13b9db1241b3"
7
8DEPENDS = "aktualizr "
9SRC_URI = " \
10 file://LICENSE \
11 "
12
13do_install_append () {
14 install -m 0700 -d ${D}${libdir}/sota/conf.d
15 echo "[telemetry]\nreport_network = false\n" > ${D}${libdir}/sota/conf.d/disable-send-ip.toml
16}
17
18FILES_${PN} = " \
19 ${libdir}/sota/conf.d/disable-send-ip.toml \
20 "
21
22# vim:set ts=4 sw=4 sts=4 expandtab:
23