summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Luck <ben+qa@advancedtelematic.com>2018-09-04 14:21:15 +0200
committerGitHub <noreply@github.com>2018-09-04 14:21:15 +0200
commit15305e9bf798a3fbeba46150df730d3aaf6ce058 (patch)
tree1f73f0bfa53884803729f53cbaaed9096956086c
parentf00e6ac0a91eeb54b1e6039552eb038853bdcc1e (diff)
parent33ec42b4020ff53b46043531a6772c7258b6b34f (diff)
downloadmeta-updater-15305e9bf798a3fbeba46150df730d3aaf6ce058.tar.gz
Merge pull request #377 from advancedtelematic/bugfix/lshw-aktualizr-etc-rocko
Bugfix/lshw aktualizr etc rocko @patrickvacek Looks good to me :)
-rwxr-xr-xrecipes-sota/aktualizr/aktualizr_git.bb2
-rw-r--r--recipes-support/lshw/files/ldflags.patch4
-rw-r--r--recipes-support/lshw/lshw_02.17.bb (renamed from recipes-support/lshw/lshw_02.16.bb)6
-rw-r--r--scripts/qemucommand.py2
4 files changed, 7 insertions, 7 deletions
diff --git a/recipes-sota/aktualizr/aktualizr_git.bb b/recipes-sota/aktualizr/aktualizr_git.bb
index bf098ad..9369cbe 100755
--- a/recipes-sota/aktualizr/aktualizr_git.bb
+++ b/recipes-sota/aktualizr/aktualizr_git.bb
@@ -27,7 +27,7 @@ SRC_URI = " \
27 file://aktualizr-secondary.socket \ 27 file://aktualizr-secondary.socket \
28 file://aktualizr-serialcan.service \ 28 file://aktualizr-serialcan.service \
29 " 29 "
30SRCREV = "a94a15e31f3b973966b1afc9081fc1b17a3b9d48" 30SRCREV = "062ab7756c375ee2c913d3197cafe4ee2f97ef2a"
31BRANCH ?= "master" 31BRANCH ?= "master"
32 32
33S = "${WORKDIR}/git" 33S = "${WORKDIR}/git"
diff --git a/recipes-support/lshw/files/ldflags.patch b/recipes-support/lshw/files/ldflags.patch
index 83e0410..d95699d 100644
--- a/recipes-support/lshw/files/ldflags.patch
+++ b/recipes-support/lshw/files/ldflags.patch
@@ -1,6 +1,6 @@
1diff -Naur /home/anton/lshw-old/src/Makefile lshw-B.02.16/src/Makefile 1diff -Naur /home/anton/lshw-old/src/Makefile lshw-B.02.17/src/Makefile
2--- /home/anton/lshw-old/src/Makefile 2017-02-07 16:21:52.554738182 +0100 2--- /home/anton/lshw-old/src/Makefile 2017-02-07 16:21:52.554738182 +0100
3+++ lshw-B.02.16/src/Makefile 2017-02-07 16:22:45.578588072 +0100 3+++ lshw-B.02.17/src/Makefile 2017-02-07 16:22:45.578588072 +0100
4@@ -25,9 +25,9 @@ 4@@ -25,9 +25,9 @@
5 ifeq ($(SQLITE), 1) 5 ifeq ($(SQLITE), 1)
6 CXXFLAGS+= -DSQLITE $(shell pkg-config --cflags sqlite3) 6 CXXFLAGS+= -DSQLITE $(shell pkg-config --cflags sqlite3)
diff --git a/recipes-support/lshw/lshw_02.16.bb b/recipes-support/lshw/lshw_02.17.bb
index 99901ff..1ecc4c1 100644
--- a/recipes-support/lshw/lshw_02.16.bb
+++ b/recipes-support/lshw/lshw_02.17.bb
@@ -9,7 +9,7 @@ SUMMARY = "Hardware lister"
9HOMEPAGE = "http://ezix.org/project/wiki/HardwareLiSter" 9HOMEPAGE = "http://ezix.org/project/wiki/HardwareLiSter"
10SECTION = "console/tools" 10SECTION = "console/tools"
11LICENSE = "GPLv2+" 11LICENSE = "GPLv2+"
12LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" 12LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
13DEPENDS = "pciutils \ 13DEPENDS = "pciutils \
14 usbutils" 14 usbutils"
15COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux" 15COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
@@ -19,8 +19,8 @@ SRC_URI="http://ezix.org/software/files/lshw-B.${PV}.tar.gz \
19 file://ldflags.patch \ 19 file://ldflags.patch \
20 " 20 "
21 21
22SRC_URI[md5sum] = "67479167add605e8f001097c30e96d0d" 22SRC_URI[md5sum] = "a5feb796cb302850eaf5b4530888e3ed"
23SRC_URI[sha256sum] = "809882429555b93259785cc261dbff04c16c93d064db5f445a51945bc47157cb" 23SRC_URI[sha256sum] = "eb9cc053fa0f1e78685cb695596e73931bfb55d2377e3bc3b8b94aff4c5a489c"
24 24
25S="${WORKDIR}/lshw-B.${PV}" 25S="${WORKDIR}/lshw-B.${PV}"
26 26
diff --git a/scripts/qemucommand.py b/scripts/qemucommand.py
index 4918314..86362f7 100644
--- a/scripts/qemucommand.py
+++ b/scripts/qemucommand.py
@@ -115,7 +115,7 @@ class QemuCommand(object):
115 else: 115 else:
116 cmdline.append('-nographic') 116 cmdline.append('-nographic')
117 if self.kvm: 117 if self.kvm:
118 cmdline.append('-enable-kvm') 118 cmdline += ['-enable-kvm', '-cpu', 'host']
119 else: 119 else:
120 cmdline += ['-cpu', 'Haswell'] 120 cmdline += ['-cpu', 'Haswell']
121 if self.overlay: 121 if self.overlay: