summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRicardo Salveti <ricardo@opensourcefoundries.com>2018-05-04 23:04:42 -0300
committerPatrick Vacek <patrickvacek@gmail.com>2018-10-10 12:24:38 +0200
commit310eddc80f2866bad4988dd91ee5ac6df1442de7 (patch)
tree73d988523492f710573d12578e74dbb2b5af189a
parent16dbe39af34a74576929bcf5ebebe66a10bfbc7a (diff)
downloadmeta-updater-310eddc80f2866bad4988dd91ee5ac6df1442de7.tar.gz
ostree: improve package split logic and define extra packages
Define extra packages to cover the bash-completion and dracut related files, as they are not necessarily required by ostree. Signed-off-by: Ricardo Salveti <ricardo@opensourcefoundries.com>
-rw-r--r--recipes-sota/ostree/ostree_git.bb34
1 files changed, 17 insertions, 17 deletions
diff --git a/recipes-sota/ostree/ostree_git.bb b/recipes-sota/ostree/ostree_git.bb
index dc31efe..6fa6ad4 100644
--- a/recipes-sota/ostree/ostree_git.bb
+++ b/recipes-sota/ostree/ostree_git.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "https://ostree.readthedocs.io/en/latest/"
3LICENSE = "LGPLv2+" 3LICENSE = "LGPLv2+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2" 4LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
5 5
6inherit autotools pkgconfig systemd gobject-introspection 6inherit autotools pkgconfig systemd bash-completion gobject-introspection
7 7
8SRC_URI = "gitsm://github.com/ostreedev/ostree.git;branch=master" 8SRC_URI = "gitsm://github.com/ostreedev/ostree.git;branch=master"
9 9
@@ -18,7 +18,7 @@ BBCLASSEXTEND = "native"
18 18
19DEPENDS += "attr libarchive libcap glib-2.0 gpgme libgsystem fuse e2fsprogs curl xz" 19DEPENDS += "attr libarchive libcap glib-2.0 gpgme libgsystem fuse e2fsprogs curl xz"
20DEPENDS += "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" 20DEPENDS += "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
21RDEPENDS_${PN} = "bash" 21RDEPENDS_${PN}-dracut = "bash"
22 22
23CFLAGS_append = " -Wno-error=missing-prototypes" 23CFLAGS_append = " -Wno-error=missing-prototypes"
24EXTRA_OECONF = "--disable-gtk-doc --disable-man --with-smack --with-builtin-grub2-mkconfig --with-curl --without-soup" 24EXTRA_OECONF = "--disable-gtk-doc --disable-man --with-smack --with-builtin-grub2-mkconfig --with-curl --without-soup"
@@ -35,8 +35,6 @@ do_configure[vardeps] += "SYSROOT_DIR"
35 35
36SYSTEMD_SERVICE_${PN} = "ostree-prepare-root.service ostree-remount.service" 36SYSTEMD_SERVICE_${PN} = "ostree-prepare-root.service ostree-remount.service"
37 37
38FILES_${PN} += "${libdir}/ostree/ ${libdir}/ostbuild"
39
40export BUILD_SYS 38export BUILD_SYS
41export HOST_SYS 39export HOST_SYS
42export STAGING_INCDIR 40export STAGING_INCDIR
@@ -51,19 +49,21 @@ do_install_append_class-native() {
51 create_wrapper ${D}${bindir}/ostree OSTREE_GRUB2_EXEC="${STAGING_LIBDIR_NATIVE}/ostree/ostree-grub-generator" 49 create_wrapper ${D}${bindir}/ostree OSTREE_GRUB2_EXEC="${STAGING_LIBDIR_NATIVE}/ostree/ostree-grub-generator"
52} 50}
53 51
54 52PACKAGES += " \
55FILES_${PN} += " \ 53 ${PN}-switchroot \
56 ${@bb.utils.contains('DISTRO_FEATURES','systemd','${libdir}/dracut', '', d)} \ 54 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'ostree-dracut', '', d)} \
57 ${datadir}/gir-1.0 \
58 ${datadir}/gir-1.0/OSTree-1.0.gir \
59 ${libdir}/girepository-1.0 \
60 ${libdir}/girepository-1.0/OSTree-1.0.typelib \
61 ${libdir}/tmpfiles.d/ostree-tmpfiles.conf \
62 ${datadir}/bash-completion/completions/ostree \
63 ${systemd_unitdir}/system-generators/ostree-system-generator \
64" 55"
65 56
66PACKAGES =+ "${PN}-switchroot" 57FILES_${PN} = "${bindir} \
67 58 ${sysconfdir}/ostree \
59 ${datadir}/ostree \
60 ${libdir}/*.so.* \
61 ${libdir}/ostree/ostree-grub-generator \
62 ${libdir}/ostree/ostree-remount \
63 ${libdir}/girepository-1.0/* \
64 ${@bb.utils.contains('DISTRO_FEATURES','systemd','${libdir}/tmpfiles.d', '', d)} \
65 ${@bb.utils.contains('DISTRO_FEATURES','systemd','${systemd_unitdir}/system-generators', '', d)} \
66"
67FILES_${PN}-dev += " ${datadir}/gir-1.0"
68FILES_${PN}-dracut = "${sysconfdir}/dracut.conf.d ${libdir}/dracut"
68FILES_${PN}-switchroot = "${libdir}/ostree/ostree-prepare-root" 69FILES_${PN}-switchroot = "${libdir}/ostree/ostree-prepare-root"
69RDEPENDS_${PN}-switchroot = ""