summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Vacek <patrickvacek@gmail.com>2018-10-10 09:08:47 +0200
committerGitHub <noreply@github.com>2018-10-10 09:08:47 +0200
commitf855696de9d4bdecd2374eefcd11898fcb529b50 (patch)
tree20d1646797a3c72c2b20b1a30c59ba07f27d8875
parent751e8b6e46acc957b6ec47c30868835be4c89d52 (diff)
parentba1181e2fc9afe7a913df7fd5e2f55e2e7ae99f4 (diff)
downloadmeta-updater-f855696de9d4bdecd2374eefcd11898fcb529b50.tar.gz
Merge pull request #403 from agners/drop-libgsystem
Drop libgsystem
-rw-r--r--recipes-sota/ostree/ostree_git.bb2
-rw-r--r--recipes-support/libgsystem/libgsystem_git.bb40
2 files changed, 1 insertions, 41 deletions
diff --git a/recipes-sota/ostree/ostree_git.bb b/recipes-sota/ostree/ostree_git.bb
index 501d636..3e3c951 100644
--- a/recipes-sota/ostree/ostree_git.bb
+++ b/recipes-sota/ostree/ostree_git.bb
@@ -15,7 +15,7 @@ S = "${WORKDIR}/git"
15 15
16BBCLASSEXTEND = "native" 16BBCLASSEXTEND = "native"
17 17
18DEPENDS += "attr bison-native libarchive libcap glib-2.0 gpgme libgsystem fuse e2fsprogs curl xz" 18DEPENDS += "attr bison-native libarchive libcap glib-2.0 gpgme fuse e2fsprogs curl xz"
19DEPENDS += "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" 19DEPENDS += "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
20RDEPENDS_${PN}-dracut = "bash" 20RDEPENDS_${PN}-dracut = "bash"
21 21
diff --git a/recipes-support/libgsystem/libgsystem_git.bb b/recipes-support/libgsystem/libgsystem_git.bb
deleted file mode 100644
index e2b362f..0000000
--- a/recipes-support/libgsystem/libgsystem_git.bb
+++ /dev/null
@@ -1,40 +0,0 @@
1SUMMARY = "GIO-based library, targeted primarily for use by operating system components"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
4
5SRC_URI = "gitsm://github.com/GNOME/libgsystem.git"
6SRCREV="d606bec68ddfea78de4b03c3f3568afb71bdc1ce"
7
8S = "${WORKDIR}/git"
9
10inherit autotools-brokensep gobject-introspection
11
12DEPENDS += "attr glib-2.0 pkgconfig libcap gtk-doc-native gpgme"
13RDEPENDS_${PN} = "xz "
14RDEPENDS_${PN}_append = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', ' systemd', '', d)}"
15
16RDEPENDS_${PN}_remove_class-native = "systemd-native"
17
18BBCLASSEXTEND = "native"
19
20export STAGING_INCDIR
21export STAGING_LIBDIR
22
23do_configure() {
24 #NOCONFIGURE=true ./autogen.sh
25 autoreconf -vfi
26 oe_runconf
27}
28
29do_compile_prepend() {
30 export BUILD_SYS="${BUILD_SYS}"
31 export HOST_SYS="${HOST_SYS}"
32}
33
34FILES_${PN} += " \
35 ${datadir} \
36 ${datadir}/gir-1.0 \
37 ${datadir}/gir-1.0/GSystem-1.0.gir \
38 ${libdir}/girepository-1.0/ \
39 ${libdir}/girepository-1.0/GSystem-1.0.typelib \
40"