summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlbonn <lbonn@users.noreply.github.com>2020-06-18 13:17:59 +0200
committerGitHub <noreply@github.com>2020-06-18 13:17:59 +0200
commit291facdac4cc710551b69297f9c958a32bf1e96b (patch)
tree39494d138ebe7ddf1066304d29dd154b278ad083
parent5d46e7dfa4430e9958fb651a3fb5b4d6148df0b0 (diff)
parentad341f199052427f3d96705cfe6fc3f035480607 (diff)
downloadmeta-updater-291facdac4cc710551b69297f9c958a32bf1e96b.tar.gz
Merge pull request #735 from advancedtelematic/test/OTA-4838/mem-binary-update
Add recipe to build images with binary primaries
-rw-r--r--recipes-sota/config/aktualizr-binary-pacman.bb21
-rw-r--r--recipes-sota/config/files/10-pacman.toml2
2 files changed, 23 insertions, 0 deletions
diff --git a/recipes-sota/config/aktualizr-binary-pacman.bb b/recipes-sota/config/aktualizr-binary-pacman.bb
new file mode 100644
index 0000000..36bafb3
--- /dev/null
+++ b/recipes-sota/config/aktualizr-binary-pacman.bb
@@ -0,0 +1,21 @@
1DESCRIPTION = "Configure aktualizr with a binary package manager"
2LICENSE = "MPL-2.0"
3LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7f619bab123dad"
4
5inherit allarch
6
7SRC_URI = "\
8 file://10-pacman.toml \
9 "
10
11FILES_${PN} = " \
12 ${libdir}/sota/conf.d \
13 ${libdir}/sota/conf.d/10-pacman.toml \
14 "
15
16PR = "1"
17
18do_install() {
19 install -m 0700 -d ${D}${libdir}/sota/conf.d
20 install -m 0644 ${WORKDIR}/10-pacman.toml ${D}${libdir}/sota/conf.d/10-pacman.toml
21}
diff --git a/recipes-sota/config/files/10-pacman.toml b/recipes-sota/config/files/10-pacman.toml
new file mode 100644
index 0000000..a24fd39
--- /dev/null
+++ b/recipes-sota/config/files/10-pacman.toml
@@ -0,0 +1,2 @@
1[pacman]
2type = "none"