diff options
author | Anton Gerasimov <anton.gerasimov@openmailbox.org> | 2018-01-08 14:41:22 +0100 |
---|---|---|
committer | Anton Gerasimov <anton.gerasimov@openmailbox.org> | 2018-01-08 14:41:22 +0100 |
commit | eed239d897045a93d69461b7c093c9c928518f5f (patch) | |
tree | ca4889899d5defe9eba621bd1ee1a0c200ff83e4 | |
parent | d912df6ec53893f49c9cf5626c137bae099895e8 (diff) | |
download | meta-updater-eed239d897045a93d69461b7c093c9c928518f5f.tar.gz |
Delete dependency on libsoup
It makes supporting different platforms somewhat easier
4 files changed, 30 insertions, 14 deletions
diff --git a/recipes-sota/ostree/files/0001-Allow-building-without-libsoup.patch b/recipes-sota/ostree/files/0001-Allow-building-without-libsoup.patch new file mode 100644 index 0000000..f45bae4 --- /dev/null +++ b/recipes-sota/ostree/files/0001-Allow-building-without-libsoup.patch | |||
@@ -0,0 +1,26 @@ | |||
1 | From 666e80acda17680e20d363ddc6fcf0a63f9c1dde Mon Sep 17 00:00:00 2001 | ||
2 | From: Anton Gerasimov <anton.gerasimov@openmailbox.org> | ||
3 | Date: Thu, 21 Dec 2017 22:36:06 +0100 | ||
4 | Subject: [PATCH] Allow building without libsoup | ||
5 | |||
6 | --- | ||
7 | configure.ac | 3 --- | ||
8 | 1 file changed, 3 deletions(-) | ||
9 | |||
10 | diff --git a/configure.ac b/configure.ac | ||
11 | index 92248af8..baf66e4f 100644 | ||
12 | --- a/configure.ac | ||
13 | +++ b/configure.ac | ||
14 | @@ -182,9 +182,6 @@ AM_COND_IF(BUILDOPT_TRIVIAL_HTTPD, | ||
15 | [AC_DEFINE([BUILDOPT_ENABLE_TRIVIAL_HTTPD_CMDLINE], 1, [Define if we are enabling ostree trivial-httpd entrypoint])] | ||
16 | ) | ||
17 | |||
18 | -AS_IF([test x$with_curl = xyes && test x$with_soup = xno], [ | ||
19 | - AC_MSG_ERROR([Curl enabled, but libsoup is not; libsoup is needed for tests]) | ||
20 | -]) | ||
21 | AM_CONDITIONAL(USE_CURL_OR_SOUP, test x$with_curl != xno || test x$with_soup != xno) | ||
22 | AS_IF([test x$with_curl != xno || test x$with_soup != xno], | ||
23 | [AC_DEFINE([HAVE_LIBCURL_OR_LIBSOUP], 1, [Define if we have soup or curl])]) | ||
24 | -- | ||
25 | 2.15.0 | ||
26 | |||
diff --git a/recipes-sota/ostree/ostree_git.bb b/recipes-sota/ostree/ostree_git.bb index 724976a..9ef4478 100644 --- a/recipes-sota/ostree/ostree_git.bb +++ b/recipes-sota/ostree/ostree_git.bb | |||
@@ -6,7 +6,8 @@ inherit autotools-brokensep pkgconfig systemd gobject-introspection | |||
6 | 6 | ||
7 | INHERIT_remove_class-native = "systemd" | 7 | INHERIT_remove_class-native = "systemd" |
8 | 8 | ||
9 | SRC_URI = "gitsm://github.com/ostreedev/ostree.git;branch=master" | 9 | SRC_URI = "gitsm://github.com/ostreedev/ostree.git;branch=master \ |
10 | file://0001-Allow-building-without-libsoup.patch" | ||
10 | 11 | ||
11 | SRCREV="ae61321046ad7f4148a5884c8c6c8b2594ff840e" | 12 | SRCREV="ae61321046ad7f4148a5884c8c6c8b2594ff840e" |
12 | 13 | ||
@@ -16,14 +17,14 @@ S = "${WORKDIR}/git" | |||
16 | 17 | ||
17 | BBCLASSEXTEND = "native" | 18 | BBCLASSEXTEND = "native" |
18 | 19 | ||
19 | DEPENDS += "attr libarchive glib-2.0 pkgconfig gpgme libgsystem fuse libsoup-2.4 e2fsprogs gtk-doc-native curl xz" | 20 | DEPENDS += "attr libarchive glib-2.0 pkgconfig gpgme libgsystem fuse e2fsprogs gtk-doc-native curl xz" |
20 | DEPENDS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', ' systemd', '', d)}" | 21 | DEPENDS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', ' systemd', '', d)}" |
21 | DEPENDS_remove_class-native = "systemd-native" | 22 | DEPENDS_remove_class-native = "systemd-native" |
22 | 23 | ||
23 | RDEPENDS_${PN} = "python util-linux-libuuid util-linux-libblkid util-linux-libmount libcap bash" | 24 | RDEPENDS_${PN} = "python util-linux-libuuid util-linux-libblkid util-linux-libmount libcap bash" |
24 | RDEPENDS_${PN}_remove_class-native = "python-native" | 25 | RDEPENDS_${PN}_remove_class-native = "python-native" |
25 | 26 | ||
26 | EXTRA_OECONF = "--with-libarchive --disable-gtk-doc --disable-gtk-doc-html --disable-gtk-doc-pdf --disable-man --with-smack --with-builtin-grub2-mkconfig --with-curl" | 27 | EXTRA_OECONF = "CFLAGS='-Wno-error=missing-prototypes' --with-libarchive --disable-gtk-doc --disable-gtk-doc-html --disable-gtk-doc-pdf --disable-man --with-smack --with-builtin-grub2-mkconfig --with-curl --without-soup" |
27 | EXTRA_OECONF_append_class-native = " --enable-wrpseudo-compat" | 28 | EXTRA_OECONF_append_class-native = " --enable-wrpseudo-compat" |
28 | 29 | ||
29 | # Path to ${prefix}/lib/ostree/ostree-grub-generator is hardcoded on the | 30 | # Path to ${prefix}/lib/ostree/ostree-grub-generator is hardcoded on the |
diff --git a/recipes-support/glib-networking/glib-networking_%.bbappend b/recipes-support/glib-networking/glib-networking_%.bbappend deleted file mode 100644 index 22e6f05..0000000 --- a/recipes-support/glib-networking/glib-networking_%.bbappend +++ /dev/null | |||
@@ -1,8 +0,0 @@ | |||
1 | BBCLASSEXTEND_append_sota = " native nativesdk" | ||
2 | |||
3 | # Hackery to prevent relocatable_native_pcfiles from crashing | ||
4 | do_install_append_class-native () { | ||
5 | if [ -d ${D}${libdir}/pkgconfig ]; then | ||
6 | rmdir ${D}${libdir}/pkgconfig | ||
7 | fi | ||
8 | } | ||
diff --git a/recipes-support/libsoup/libsoup-2.4_%.bbappend b/recipes-support/libsoup/libsoup-2.4_%.bbappend deleted file mode 100644 index 18383f1..0000000 --- a/recipes-support/libsoup/libsoup-2.4_%.bbappend +++ /dev/null | |||
@@ -1,3 +0,0 @@ | |||
1 | BBCLASSEXTEND_append_sota = " native nativesdk" | ||
2 | |||
3 | DEPENDS_append_class-native = "${@bb.utils.contains('DISTRO_FEATURES', 'sota', ' glib-networking-native', ' ', d)}" | ||