summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRicardo Salveti <ricardo@foundries.io>2019-07-24 18:46:45 -0300
committerLaurent Bonnans <laurent.bonnans@here.com>2019-08-15 15:38:54 +0200
commit84b716fa4b45ccdf308b0d38ee9bf6b6db989853 (patch)
treed9f8e3e5c996ec5e36fa6090eaa90e48a4a7bab5
parent80464bd9c6fd7a33a35fd17a0daa7e799279de48 (diff)
downloadmeta-updater-84b716fa4b45ccdf308b0d38ee9bf6b6db989853.tar.gz
initramfs-ostree-image: unset EXTRA_IMAGEDEPENDS to avoid extra dependencies
It is common for machine configurations to set EXTRA_IMAGEDEPENDS, which can end up causing circular dependencies when building the initramfs image (they are usually only required for the actual rootfs image). Signed-off-by: Ricardo Salveti <ricardo@foundries.io> (cherry-picked from commit e556e32c8449fc324481d0d74682f5e04a191477)
-rw-r--r--recipes-core/images/initramfs-ostree-image.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/recipes-core/images/initramfs-ostree-image.bb b/recipes-core/images/initramfs-ostree-image.bb
index b2d9e27..26a70d3 100644
--- a/recipes-core/images/initramfs-ostree-image.bb
+++ b/recipes-core/images/initramfs-ostree-image.bb
@@ -15,6 +15,9 @@ LICENSE = "MIT"
15 15
16IMAGE_FSTYPES = "${OSTREE_INITRAMFS_FSTYPES}" 16IMAGE_FSTYPES = "${OSTREE_INITRAMFS_FSTYPES}"
17 17
18# Avoid circular dependencies
19EXTRA_IMAGEDEPENDS = ""
20
18inherit core-image 21inherit core-image
19 22
20IMAGE_ROOTFS_SIZE = "8192" 23IMAGE_ROOTFS_SIZE = "8192"