summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Vacek <patrickvacek@gmail.com>2019-05-13 15:42:40 +0200
committerGitHub <noreply@github.com>2019-05-13 15:42:40 +0200
commit9725c55078e6216437904aa63d5bb5c632f92302 (patch)
tree6443c974aca7aa2c3803b1f941fe4fb66d6d8e44
parent438814dec075da891ed37a57c8b5138b43f56818 (diff)
parentfbc6d2b60d78ec500fa7a14cf9724497142867ce (diff)
downloadmeta-updater-9725c55078e6216437904aa63d5bb5c632f92302.tar.gz
Merge pull request #517 from advancedtelematic/test/thud/ptest-printing
Test/thud/ptest printing
-rw-r--r--README.adoc2
-rw-r--r--lib/oeqa/selftest/cases/updater_qemux86_64_ptest.py4
-rwxr-xr-xrecipes-sota/aktualizr/aktualizr_git.bb2
3 files changed, 4 insertions, 4 deletions
diff --git a/README.adoc b/README.adoc
index cc01612..a28d934 100644
--- a/README.adoc
+++ b/README.adoc
@@ -228,7 +228,7 @@ sudo apt install ovmf
2285. Run oe-selftest: 2285. Run oe-selftest:
229+ 229+
230``` 230```
231oe-selftest -r updater_native updater_qemux86_64 updater_minnowboard updater_raspberrypi 231oe-selftest -r updater_native updater_qemux86_64 updater_minnowboard updater_raspberrypi updater_qemux86_64_ptest
232``` 232```
233 233
234For more information about oe-selftest, including details about how to run individual test modules or classes, please refer to the https://wiki.yoctoproject.org/wiki/Oe-selftest[Yocto Project wiki]. 234For more information about oe-selftest, including details about how to run individual test modules or classes, please refer to the https://wiki.yoctoproject.org/wiki/Oe-selftest[Yocto Project wiki].
diff --git a/lib/oeqa/selftest/cases/updater_qemux86_64_ptest.py b/lib/oeqa/selftest/cases/updater_qemux86_64_ptest.py
index a04032c..0f0f491 100644
--- a/lib/oeqa/selftest/cases/updater_qemux86_64_ptest.py
+++ b/lib/oeqa/selftest/cases/updater_qemux86_64_ptest.py
@@ -41,12 +41,12 @@ class PtestTests(OESelftestTestCase):
41 stdout, stderr, retcode = self.qemu_command('sh -l -c ptest-runner', timeout=None) 41 stdout, stderr, retcode = self.qemu_command('sh -l -c ptest-runner', timeout=None)
42 output = stdout.decode() 42 output = stdout.decode()
43 print(output) 43 print(output)
44 self.assertEqual(retcode, 0)
45 44
46 has_failure = re.search('^FAIL', output, flags=re.MULTILINE) is not None 45 has_failure = re.search('^FAIL', output, flags=re.MULTILINE) is not None
47 if has_failure: 46 if has_failure:
48 print("Full test suite log:") 47 print("Full test suite log:")
49 stdout, stderr, retcode = self.qemu_command('cat /tmp/aktualizr-ptest.log', timeout=None) 48 stdout, _, _ = self.qemu_command('cat /tmp/aktualizr-ptest.log || cat /tmp/aktualizr-ptest.log.tmp', timeout=None)
50 print(stdout.decode()) 49 print(stdout.decode())
51 50
51 self.assertEqual(retcode, 0)
52 self.assertFalse(has_failure) 52 self.assertFalse(has_failure)
diff --git a/recipes-sota/aktualizr/aktualizr_git.bb b/recipes-sota/aktualizr/aktualizr_git.bb
index c0e275d..903f2de 100755
--- a/recipes-sota/aktualizr/aktualizr_git.bb
+++ b/recipes-sota/aktualizr/aktualizr_git.bb
@@ -10,7 +10,7 @@ DEPENDS_append = "${@bb.utils.contains('PTEST_ENABLED', '1', ' coreutils-native
10RDEPENDS_${PN}_class-target = "aktualizr-configs lshw" 10RDEPENDS_${PN}_class-target = "aktualizr-configs lshw"
11RDEPENDS_${PN}-host-tools = "aktualizr aktualizr-repo aktualizr-cert-provider ${@bb.utils.contains('PACKAGECONFIG', 'sota-tools', 'garage-deploy garage-push', '', d)}" 11RDEPENDS_${PN}-host-tools = "aktualizr aktualizr-repo aktualizr-cert-provider ${@bb.utils.contains('PACKAGECONFIG', 'sota-tools', 'garage-deploy garage-push', '', d)}"
12 12
13RDEPENDS_${PN}-ptest += "bash cmake curl python3-modules openssl-bin sqlite3 valgrind" 13RDEPENDS_${PN}-ptest += "bash cmake curl python3-misc python3-modules openssl-bin sqlite3 valgrind"
14 14
15PV = "1.0+git${SRCPV}" 15PV = "1.0+git${SRCPV}"
16PR = "7" 16PR = "7"