diff options
author | Patrick Vacek <patrickvacek@gmail.com> | 2018-02-13 17:06:51 +0100 |
---|---|---|
committer | Patrick Vacek <patrickvacek@gmail.com> | 2018-02-13 17:06:51 +0100 |
commit | 2dbeaf315ff9cf8cce1d0a3276fd561163db6237 (patch) | |
tree | fa4f11fe318f3bd1d003b68a8fdf7f6530010ec4 | |
parent | 3a4bdbcae17b1b2f2197c61a0d188336767e1c60 (diff) | |
download | meta-updater-2dbeaf315ff9cf8cce1d0a3276fd561163db6237.tar.gz |
Fix minor ovmf compilation bug only present in pyro.
This does not appear to be a problem on rocko, and it wasn't a problem
for me on pyro when I last checked less than a month ago. It actually
only broke the native build. This has been fixed upstream at some point,
anyway.
-rw-r--r-- | recipes-core/ovmf/files/0001-Compare-c-string-with-NULL-instead-of-a-literal.patch | 25 | ||||
-rw-r--r-- | recipes-core/ovmf/ovmf_%.bbappend | 3 |
2 files changed, 28 insertions, 0 deletions
diff --git a/recipes-core/ovmf/files/0001-Compare-c-string-with-NULL-instead-of-a-literal.patch b/recipes-core/ovmf/files/0001-Compare-c-string-with-NULL-instead-of-a-literal.patch new file mode 100644 index 0000000..6bdaf7e --- /dev/null +++ b/recipes-core/ovmf/files/0001-Compare-c-string-with-NULL-instead-of-a-literal.patch | |||
@@ -0,0 +1,25 @@ | |||
1 | From 6c730f3da7490ffbba5ad17af29ca44ed167cbfc Mon Sep 17 00:00:00 2001 | ||
2 | From: Patrick Vacek <patrickvacek@gmail.com> | ||
3 | Date: Tue, 13 Feb 2018 16:38:15 +0100 | ||
4 | Subject: [PATCH] Compare c-string with NULL instead of a literal. | ||
5 | |||
6 | --- | ||
7 | BaseTools/Source/C/VfrCompile/VfrUtilityLib.cpp | 2 +- | ||
8 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
9 | |||
10 | diff --git a/BaseTools/Source/C/VfrCompile/VfrUtilityLib.cpp b/BaseTools/Source/C/VfrCompile/VfrUtilityLib.cpp | ||
11 | index 3ca57ed741..4fa066dd9f 100644 | ||
12 | --- a/BaseTools/Source/C/VfrCompile/VfrUtilityLib.cpp | ||
13 | +++ b/BaseTools/Source/C/VfrCompile/VfrUtilityLib.cpp | ||
14 | @@ -3372,7 +3372,7 @@ CVfrStringDB::GetVarStoreNameFormStringId ( | ||
15 | UINT8 BlockType; | ||
16 | EFI_HII_STRING_PACKAGE_HDR *PkgHeader; | ||
17 | |||
18 | - if (mStringFileName == '\0' ) { | ||
19 | + if (mStringFileName == NULL ) { | ||
20 | return NULL; | ||
21 | } | ||
22 | |||
23 | -- | ||
24 | 2.14.1 | ||
25 | |||
diff --git a/recipes-core/ovmf/ovmf_%.bbappend b/recipes-core/ovmf/ovmf_%.bbappend new file mode 100644 index 0000000..142fc53 --- /dev/null +++ b/recipes-core/ovmf/ovmf_%.bbappend | |||
@@ -0,0 +1,3 @@ | |||
1 | FILESEXTRAPATHS_prepend := "${THISDIR}/files:" | ||
2 | |||
3 | SRC_URI_append = "file://0001-Compare-c-string-with-NULL-instead-of-a-literal.patch" | ||