diff options
author | Anton Gerasimov <anton@advancedtelematic.com> | 2017-02-23 15:14:03 +0100 |
---|---|---|
committer | Anton Gerasimov <anton@advancedtelematic.com> | 2017-02-23 15:18:26 +0100 |
commit | f38fc412321c9cb6c17110d8a8aa6183823b0122 (patch) | |
tree | ff4a65a54ac2e4ee10a0b93f683be55b115716e6 | |
parent | 7643e4da141c10bcb017d7a216512febe08da68a (diff) | |
download | meta-updater-f38fc412321c9cb6c17110d8a8aa6183823b0122.tar.gz |
Changes for morty branch (sync with AGL's meta-sota)
-rw-r--r-- | recipes-bsp/u-boot/u-boot_2016.11.bb | 6 | ||||
-rw-r--r-- | recipes-devtools/pseudo/files/0001-Add-check-for-existence-of-old-file-to-renameat.patch | 40 | ||||
-rw-r--r-- | recipes-devtools/pseudo/files/fallback-group | 2 | ||||
-rw-r--r-- | recipes-devtools/pseudo/files/fallback-passwd | 1 | ||||
-rw-r--r-- | recipes-devtools/pseudo/pseudo_1.7.5.bbappend | 3 | ||||
-rw-r--r-- | recipes-devtools/pseudo/pseudo_1.8.1.bb | 20 | ||||
-rw-r--r-- | recipes-sota/ostree/ostree_git.bb | 14 | ||||
-rw-r--r-- | recipes-sota/rvi-sota-client/rvi-sota-client_git.bb | 1 | ||||
-rw-r--r-- | recipes-support/libgsystem/libgsystem_git.bb | 8 | ||||
-rw-r--r-- | recipes-support/lshw/lshw_02.16.bb | 4 |
10 files changed, 21 insertions, 78 deletions
diff --git a/recipes-bsp/u-boot/u-boot_2016.11.bb b/recipes-bsp/u-boot/u-boot_2016.11.bb index a05b37f..e6e1fcf 100644 --- a/recipes-bsp/u-boot/u-boot_2016.11.bb +++ b/recipes-bsp/u-boot/u-boot_2016.11.bb | |||
@@ -5,3 +5,9 @@ DEPENDS += "dtc-native" | |||
5 | SRCREV = "5ea3e51fc481613a8dee8c02848d1b42c81ad892" | 5 | SRCREV = "5ea3e51fc481613a8dee8c02848d1b42c81ad892" |
6 | 6 | ||
7 | PV = "v2016.11+git${SRCPV}" | 7 | PV = "v2016.11+git${SRCPV}" |
8 | |||
9 | #This patch is not compliant with u-boot 2016.11 | ||
10 | #Version of u-boot from yocto 2.2 Morty is 2016.03 from: | ||
11 | # meta/recipes-bsp/u-boot/u-boot_2016.03.bb | ||
12 | SRC_URI_remove_raspberrypi3 = "file://0003-Include-lowlevel_init.o-for-rpi2.patch" | ||
13 | SRC_URI_remove_raspberrypi2 = "file://0003-Include-lowlevel_init.o-for-rpi2.patch" | ||
diff --git a/recipes-devtools/pseudo/files/0001-Add-check-for-existence-of-old-file-to-renameat.patch b/recipes-devtools/pseudo/files/0001-Add-check-for-existence-of-old-file-to-renameat.patch deleted file mode 100644 index 3da2ad7..0000000 --- a/recipes-devtools/pseudo/files/0001-Add-check-for-existence-of-old-file-to-renameat.patch +++ /dev/null | |||
@@ -1,40 +0,0 @@ | |||
1 | From 41bb6c818a7ec9eeb33b60302c55c9c5ee393c5f Mon Sep 17 00:00:00 2001 | ||
2 | From: Anton Gerasimov <anton@advancedtelematic.com> | ||
3 | Date: Fri, 30 Sep 2016 17:12:19 +0200 | ||
4 | Subject: [PATCH 1/1] Add check for existence of old file to renameat | ||
5 | |||
6 | --- | ||
7 | ports/unix/guts/renameat.c | 7 ++++++- | ||
8 | 1 file changed, 6 insertions(+), 1 deletion(-) | ||
9 | |||
10 | diff --git a/ports/unix/guts/renameat.c b/ports/unix/guts/renameat.c | ||
11 | index ade0509..d5e36fa 100644 | ||
12 | --- a/ports/unix/guts/renameat.c | ||
13 | +++ b/ports/unix/guts/renameat.c | ||
14 | @@ -11,6 +11,7 @@ | ||
15 | int oldrc, newrc; | ||
16 | int save_errno; | ||
17 | int old_db_entry = 0; | ||
18 | + int may_unlinked = 0; | ||
19 | |||
20 | pseudo_debug(PDBGF_FILE, "renameat: %d,%s->%d,%s\n", | ||
21 | olddirfd, oldpath ? oldpath : "<nil>", | ||
22 | @@ -44,10 +45,14 @@ | ||
23 | /* as with unlink, we have to mark that the file may get deleted */ | ||
24 | msg = pseudo_client_op(OP_MAY_UNLINK, 0, -1, newdirfd, newpath, newrc ? NULL : &newbuf); | ||
25 | if (msg && msg->result == RESULT_SUCCEED) | ||
26 | + may_unlinked = 1; | ||
27 | + msg = pseudo_client_op(OP_STAT, 0, -1, olddirfd, oldpath, oldrc ? NULL : &oldbuf); | ||
28 | + if (msg && msg->result == RESULT_SUCCEED) | ||
29 | old_db_entry = 1; | ||
30 | + | ||
31 | rc = real_renameat(olddirfd, oldpath, newdirfd, newpath); | ||
32 | save_errno = errno; | ||
33 | - if (old_db_entry) { | ||
34 | + if (may_unlinked) { | ||
35 | if (rc == -1) { | ||
36 | /* since we failed, that wasn't really unlinked -- put | ||
37 | * it back. | ||
38 | -- | ||
39 | 2.9.3 | ||
40 | |||
diff --git a/recipes-devtools/pseudo/files/fallback-group b/recipes-devtools/pseudo/files/fallback-group deleted file mode 100644 index 81bf732..0000000 --- a/recipes-devtools/pseudo/files/fallback-group +++ /dev/null | |||
@@ -1,2 +0,0 @@ | |||
1 | root:*:0: | ||
2 | mail:*:8: | ||
diff --git a/recipes-devtools/pseudo/files/fallback-passwd b/recipes-devtools/pseudo/files/fallback-passwd deleted file mode 100644 index c1458dc..0000000 --- a/recipes-devtools/pseudo/files/fallback-passwd +++ /dev/null | |||
@@ -1 +0,0 @@ | |||
1 | root::0:0:root:/home/root:/bin/sh | ||
diff --git a/recipes-devtools/pseudo/pseudo_1.7.5.bbappend b/recipes-devtools/pseudo/pseudo_1.7.5.bbappend deleted file mode 100644 index 73b43df..0000000 --- a/recipes-devtools/pseudo/pseudo_1.7.5.bbappend +++ /dev/null | |||
@@ -1,3 +0,0 @@ | |||
1 | FILESEXTRAPATHS_prepend := "${THISDIR}/files:" | ||
2 | |||
3 | SRC_URI += "file://0001-Add-check-for-existence-of-old-file-to-renameat.patch" | ||
diff --git a/recipes-devtools/pseudo/pseudo_1.8.1.bb b/recipes-devtools/pseudo/pseudo_1.8.1.bb deleted file mode 100644 index 211439e..0000000 --- a/recipes-devtools/pseudo/pseudo_1.8.1.bb +++ /dev/null | |||
@@ -1,20 +0,0 @@ | |||
1 | require recipes-devtools/pseudo/pseudo.inc | ||
2 | |||
3 | SRC_URI = " \ | ||
4 | http://downloads.yoctoproject.org/releases/pseudo/${BPN}-${PV}.tar.bz2 \ | ||
5 | file://fallback-passwd \ | ||
6 | file://fallback-group \ | ||
7 | file://0001-Add-check-for-existence-of-old-file-to-renameat.patch \ | ||
8 | " | ||
9 | |||
10 | SRC_URI[md5sum] = "ee38e4fb62ff88ad067b1a5a3825bac7" | ||
11 | SRC_URI[sha256sum] = "dac4ad2d21228053151121320f629d41dd5c0c87695ac4e7aea286c414192ab5" | ||
12 | |||
13 | PSEUDO_EXTRA_OPTS ?= "--enable-force-async --without-passwd-fallback" | ||
14 | |||
15 | do_install_append_class-native () { | ||
16 | install -d ${D}${sysconfdir} | ||
17 | # The fallback files should never be modified | ||
18 | install -m 444 ${WORKDIR}/fallback-passwd ${D}${sysconfdir}/passwd | ||
19 | install -m 444 ${WORKDIR}/fallback-group ${D}${sysconfdir}/group | ||
20 | } | ||
diff --git a/recipes-sota/ostree/ostree_git.bb b/recipes-sota/ostree/ostree_git.bb index 67b5047..5775dfa 100644 --- a/recipes-sota/ostree/ostree_git.bb +++ b/recipes-sota/ostree/ostree_git.bb | |||
@@ -8,13 +8,13 @@ INHERIT_remove_class-native = "systemd" | |||
8 | 8 | ||
9 | SRC_URI = "gitsm://github.com/ostreedev/ostree.git;branch=master" | 9 | SRC_URI = "gitsm://github.com/ostreedev/ostree.git;branch=master" |
10 | 10 | ||
11 | SRCREV="37c07d2f1c90b12bcfba85a7d900f81a7c362eb4" | 11 | SRCREV="6517a8a27a1386e7cb5482e7cb2919fe92721ccf" |
12 | 12 | ||
13 | S = "${WORKDIR}/git" | 13 | S = "${WORKDIR}/git" |
14 | 14 | ||
15 | BBCLASSEXTEND = "native" | 15 | BBCLASSEXTEND = "native" |
16 | 16 | ||
17 | DEPENDS += "attr libarchive glib-2.0 pkgconfig gpgme libgsystem fuse libsoup-2.4 e2fsprogs" | 17 | DEPENDS += "attr libarchive glib-2.0 pkgconfig gpgme libgsystem fuse libsoup-2.4 e2fsprogs gtk-doc-native" |
18 | DEPENDS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', ' systemd', '', d)}" | 18 | DEPENDS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', ' systemd', '', d)}" |
19 | 19 | ||
20 | DEPENDS_remove_class-native = "systemd-native" | 20 | DEPENDS_remove_class-native = "systemd-native" |
@@ -27,12 +27,12 @@ EXTRA_OEMAKE = "CFLAGS='-g'" | |||
27 | EXTRA_OECONF_append_class-native = " --enable-wrpseudo-compat" | 27 | EXTRA_OECONF_append_class-native = " --enable-wrpseudo-compat" |
28 | 28 | ||
29 | SYSTEMD_REQUIRED = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}" | 29 | SYSTEMD_REQUIRED = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}" |
30 | SYSTEMD_REQUIRED_class-native = "false" | 30 | SYSTEMD_REQUIRED_class-native = "" |
31 | 31 | ||
32 | SYSTEMD_SERVICE_${PN} = "ostree-prepare-root.service ostree-remount.service" | 32 | SYSTEMD_SERVICE_${PN} = "ostree-prepare-root.service ostree-remount.service" |
33 | SYSTEMD_SERVICE_${PN}_class-native = "" | 33 | SYSTEMD_SERVICE_${PN}_class-native = "" |
34 | 34 | ||
35 | PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}" | 35 | PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}" |
36 | PACKAGECONFIG_class-native = "" | 36 | PACKAGECONFIG_class-native = "" |
37 | PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/ --with-dracut" | 37 | PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/ --with-dracut" |
38 | 38 | ||
@@ -42,7 +42,8 @@ export STAGING_INCDIR | |||
42 | export STAGING_LIBDIR | 42 | export STAGING_LIBDIR |
43 | 43 | ||
44 | do_configure() { | 44 | do_configure() { |
45 | NOCONFIGURE=true ./autogen.sh | 45 | unset docdir |
46 | NOCONFIGURE=1 ./autogen.sh | ||
46 | oe_runconf | 47 | oe_runconf |
47 | } | 48 | } |
48 | 49 | ||
@@ -54,7 +55,8 @@ do_compile_prepend() { | |||
54 | export SYSTEMD_REQUIRED | 55 | export SYSTEMD_REQUIRED |
55 | 56 | ||
56 | do_install_append() { | 57 | do_install_append() { |
57 | if [ "$SYSTEMD_REQUIRED" == "true" ]; then | 58 | if [ -n $SYSTEMD_REQUIRED ]; then |
59 | install -p -D ${S}/src/boot/ostree-prepare-root.service ${D}${systemd_unitdir}/system/ostree-prepare-root.service | ||
58 | install -p -D ${S}/src/boot/ostree-remount.service ${D}${systemd_unitdir}/system/ostree-remount.service | 60 | install -p -D ${S}/src/boot/ostree-remount.service ${D}${systemd_unitdir}/system/ostree-remount.service |
59 | fi | 61 | fi |
60 | } | 62 | } |
diff --git a/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb b/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb index 15aa7a4..459cf6b 100644 --- a/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb +++ b/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb | |||
@@ -95,7 +95,6 @@ crate://crates.io/winapi/0.2.8 \ | |||
95 | crate://crates.io/ws/0.5.3 \ | 95 | crate://crates.io/ws/0.5.3 \ |
96 | crate://crates.io/ws2_32-sys/0.2.1 \ | 96 | crate://crates.io/ws2_32-sys/0.2.1 \ |
97 | git://github.com/advancedtelematic/rvi_sota_client \ | 97 | git://github.com/advancedtelematic/rvi_sota_client \ |
98 | crate-index://crates.io/213b1a455d9270888c03a42c8d29975369102caa \ | ||
99 | " | 98 | " |
100 | SRC_URI[index.md5sum] = "79f10f436dbf26737cc80445746f16b4" | 99 | SRC_URI[index.md5sum] = "79f10f436dbf26737cc80445746f16b4" |
101 | SRC_URI[index.sha256sum] = "86114b93f1f51aaf0aec3af0751d214b351f4ff9839ba031315c1b19dcbb1913" | 100 | SRC_URI[index.sha256sum] = "86114b93f1f51aaf0aec3af0751d214b351f4ff9839ba031315c1b19dcbb1913" |
diff --git a/recipes-support/libgsystem/libgsystem_git.bb b/recipes-support/libgsystem/libgsystem_git.bb index 048c44b..e2b362f 100644 --- a/recipes-support/libgsystem/libgsystem_git.bb +++ b/recipes-support/libgsystem/libgsystem_git.bb | |||
@@ -9,9 +9,10 @@ S = "${WORKDIR}/git" | |||
9 | 9 | ||
10 | inherit autotools-brokensep gobject-introspection | 10 | inherit autotools-brokensep gobject-introspection |
11 | 11 | ||
12 | DEPENDS += "attr glib-2.0 pkgconfig libcap xz" | 12 | DEPENDS += "attr glib-2.0 pkgconfig libcap gtk-doc-native gpgme" |
13 | 13 | RDEPENDS_${PN} = "xz " | |
14 | RDEPENDS_${PN}_append = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', ' systemd', '', d)}" | 14 | RDEPENDS_${PN}_append = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', ' systemd', '', d)}" |
15 | |||
15 | RDEPENDS_${PN}_remove_class-native = "systemd-native" | 16 | RDEPENDS_${PN}_remove_class-native = "systemd-native" |
16 | 17 | ||
17 | BBCLASSEXTEND = "native" | 18 | BBCLASSEXTEND = "native" |
@@ -20,7 +21,8 @@ export STAGING_INCDIR | |||
20 | export STAGING_LIBDIR | 21 | export STAGING_LIBDIR |
21 | 22 | ||
22 | do_configure() { | 23 | do_configure() { |
23 | NOCONFIGURE=true ./autogen.sh | 24 | #NOCONFIGURE=true ./autogen.sh |
25 | autoreconf -vfi | ||
24 | oe_runconf | 26 | oe_runconf |
25 | } | 27 | } |
26 | 28 | ||
diff --git a/recipes-support/lshw/lshw_02.16.bb b/recipes-support/lshw/lshw_02.16.bb index 0b057bd..53b0d65 100644 --- a/recipes-support/lshw/lshw_02.16.bb +++ b/recipes-support/lshw/lshw_02.16.bb | |||
@@ -18,8 +18,8 @@ PR="r1" | |||
18 | 18 | ||
19 | SRC_URI="http://ezix.org/software/files/lshw-B.${PV}.tar.gz \ | 19 | SRC_URI="http://ezix.org/software/files/lshw-B.${PV}.tar.gz \ |
20 | file://cross-compile.patch \ | 20 | file://cross-compile.patch \ |
21 | file://ldflags.patch" | 21 | file://ldflags.patch \ |
22 | 22 | " | |
23 | SRC_URI[md5sum] = "67479167add605e8f001097c30e96d0d" | 23 | SRC_URI[md5sum] = "67479167add605e8f001097c30e96d0d" |
24 | SRC_URI[sha256sum] = "809882429555b93259785cc261dbff04c16c93d064db5f445a51945bc47157cb" | 24 | SRC_URI[sha256sum] = "809882429555b93259785cc261dbff04c16c93d064db5f445a51945bc47157cb" |
25 | 25 | ||