summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlbonn <lbonn@users.noreply.github.com>2018-05-28 11:41:38 +0200
committerGitHub <noreply@github.com>2018-05-28 11:41:38 +0200
commitb799d9c4a83de82bc4e0664ed63c788955b33a68 (patch)
tree619a74da4a6089b1dc9e86565bab2ab9fd668678
parent52e20c85e8a39f3d9bfc27448f235c34b31491e6 (diff)
parent4bcd0509c780a2e244aab4713926a548c176fb5f (diff)
downloadmeta-updater-b799d9c4a83de82bc4e0664ed63c788955b33a68.tar.gz
Merge pull request #322 from advancedtelematic/rocko-to-master-2018-05-28
Rocko to master 2018 05 28
-rw-r--r--README.adoc6
-rw-r--r--classes/sota_qemux86-64.bbclass3
-rw-r--r--recipes-sota/ostree/ostree_git.bb4
3 files changed, 5 insertions, 8 deletions
diff --git a/README.adoc b/README.adoc
index c47dd1d..75ee9ae 100644
--- a/README.adoc
+++ b/README.adoc
@@ -53,12 +53,6 @@ Although `aglsetup.sh` hooks provide reasonable defaults for SOTA-related variab
53 53
54=== Build problems 54=== Build problems
55 55
56Multilib systems may require adding this line to `local.conf`:
57
58....
59HOSTTOOLS += "x86_64-linux-gnu-gcc"
60....
61
62Ubuntu users that encounter an error due to missing `Python.h` should install `libpython2.7-dev` on their host machine. 56Ubuntu users that encounter an error due to missing `Python.h` should install `libpython2.7-dev` on their host machine.
63 57
64== Supported boards 58== Supported boards
diff --git a/classes/sota_qemux86-64.bbclass b/classes/sota_qemux86-64.bbclass
index 15b2043..82efe52 100644
--- a/classes/sota_qemux86-64.bbclass
+++ b/classes/sota_qemux86-64.bbclass
@@ -9,3 +9,6 @@ OSTREE_INITRAMFS_FSTYPES ?= "ext4.gz"
9OSTREE_KERNEL_ARGS ?= "ramdisk_size=16384 rw rootfstype=ext4 rootwait rootdelay=2 ostree_root=/dev/hda" 9OSTREE_KERNEL_ARGS ?= "ramdisk_size=16384 rw rootfstype=ext4 rootwait rootdelay=2 ostree_root=/dev/hda"
10 10
11IMAGE_ROOTFS_EXTRA_SPACE = "${@bb.utils.contains('DISTRO_FEATURES', 'sota', '65536', '', d)}" 11IMAGE_ROOTFS_EXTRA_SPACE = "${@bb.utils.contains('DISTRO_FEATURES', 'sota', '65536', '', d)}"
12
13# fix for u-boot/swig build issue
14HOSTTOOLS_NONFATAL += "x86_64-linux-gnu-gcc"
diff --git a/recipes-sota/ostree/ostree_git.bb b/recipes-sota/ostree/ostree_git.bb
index cdcb485..bfe16e9 100644
--- a/recipes-sota/ostree/ostree_git.bb
+++ b/recipes-sota/ostree/ostree_git.bb
@@ -2,7 +2,7 @@ SUMMARY = "Tool for managing bootable, immutable, versioned filesystem trees"
2LICENSE = "GPLv2+" 2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2" 3LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
4 4
5inherit autotools-brokensep pkgconfig systemd gobject-introspection 5inherit autotools pkgconfig systemd gobject-introspection
6 6
7INHERIT_remove_class-native = "systemd" 7INHERIT_remove_class-native = "systemd"
8 8
@@ -49,7 +49,7 @@ export STAGING_LIBDIR
49 49
50do_configure() { 50do_configure() {
51 unset docdir 51 unset docdir
52 NOCONFIGURE=1 ./autogen.sh 52 NOCONFIGURE=1 "${S}/autogen.sh"
53 oe_runconf 53 oe_runconf
54} 54}
55 55