summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRicardo Salveti <ricardo@opensourcefoundries.com>2018-05-04 22:51:23 -0300
committerRicardo Salveti <ricardo@opensourcefoundries.com>2018-06-12 16:55:19 -0300
commit9f30ec0c0b818c5268964b845a380270d03d3346 (patch)
tree2e245fa4d065dc29491879478ef9e460a97d6a80
parent9b709a079d30a005f7187517466c81f9119b10fd (diff)
downloadmeta-updater-9f30ec0c0b818c5268964b845a380270d03d3346.tar.gz
ostree: no need to disable systemd when building native
Maintaining different build flags for target and native just makes it harder to maintain the recipe and it is not really needed as systemd-native is already available for systems building systemd. Signed-off-by: Ricardo Salveti <ricardo@opensourcefoundries.com>
-rw-r--r--recipes-sota/ostree/ostree_git.bb7
1 files changed, 0 insertions, 7 deletions
diff --git a/recipes-sota/ostree/ostree_git.bb b/recipes-sota/ostree/ostree_git.bb
index b948131..39d3c48 100644
--- a/recipes-sota/ostree/ostree_git.bb
+++ b/recipes-sota/ostree/ostree_git.bb
@@ -5,8 +5,6 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
5 5
6inherit autotools pkgconfig systemd gobject-introspection 6inherit autotools pkgconfig systemd gobject-introspection
7 7
8INHERIT_remove_class-native = "systemd"
9
10SRC_URI = "gitsm://github.com/ostreedev/ostree.git;branch=master" 8SRC_URI = "gitsm://github.com/ostreedev/ostree.git;branch=master"
11 9
12SRCREV="854a823e05d6fe8b610c02c2a71eaeb2bf1e98a6" 10SRCREV="854a823e05d6fe8b610c02c2a71eaeb2bf1e98a6"
@@ -20,7 +18,6 @@ BBCLASSEXTEND = "native"
20 18
21DEPENDS += "attr libarchive glib-2.0 pkgconfig gpgme libgsystem fuse e2fsprogs gtk-doc-native curl xz" 19DEPENDS += "attr libarchive glib-2.0 pkgconfig gpgme libgsystem fuse e2fsprogs gtk-doc-native curl xz"
22DEPENDS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', ' systemd', '', d)}" 20DEPENDS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', ' systemd', '', d)}"
23DEPENDS_remove_class-native = "systemd-native"
24 21
25RDEPENDS_${PN} = "util-linux-libuuid util-linux-libblkid util-linux-libmount libcap bash" 22RDEPENDS_${PN} = "util-linux-libuuid util-linux-libblkid util-linux-libmount libcap bash"
26 23
@@ -35,13 +32,10 @@ SYSROOT_DIR_class-native = "${STAGING_DIR_NATIVE}"
35do_configure[vardeps] += "SYSROOT_DIR" 32do_configure[vardeps] += "SYSROOT_DIR"
36 33
37SYSTEMD_REQUIRED = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}" 34SYSTEMD_REQUIRED = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}"
38SYSTEMD_REQUIRED_class-native = ""
39 35
40SYSTEMD_SERVICE_${PN} = "ostree-prepare-root.service ostree-remount.service" 36SYSTEMD_SERVICE_${PN} = "ostree-prepare-root.service ostree-remount.service"
41SYSTEMD_SERVICE_${PN}_class-native = ""
42 37
43PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}" 38PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
44PACKAGECONFIG_class-native = ""
45PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/ --with-dracut" 39PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/ --with-dracut"
46 40
47FILES_${PN} += "${libdir}/ostree/ ${libdir}/ostbuild" 41FILES_${PN} += "${libdir}/ostree/ ${libdir}/ostbuild"
@@ -86,4 +80,3 @@ PACKAGES =+ "${PN}-switchroot"
86 80
87FILES_${PN}-switchroot = "${libdir}/ostree/ostree-prepare-root" 81FILES_${PN}-switchroot = "${libdir}/ostree/ostree-prepare-root"
88RDEPENDS_${PN}-switchroot = "" 82RDEPENDS_${PN}-switchroot = ""
89DEPENDS_remove_class-native = "systemd-native"