summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMing Liu <liu.ming50@gmail.com>2017-11-20 16:45:32 +0800
committerLaurent Bonnans <laurent.bonnans@here.com>2018-05-15 10:49:49 +0200
commit3af1b32743b245be8c4e199c6a3785bc92e93ab1 (patch)
treef1967ddf28ed77ccdb15734b8ff2cc114b5cdabd
parentb11ddfbc56721ccc2836c6994678acb3e1b5ca74 (diff)
downloadmeta-updater-3af1b32743b245be8c4e199c6a3785bc92e93ab1.tar.gz
sota: introduce INITRAMFS_FSTYPES
RAMDISK_EXT and IMAGE_FSTYPES of initramfs-ostree-image should not be defined separately, because they are representing the same fstype of a same initramfs image, or else, they turn out to be inconsistent if the users change one of them. So we use INITRAMFS_FSTYPES already defined in bitbake.conf, to be able to set fstype for initramfs. And it should default to ext4.gz.u-boot or ext4.gz depending on what OSTREE_BOOTLOADER is being set. Signed-off-by: Ming Liu <liu.ming50@gmail.com>
-rw-r--r--classes/image_types_ostree.bbclass3
-rw-r--r--classes/image_types_ota.bbclass2
-rw-r--r--classes/sota.bbclass4
-rw-r--r--recipes-core/images/initramfs-ostree-image.bb3
4 files changed, 5 insertions, 7 deletions
diff --git a/classes/image_types_ostree.bbclass b/classes/image_types_ostree.bbclass
index 777360f..349d8fb 100644
--- a/classes/image_types_ostree.bbclass
+++ b/classes/image_types_ostree.bbclass
@@ -11,8 +11,7 @@ export OSTREE_REPO
11export OSTREE_BRANCHNAME 11export OSTREE_BRANCHNAME
12export GARAGE_TARGET_NAME 12export GARAGE_TARGET_NAME
13 13
14RAMDISK_EXT ?= ".ext4.gz" 14RAMDISK_EXT ?= ".${INITRAMFS_FSTYPES}"
15RAMDISK_EXT_arm ?= ".ext4.gz.u-boot"
16 15
17OSTREE_KERNEL ??= "${KERNEL_IMAGETYPE}" 16OSTREE_KERNEL ??= "${KERNEL_IMAGETYPE}"
18 17
diff --git a/classes/image_types_ota.bbclass b/classes/image_types_ota.bbclass
index 17fe4e8..362c1bd 100644
--- a/classes/image_types_ota.bbclass
+++ b/classes/image_types_ota.bbclass
@@ -7,8 +7,6 @@
7# boot scripts, kernel and initramfs images 7# boot scripts, kernel and initramfs images
8# 8#
9 9
10OSTREE_BOOTLOADER ??= 'u-boot'
11
12do_image_otaimg[depends] += "e2fsprogs-native:do_populate_sysroot \ 10do_image_otaimg[depends] += "e2fsprogs-native:do_populate_sysroot \
13 ${@'grub:do_populate_sysroot' if d.getVar('OSTREE_BOOTLOADER', True) == 'grub' else ''} \ 11 ${@'grub:do_populate_sysroot' if d.getVar('OSTREE_BOOTLOADER', True) == 'grub' else ''} \
14 ${@'virtual/bootloader:do_deploy' if d.getVar('OSTREE_BOOTLOADER', True) == 'u-boot' else ''}" 12 ${@'virtual/bootloader:do_deploy' if d.getVar('OSTREE_BOOTLOADER', True) == 'u-boot' else ''}"
diff --git a/classes/sota.bbclass b/classes/sota.bbclass
index 1e765f0..7ff4bf1 100644
--- a/classes/sota.bbclass
+++ b/classes/sota.bbclass
@@ -20,13 +20,15 @@ WKS_FILE_sota ?= "sdimage-sota.wks"
20 20
21EXTRA_IMAGEDEPENDS_append_sota = " parted-native mtools-native dosfstools-native" 21EXTRA_IMAGEDEPENDS_append_sota = " parted-native mtools-native dosfstools-native"
22 22
23INITRAMFS_FSTYPES = "${@oe.utils.ifelse(d.getVar('OSTREE_BOOTLOADER', True) == 'u-boot', 'ext4.gz.u-boot', 'ext4.gz')}"
24
23# Please redefine OSTREE_REPO in order to have a persistent OSTree repo 25# Please redefine OSTREE_REPO in order to have a persistent OSTree repo
24OSTREE_REPO ?= "${DEPLOY_DIR_IMAGE}/ostree_repo" 26OSTREE_REPO ?= "${DEPLOY_DIR_IMAGE}/ostree_repo"
25# For UPTANE operation, OSTREE_BRANCHNAME must start with "${MACHINE}-" 27# For UPTANE operation, OSTREE_BRANCHNAME must start with "${MACHINE}-"
26OSTREE_BRANCHNAME ?= "${MACHINE}" 28OSTREE_BRANCHNAME ?= "${MACHINE}"
27OSTREE_OSNAME ?= "poky" 29OSTREE_OSNAME ?= "poky"
28OSTREE_INITRAMFS_IMAGE ?= "initramfs-ostree-image" 30OSTREE_INITRAMFS_IMAGE ?= "initramfs-ostree-image"
29 31OSTREE_BOOTLOADER ??= 'u-boot'
30 32
31GARAGE_SIGN_REPO ?= "${DEPLOY_DIR_IMAGE}/garage_sign_repo" 33GARAGE_SIGN_REPO ?= "${DEPLOY_DIR_IMAGE}/garage_sign_repo"
32GARAGE_SIGN_KEYNAME ?= "garage-key" 34GARAGE_SIGN_KEYNAME ?= "garage-key"
diff --git a/recipes-core/images/initramfs-ostree-image.bb b/recipes-core/images/initramfs-ostree-image.bb
index 4ab9da8..e77499e 100644
--- a/recipes-core/images/initramfs-ostree-image.bb
+++ b/recipes-core/images/initramfs-ostree-image.bb
@@ -13,8 +13,7 @@ IMAGE_LINGUAS = ""
13 13
14LICENSE = "MIT" 14LICENSE = "MIT"
15 15
16IMAGE_FSTYPES = "ext4.gz" 16IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
17IMAGE_FSTYPES_append_arm = " ext4.gz.u-boot"
18 17
19inherit core-image 18inherit core-image
20 19