summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLaurent Bonnans <laurent.bonnans@here.com>2019-05-21 16:59:59 +0200
committerMykhaylo Sul <ext-mykhaylo.sul@here.com>2019-07-19 20:48:42 +0200
commit455b6a1f1d33e30310089b28a8c97b3798b294c9 (patch)
tree9117930f68c30e1ff5ec59a3ea0354efa71c582c
parentcd9f539ec6eb171b28411f4ad7b0b6a7372c01d9 (diff)
downloadmeta-updater-455b6a1f1d33e30310089b28a8c97b3798b294c9.tar.gz
Add example recipe for systemd-journald configuration
Signed-off-by: Laurent Bonnans <laurent.bonnans@here.com>
-rw-r--r--recipes-support/systemd-journald-persistent/files/10-persistent-journal.conf3
-rw-r--r--recipes-support/systemd-journald-persistent/systemd-journald-persistent.bb20
2 files changed, 23 insertions, 0 deletions
diff --git a/recipes-support/systemd-journald-persistent/files/10-persistent-journal.conf b/recipes-support/systemd-journald-persistent/files/10-persistent-journal.conf
new file mode 100644
index 0000000..a56527c
--- /dev/null
+++ b/recipes-support/systemd-journald-persistent/files/10-persistent-journal.conf
@@ -0,0 +1,3 @@
1[Journal]
2Storage=persistent
3SystemMaxUse=64M
diff --git a/recipes-support/systemd-journald-persistent/systemd-journald-persistent.bb b/recipes-support/systemd-journald-persistent/systemd-journald-persistent.bb
new file mode 100644
index 0000000..1715fe1
--- /dev/null
+++ b/recipes-support/systemd-journald-persistent/systemd-journald-persistent.bb
@@ -0,0 +1,20 @@
1SUMMARY = "Configuration for systemd-journald"
2DESCRIPTION = "Provides configuration for systemd-journald, so that logs are \
3stored on persistent storage"
4LICENSE = "MPL-2.0"
5LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7f619bab123dad"
6
7PACKAGE_ARCH = "${MACHINE_ARCH}"
8
9SRC_URI_append = " file://10-persistent-journal.conf"
10PR = "r1"
11
12S = "${WORKDIR}"
13
14FILES_${PN} = "${systemd_unitdir}/journald.conf.d/*"
15
16do_install() {
17 install -d ${D}/${systemd_unitdir}/journald.conf.d
18 install -m 0644 ${WORKDIR}/10-persistent-journal.conf ${D}/${systemd_unitdir}/journald.conf.d
19}
20