summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Sul <mykhaylo.sul@innoteka.com>2019-02-19 16:33:09 +0200
committerPatrick Vacek <patrickvacek@gmail.com>2019-02-26 17:04:35 +0100
commitea02b35be923c30dd2d130647d71ed445216f4c7 (patch)
tree0e0e244422eea1d1350b2f81a0f5fc014eb067c1
parente9c373dba1e249085de4c9068521a83653fa5d77 (diff)
downloadmeta-updater-ea02b35be923c30dd2d130647d71ed445216f4c7.tar.gz
OTA-2135: Aktualizr's config and recipe to auto reboot just after update
Signed-off-by: Mike Sul <mykhaylo.sul@innoteka.com>
-rw-r--r--recipes-sota/config/aktualizr-auto-reboot.bb21
-rw-r--r--recipes-sota/config/files/35-enable-auto-reboot.toml2
2 files changed, 23 insertions, 0 deletions
diff --git a/recipes-sota/config/aktualizr-auto-reboot.bb b/recipes-sota/config/aktualizr-auto-reboot.bb
new file mode 100644
index 0000000..1317fd4
--- /dev/null
+++ b/recipes-sota/config/aktualizr-auto-reboot.bb
@@ -0,0 +1,21 @@
1SUMMARY = "Enable auto reboot to apply updates"
2DESCRIPTION = "Configures aktualizr to auto reboot just after new updates installation in order to apply them"
3HOMEPAGE = "https://github.com/advancedtelematic/aktualizr"
4SECTION = "base"
5LICENSE = "MPL-2.0"
6LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7f619bab123dad"
7
8SRC_URI = " \
9 file://35-enable-auto-reboot.toml \
10 "
11
12do_install_append () {
13 install -m 0700 -d ${D}${libdir}/sota/conf.d
14 install -m 0644 ${WORKDIR}/35-enable-auto-reboot.toml ${D}${libdir}/sota/conf.d/35-enable-auto-reboot.toml
15}
16
17FILES_${PN} = " \
18 ${libdir}/sota/conf.d/35-enable-auto-reboot.toml \
19 "
20
21# vim:set ts=4 sw=4 sts=4 expandtab:
diff --git a/recipes-sota/config/files/35-enable-auto-reboot.toml b/recipes-sota/config/files/35-enable-auto-reboot.toml
new file mode 100644
index 0000000..f83810e
--- /dev/null
+++ b/recipes-sota/config/files/35-enable-auto-reboot.toml
@@ -0,0 +1,2 @@
1[uptane]
2force_install_completion = true