summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Vacek <patrickvacek@gmail.com>2019-02-21 17:22:50 +0100
committerPatrick Vacek <patrickvacek@gmail.com>2019-02-26 17:07:41 +0100
commit68436312e13b116121f2dae07f34eaa1988f16b9 (patch)
tree0dc0cb75503c39230248e511ddf7dfbe114b24f2
parentfbabfa932a18332ea0e929f5ca733814bac84294 (diff)
downloadmeta-updater-68436312e13b116121f2dae07f34eaa1988f16b9.tar.gz
aktualizr-auto-prov-creds: remove API Gateway URL if it exists.
It will only be used by garage-sign. Signed-off-by: Patrick Vacek <patrickvacek@gmail.com>
-rw-r--r--recipes-sota/aktualizr/aktualizr-auto-prov-creds.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/recipes-sota/aktualizr/aktualizr-auto-prov-creds.bb b/recipes-sota/aktualizr/aktualizr-auto-prov-creds.bb
index 34460af..0628a61 100644
--- a/recipes-sota/aktualizr/aktualizr-auto-prov-creds.bb
+++ b/recipes-sota/aktualizr/aktualizr-auto-prov-creds.bb
@@ -11,9 +11,14 @@ require credentials.inc
11do_install() { 11do_install() {
12 if [ -n "${SOTA_PACKED_CREDENTIALS}" ]; then 12 if [ -n "${SOTA_PACKED_CREDENTIALS}" ]; then
13 install -m 0700 -d ${D}${localstatedir}/sota 13 install -m 0700 -d ${D}${localstatedir}/sota
14 cp ${SOTA_PACKED_CREDENTIALS} ${D}${localstatedir}/sota/sota_provisioning_credentials.zip 14 cp "${SOTA_PACKED_CREDENTIALS}" ${D}${localstatedir}/sota/sota_provisioning_credentials.zip
15 # Device should not be able to push data to treehub 15 # Device should not be able to push data to treehub
16 zip -d ${D}${localstatedir}/sota/sota_provisioning_credentials.zip treehub.json 16 zip -d ${D}${localstatedir}/sota/sota_provisioning_credentials.zip treehub.json
17 # Device has no use for the API Gateway. Remove if present. See:
18 # https://github.com/advancedtelematic/ota-plus-server/pull/1913/
19 if unzip -l ${D}${localstatedir}/sota/sota_provisioning_credentials.zip api_gateway.url > /dev/null; then
20 zip -d ${D}${localstatedir}/sota/sota_provisioning_credentials.zip api_gateway.url
21 fi
17 fi 22 fi
18} 23}
19 24