summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRicardo Salveti <ricardo@foundries.io>2019-07-24 18:46:45 -0300
committerLaurent Bonnans <laurent.bonnans@here.com>2019-08-15 17:49:09 +0200
commita5408f226c9dbc0a63ac6441e859cea361f49cd6 (patch)
tree1cd8ada7e8b4140256d8f1e2c8bd1d67fe960aed
parent7679da3a7ada003c112e68d4c6e317466f0ccc7e (diff)
downloadmeta-updater-a5408f226c9dbc0a63ac6441e859cea361f49cd6.tar.gz
initramfs-ostree-image: unset EXTRA_IMAGEDEPENDS to avoid extra dependencies
It is common for machine configurations to set EXTRA_IMAGEDEPENDS, which can end up causing circular dependencies when building the initramfs image (they are usually only required for the actual rootfs image). Signed-off-by: Ricardo Salveti <ricardo@foundries.io> (cherry-picked from commit e556e32c8449fc324481d0d74682f5e04a191477)
-rw-r--r--recipes-core/images/initramfs-ostree-image.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/recipes-core/images/initramfs-ostree-image.bb b/recipes-core/images/initramfs-ostree-image.bb
index e77499e..b21be1c 100644
--- a/recipes-core/images/initramfs-ostree-image.bb
+++ b/recipes-core/images/initramfs-ostree-image.bb
@@ -15,6 +15,9 @@ LICENSE = "MIT"
15 15
16IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}" 16IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
17 17
18# Avoid circular dependencies
19EXTRA_IMAGEDEPENDS = ""
20
18inherit core-image 21inherit core-image
19 22
20IMAGE_ROOTFS_SIZE = "8192" 23IMAGE_ROOTFS_SIZE = "8192"