summaryrefslogtreecommitdiffstats
path: root/recipes-ti
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-ti')
-rw-r--r--recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb b/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
index 56a74899..0f2ba9af 100644
--- a/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
+++ b/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
@@ -169,6 +169,16 @@ do_install_am62xx() {
169 install -m 0644 ${RTOS_DM_FW_DIR}/ipc_echo_testb_mcu1_0_release_strip.xer5f ${LEGACY_DM_FW_DIR} 169 install -m 0644 ${RTOS_DM_FW_DIR}/ipc_echo_testb_mcu1_0_release_strip.xer5f ${LEGACY_DM_FW_DIR}
170} 170}
171 171
172
173do_deploy() {
174 install -d ${DEPLOYDIR}
175}
176
177do_deploy_am62xx() {
178 install -d ${DEPLOYDIR}
179 install -m 0644 ${RTOS_DM_FW_DIR}/ipc_echo_testb_mcu1_0_release_strip.xer5f ${DEPLOYDIR}
180}
181
172# Set up names for the firmwares 182# Set up names for the firmwares
173ALTERNATIVE_${PN}_am65xx = "\ 183ALTERNATIVE_${PN}_am65xx = "\
174 am65x-mcu-r5f0_0-fw \ 184 am65x-mcu-r5f0_0-fw \
@@ -357,3 +367,5 @@ INSANE_SKIP_${PN} += "arch"
357# we don't want to configure and build the source code 367# we don't want to configure and build the source code
358do_compile[noexec] = "1" 368do_compile[noexec] = "1"
359do_configure[noexec] = "1" 369do_configure[noexec] = "1"
370
371addtask deploy after do_install