summaryrefslogtreecommitdiffstats
path: root/recipes-ti
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-ti')
-rw-r--r--recipes-ti/ipc/ti-ipc-rtos_git.bb23
1 files changed, 19 insertions, 4 deletions
diff --git a/recipes-ti/ipc/ti-ipc-rtos_git.bb b/recipes-ti/ipc/ti-ipc-rtos_git.bb
index eff10016..4c0fc74f 100644
--- a/recipes-ti/ipc/ti-ipc-rtos_git.bb
+++ b/recipes-ti/ipc/ti-ipc-rtos_git.bb
@@ -2,7 +2,7 @@ require recipes-ti/includes/ti-paths.inc
2require recipes-ti/includes/ti-staging.inc 2require recipes-ti/includes/ti-staging.inc
3require ti-ipc.inc 3require ti-ipc.inc
4 4
5PR = "${INC_PR}.3" 5PR = "${INC_PR}.4"
6 6
7DEPENDS = "ti-xdctools ti-sysbios" 7DEPENDS = "ti-xdctools ti-sysbios"
8DEPENDS_append_keystone = " ti-cgt6x-native \ 8DEPENDS_append_keystone = " ti-cgt6x-native \
@@ -55,7 +55,22 @@ do_install() {
55 install -d ${D}${IPC_INSTALL_DIR_RECIPE} 55 install -d ${D}${IPC_INSTALL_DIR_RECIPE}
56 cp -pPrf ${S}/* ${D}${IPC_INSTALL_DIR_RECIPE} 56 cp -pPrf ${S}/* ${D}${IPC_INSTALL_DIR_RECIPE}
57 57
58 install -d ${D}${base_libdir}/firmware 58 install -d ${D}${base_libdir}/firmware/ipc
59 find . -name "*.xe66" -type f | xargs -I {} install -m 0644 {} ${D}${base_libdir}/firmware/ 59 cp -pPrf ${S}/packages/ti/ipc/tests/bin/* ${D}${base_libdir}/firmware/ipc
60 find . -name "*.xem4" -type f | xargs -I {} install -m 0644 {} ${D}${base_libdir}/firmware/ 60}
61
62ALTERNATIVE_PRIORITY = "5"
63
64pkg_postinst_${PN}-fw_omap-a15 () {
65 update-alternatives --install /lib/firmware/dra7-dsp1-fw.xe66 dra7-dsp1-fw.xe66 ipc/ti_platforms_evmDRA7XX_dsp1/test_omx_dsp1_vayu.xe66 ${ALTERNATIVE_PRIORITY}
66 update-alternatives --install /lib/firmware/dra7-dsp2-fw.xe66 dra7-dsp2-fw.xe66 ipc/ti_platforms_evmDRA7XX_dsp2/test_omx_dsp2_vayu.xe66 ${ALTERNATIVE_PRIORITY}
67 update-alternatives --install /lib/firmware/dra7-ipu1-fw.xem4 dra7-ipu1-fw.xem4 ipc/ti_platforms_evmDRA7XX_ipu1/test_omx_ipu1_vayu.xem4 ${ALTERNATIVE_PRIORITY}
68 update-alternatives --install /lib/firmware/dra7-ipu2-fw.xem4 dra7-ipu2-fw.xem4 ipc/ti_platforms_evmDRA7XX_ipu2/test_omx_ipu2_vayu.xem4 ${ALTERNATIVE_PRIORITY}
69}
70
71pkg_postrm_${PN}-fw_omap-a15 () {
72 update-alternatives --remove dra7-dsp1-fw.xe66 ipc/ti_platforms_evmDRA7XX_dsp1/test_omx_dsp1_vayu.xe66
73 update-alternatives --remove dra7-dsp2-fw.xe66 ipc/ti_platforms_evmDRA7XX_dsp2/test_omx_dsp2_vayu.xe66
74 update-alternatives --remove dra7-ipu1-fw.xem4 ipc/ti_platforms_evmDRA7XX_ipu1/test_omx_ipu1_vayu.xem4
75 update-alternatives --remove dra7-ipu2-fw.xem4 ipc/ti_platforms_evmDRA7XX_ipu2/test_omx_ipu2_vayu.xem4
61} 76}