summaryrefslogtreecommitdiffstats
path: root/recipes-ti
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-ti')
-rw-r--r--recipes-ti/includes/ti-paths.inc2
-rw-r--r--recipes-ti/openmp-rtos/openmp-rtos_git.bb62
2 files changed, 64 insertions, 0 deletions
diff --git a/recipes-ti/includes/ti-paths.inc b/recipes-ti/includes/ti-paths.inc
index 4bff9216..b660c11b 100644
--- a/recipes-ti/includes/ti-paths.inc
+++ b/recipes-ti/includes/ti-paths.inc
@@ -53,6 +53,7 @@ export DSPLIB_C66_INSTALL_DIR_RECIPE = "${installdir}/ti-dsplib-c66x-tree"
53export MATHLIB_C66_INSTALL_DIR_RECIPE = "${installdir}/ti-mathlib-c66x-tree" 53export MATHLIB_C66_INSTALL_DIR_RECIPE = "${installdir}/ti-mathlib-c66x-tree"
54export IMGLIB_C66_INSTALL_DIR_RECIPE = "${installdir}/ti-imglib-c66x-tree" 54export IMGLIB_C66_INSTALL_DIR_RECIPE = "${installdir}/ti-imglib-c66x-tree"
55export CG_XML_INSTALL_DIR_RECIPE = "${installdir}/ti-cg-xml-tree" 55export CG_XML_INSTALL_DIR_RECIPE = "${installdir}/ti-cg-xml-tree"
56export OMP_INSTALL_DIR_RECIPE = "${installdir}/ti-omp-tree"
56 57
57 58
58# This is where the tools will end up in sysroot 59# This is where the tools will end up in sysroot
@@ -97,6 +98,7 @@ export DSPLIB_C66_INSTALL_DIR = "${STAGING_DIR_TARGET}${DSPLIB_C66_INSTALL_
97export MATHLIB_C66_INSTALL_DIR = "${STAGING_DIR_TARGET}${MATHLIB_C66_INSTALL_DIR_RECIPE}" 98export MATHLIB_C66_INSTALL_DIR = "${STAGING_DIR_TARGET}${MATHLIB_C66_INSTALL_DIR_RECIPE}"
98export IMGLIB_C66_INSTALL_DIR = "${STAGING_DIR_TARGET}${IMGLIB_C66_INSTALL_DIR_RECIPE}" 99export IMGLIB_C66_INSTALL_DIR = "${STAGING_DIR_TARGET}${IMGLIB_C66_INSTALL_DIR_RECIPE}"
99export CG_XML_INSTALL_DIR = "${STAGING_DIR_NATIVE}${CG_XML_INSTALL_DIR_RECIPE}" 100export CG_XML_INSTALL_DIR = "${STAGING_DIR_NATIVE}${CG_XML_INSTALL_DIR_RECIPE}"
101export OMP_INSTALL_DIR = "${STAGING_DIR_TARGET}${OMP_INSTALL_DIR_RECIPE}"
100 102
101DSPSUFFIX_omapl137 = "x674" 103DSPSUFFIX_omapl137 = "x674"
102DSPSUFFIX_omapl138 = "x674" 104DSPSUFFIX_omapl138 = "x674"
diff --git a/recipes-ti/openmp-rtos/openmp-rtos_git.bb b/recipes-ti/openmp-rtos/openmp-rtos_git.bb
new file mode 100644
index 00000000..b735ec4d
--- /dev/null
+++ b/recipes-ti/openmp-rtos/openmp-rtos_git.bb
@@ -0,0 +1,62 @@
1DESCRIPTION = "TI OpenMP RTOS"
2HOMEPAGE = "git://git.ti.com/openmp/ti-openmp-dsp-runtime.git"
3LICENSE = "BSD"
4
5require recipes-ti/includes/ti-paths.inc
6
7PV = "2_02_00_02"
8PR = "r0"
9
10OPENMP_RTOS_GIT_URI = "git://git.ti.com/openmp/ti-openmp-dsp-runtime.git"
11OPENMP_RTOS_GIT_PROTOCOL = "git"
12OPENMP_RTOS_GIT_BRANCH = "master"
13
14BRANCH = "${OPENMP_RTOS_GIT_BRANCH}"
15SRC_URI = "${OPENMP_RTOS_GIT_URI};protocol=${OPENMP_RTOS_GIT_PROTOCOL};branch=${BRANCH} \
16"
17
18SRCREV = "5599f2218be68274c58110a12c85a97c6ed1a2d9"
19
20LIC_FILES_CHKSUM = "file://docs/license/omp_manifest_template.html;md5=61a6972303c0447b7c056195d7ebafee"
21
22DEPENDS = "common-csl-ip-rtos ti-xdctools ti-ipc-rtos ti-sysbios ti-cgt6x-native libulm"
23DEPENDS_append_keystone = " qmss-lld-rtos cppi-lld-rtos"
24
25COMPATIBLE_MACHINE = "keystone|omap-a15"
26PACKAGE_ARCH = "${MACHINE_ARCH}"
27
28S = "${WORKDIR}/git"
29export IPC_DIR = "${IPC_INSTALL_DIR}"
30export XDC_DIR = "${XDC_INSTALL_DIR}"
31export BIOS_DIR = "${SYSBIOS_INSTALL_DIR}"
32export ULM_DIR ="${STAGING_DIR_TARGET}/usr/share/ti/ulm"
33export C6636_PDK_DIR ="${PDK_INSTALL_DIR}"
34export AM572_PDK_DIR ="${PDK_INSTALL_DIR}"
35export XDCCGROOT = "${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x"
36
37export BUILD_K2H = "0"
38export BUILD_AM572 = "0"
39
40BUILD_K2H_keystone = "1"
41BUILD_AM572_omap-a15 = "1"
42
43RELEASE_TARGET = ""
44RELEASE_TARGET_keystone = "k2x"
45RELEASE_TARGET_omap-a15 = "am57xx"
46
47do_compile() {
48 make -f utils/product/Makefile .zipfile
49}
50
51do_install() {
52 install -d ${D}${OMP_INSTALL_DIR_RECIPE}
53 cp -r ${S}/exports/openmp_dsp_${RELEASE_TARGET}_${PV}/. -d ${D}${OMP_INSTALL_DIR_RECIPE}
54}
55
56ALLOW_EMPTY_${PN} = "1"
57
58FILES_${PN}-dev += " \
59 ${OMP_INSTALL_DIR_RECIPE}/ \
60"
61
62INSANE_SKIP_${PN}-dev = "arch"