summaryrefslogtreecommitdiffstats
path: root/recipes-ti
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-ti')
-rw-r--r--recipes-ti/ipc/ti-ipc-rtos_git.bb112
-rw-r--r--recipes-ti/ipc/ti-ipc.inc8
2 files changed, 99 insertions, 21 deletions
diff --git a/recipes-ti/ipc/ti-ipc-rtos_git.bb b/recipes-ti/ipc/ti-ipc-rtos_git.bb
index 4c0fc74f..497fa95b 100644
--- a/recipes-ti/ipc/ti-ipc-rtos_git.bb
+++ b/recipes-ti/ipc/ti-ipc-rtos_git.bb
@@ -2,9 +2,42 @@ require recipes-ti/includes/ti-paths.inc
2require recipes-ti/includes/ti-staging.inc 2require recipes-ti/includes/ti-staging.inc
3require ti-ipc.inc 3require ti-ipc.inc
4 4
5PR = "${INC_PR}.4" 5TI_IPC_EXAMPLES_GIT_URI = "git://git.ti.com/ipc/ipc-examples.git"
6TI_IPC_EXAMPLES_DEST_SUFFIX = "git/ipc-examples"
7TI_IPC_EXAMPLES_GIT_PROTOCOL = "git"
8TI_IPC_EXAMPLES_GIT_BRANCH = "master"
9TI_IPC_EXAMPLES_NAME = "ipc-examples"
6 10
7DEPENDS = "ti-xdctools ti-sysbios" 11SRC_URI += "${TI_IPC_EXAMPLES_GIT_URI};\
12destsuffix=${TI_IPC_EXAMPLES_DEST_SUFFIX};\
13protocol=${TI_IPC_EXAMPLES_GIT_PROTOCOL};\
14branch=${TI_IPC_EXAMPLES_GIT_BRANCH};\
15name=${TI_IPC_EXAMPLES_NAME}"
16
17TI_IPC_METADATA_GIT_URI = "git://git.ti.com/ipc/ipc-metadata.git"
18TI_IPC_METADATA_DEST_SUFFIX = "git/ipc-metadata"
19TI_IPC_METADATA_GIT_PROTOCOL = "git"
20TI_IPC_METADATA_GIT_BRANCH = "master"
21TI_IPC_METADATA_NAME = "ipc-metadata"
22
23SRC_URI += "${TI_IPC_METADATA_GIT_URI};\
24destsuffix=${TI_IPC_METADATA_DEST_SUFFIX};\
25protocol=${TI_IPC_METADATA_GIT_PROTOCOL};\
26branch=${TI_IPC_METADATA_GIT_BRANCH};\
27name=${TI_IPC_METADATA_NAME}"
28
29# Corresponds to tag: 3.42.01.03
30SRCREV_ipc-examples = "bd4f28bd46467553e6610629ff13b4b5b3ba3af0"
31
32# Corresponds to tag: 3.42.01.03
33SRCREV_ipc-metadata = "4d01fe4a7c41d2ce76a62b4325e66753d59b298c"
34
35S_ipc-examples = "${WORKDIR}/git/ipc-examples"
36S_ipc-metadata = "${WORKDIR}/git/ipc-metadata"
37
38PR = "${INC_PR}.0"
39
40DEPENDS = "ti-xdctools ti-sysbios doxygen-native"
8DEPENDS_append_keystone = " ti-cgt6x-native \ 41DEPENDS_append_keystone = " ti-cgt6x-native \
9 gcc-arm-none-eabi-native \ 42 gcc-arm-none-eabi-native \
10" 43"
@@ -26,6 +59,7 @@ IPC_TARGETS = ""
26IPC_TARGETS_omap-a15 = "\ 59IPC_TARGETS_omap-a15 = "\
27 gnu.targets.arm.A15F="${GCC_ARM_NONE_TOOLCHAIN}" \ 60 gnu.targets.arm.A15F="${GCC_ARM_NONE_TOOLCHAIN}" \
28 ti.targets.elf.C66="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \ 61 ti.targets.elf.C66="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \
62 ti.targets.elf.C66_big_endian="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \
29 ti.targets.arm.elf.M4="${M4_TOOLCHAIN_INSTALL_DIR}" \ 63 ti.targets.arm.elf.M4="${M4_TOOLCHAIN_INSTALL_DIR}" \
30 ti.targets.arm.elf.M4F="${M4_TOOLCHAIN_INSTALL_DIR}" \ 64 ti.targets.arm.elf.M4F="${M4_TOOLCHAIN_INSTALL_DIR}" \
31" 65"
@@ -33,18 +67,60 @@ IPC_TARGETS_omap-a15 = "\
33IPC_TARGETS_keystone = " \ 67IPC_TARGETS_keystone = " \
34 gnu.targets.arm.A15F="${GCC_ARM_NONE_TOOLCHAIN}" \ 68 gnu.targets.arm.A15F="${GCC_ARM_NONE_TOOLCHAIN}" \
35 ti.targets.elf.C66="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \ 69 ti.targets.elf.C66="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \
70 ti.targets.elf.C66_big_endian="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \
36" 71"
37 72
38EXTRA_OEMAKE = "\ 73EXTRA_OEMAKE = "\
39 PLATFORM=${PLATFORM} \ 74 PLATFORM=${PLATFORM} \
40 XDC_INSTALL_DIR="${XDC_INSTALL_DIR}" \ 75 XDC_INSTALL_DIR="${XDC_INSTALL_DIR}" \
41 BIOS_INSTALL_DIR="${SYSBIOS_INSTALL_DIR}" \ 76 BIOS_INSTALL_DIR="${SYSBIOS_INSTALL_DIR}" \
42 ${IPC_TARGETS} -f ipc-bios.mak\ 77 ${IPC_TARGETS} \
43" 78"
44 79
80RELEASE_TYPE = "GA"
81RELEASE_SUFFIX = ""
82
83IPC_PACKAGE_DIR = "${S}/ipc-package"
84
45do_compile() { 85do_compile() {
46 oe_runmake clean 86 oe_runmake -f ipc-bios.mak clean
47 oe_runmake all 87 oe_runmake -f ipc-bios.mak release
88
89 cd ${S_ipc-metadata}
90 oe_runmake .all-files IPC_INSTALL_DIR="${S}" \
91 BUILD_HOST_OS="linux" \
92 RELEASE_TYPE="${RELEASE_TYPE}"
93
94 cd ${S_ipc-examples}/src
95 oe_runmake .examples \
96 IPCTOOLS="${S_ipc-metadata}/src/etc"
97
98 if [ "${PLATFORM}" != "UNKNOWN" ]; then
99 oe_runmake extract HOSTOS="bios" IPC_INSTALL_DIR="${S}"
100 oe_runmake extract HOSTOS="linux" IPC_INSTALL_DIR="${S}"
101
102 if [ ! -z ${ALT_PLATFORM} ]; then
103 oe_runmake extract PLATFORM=${ALT_PLATFORM} HOSTOS="bios" IPC_INSTALL_DIR="${S}"
104 oe_runmake extract PLATFORM=${ALT_PLATFORM} HOSTOS="linux" IPC_INSTALL_DIR="${S}"
105 fi
106 fi
107
108 IPC_VERSION=`echo ${PV}${RELEASE_SUFFIX} | sed -e 's|\.|_|g'`
109 install -d ${IPC_PACKAGE_DIR}
110 # Copy docs and other meta files
111 cp -pPrf ${S_ipc-metadata}/exports/ipc_${IPC_VERSION}/* -d ${IPC_PACKAGE_DIR}
112
113 # Copy example folders corresponding to the platforms
114 if [ "${PLATFORM}" != "UNKNOWN" ]; then
115 install -d ${IPC_PACKAGE_DIR}/examples
116 cp -pPf ${S_ipc-examples}/src/examples/*.* ${IPC_PACKAGE_DIR}/examples/
117 cp -pPf ${S_ipc-examples}/src/examples/makefile ${IPC_PACKAGE_DIR}/examples/
118 cp -pPrf ${S_ipc-examples}/src/examples/${PLATFORM}* ${IPC_PACKAGE_DIR}/examples/
119 if [ ! -z ${ALT_PLATFORM} ]; then
120 cp -pPrf ${S_ipc-examples}/src/examples/${ALT_PLATFORM}* ${IPC_PACKAGE_DIR}/examples/
121 fi
122 find ${IPC_PACKAGE_DIR}/examples/ -name "*zip" -type f | xargs -I {} rm {}
123 fi
48} 124}
49 125
50do_compile_append() { 126do_compile_append() {
@@ -52,25 +128,27 @@ do_compile_append() {
52} 128}
53 129
54do_install() { 130do_install() {
55 install -d ${D}${IPC_INSTALL_DIR_RECIPE} 131 IPC_VERSION=`echo ${PV}${RELEASE_SUFFIX} | sed -e 's|\.|_|g'`
56 cp -pPrf ${S}/* ${D}${IPC_INSTALL_DIR_RECIPE} 132 # Copy docs and other meta files
133 install -d ${D}${IPC_INSTALL_DIR_RECIPE}
134 cp -pPrf ${IPC_PACKAGE_DIR}/* -d ${D}${IPC_INSTALL_DIR_RECIPE}
57 135
58 install -d ${D}${base_libdir}/firmware/ipc 136 install -d ${D}${base_libdir}/firmware/ipc
59 cp -pPrf ${S}/packages/ti/ipc/tests/bin/* ${D}${base_libdir}/firmware/ipc 137 cp -pPrf ${S}/packages/ti/ipc/tests/bin/* ${D}${base_libdir}/firmware/ipc || true
60} 138}
61 139
62ALTERNATIVE_PRIORITY = "5" 140ALTERNATIVE_PRIORITY = "5"
63 141
64pkg_postinst_${PN}-fw_omap-a15 () { 142pkg_postinst_${PN}-fw_omap-a15 () {
65 update-alternatives --install /lib/firmware/dra7-dsp1-fw.xe66 dra7-dsp1-fw.xe66 ipc/ti_platforms_evmDRA7XX_dsp1/test_omx_dsp1_vayu.xe66 ${ALTERNATIVE_PRIORITY} 143 update-alternatives --install /lib/firmware/dra7-dsp1-fw.xe66 dra7-dsp1-fw.xe66 ipc/ti_platforms_evmDRA7XX_dsp1/test_omx_dsp1_vayu.xe66 ${ALTERNATIVE_PRIORITY}
66 update-alternatives --install /lib/firmware/dra7-dsp2-fw.xe66 dra7-dsp2-fw.xe66 ipc/ti_platforms_evmDRA7XX_dsp2/test_omx_dsp2_vayu.xe66 ${ALTERNATIVE_PRIORITY} 144 update-alternatives --install /lib/firmware/dra7-dsp2-fw.xe66 dra7-dsp2-fw.xe66 ipc/ti_platforms_evmDRA7XX_dsp2/test_omx_dsp2_vayu.xe66 ${ALTERNATIVE_PRIORITY}
67 update-alternatives --install /lib/firmware/dra7-ipu1-fw.xem4 dra7-ipu1-fw.xem4 ipc/ti_platforms_evmDRA7XX_ipu1/test_omx_ipu1_vayu.xem4 ${ALTERNATIVE_PRIORITY} 145 update-alternatives --install /lib/firmware/dra7-ipu1-fw.xem4 dra7-ipu1-fw.xem4 ipc/ti_platforms_evmDRA7XX_ipu1/test_omx_ipu1_vayu.xem4 ${ALTERNATIVE_PRIORITY}
68 update-alternatives --install /lib/firmware/dra7-ipu2-fw.xem4 dra7-ipu2-fw.xem4 ipc/ti_platforms_evmDRA7XX_ipu2/test_omx_ipu2_vayu.xem4 ${ALTERNATIVE_PRIORITY} 146 update-alternatives --install /lib/firmware/dra7-ipu2-fw.xem4 dra7-ipu2-fw.xem4 ipc/ti_platforms_evmDRA7XX_ipu2/test_omx_ipu2_vayu.xem4 ${ALTERNATIVE_PRIORITY}
69} 147}
70 148
71pkg_postrm_${PN}-fw_omap-a15 () { 149pkg_postrm_${PN}-fw_omap-a15 () {
72 update-alternatives --remove dra7-dsp1-fw.xe66 ipc/ti_platforms_evmDRA7XX_dsp1/test_omx_dsp1_vayu.xe66 150 update-alternatives --remove dra7-dsp1-fw.xe66 ipc/ti_platforms_evmDRA7XX_dsp1/test_omx_dsp1_vayu.xe66
73 update-alternatives --remove dra7-dsp2-fw.xe66 ipc/ti_platforms_evmDRA7XX_dsp2/test_omx_dsp2_vayu.xe66 151 update-alternatives --remove dra7-dsp2-fw.xe66 ipc/ti_platforms_evmDRA7XX_dsp2/test_omx_dsp2_vayu.xe66
74 update-alternatives --remove dra7-ipu1-fw.xem4 ipc/ti_platforms_evmDRA7XX_ipu1/test_omx_ipu1_vayu.xem4 152 update-alternatives --remove dra7-ipu1-fw.xem4 ipc/ti_platforms_evmDRA7XX_ipu1/test_omx_ipu1_vayu.xem4
75 update-alternatives --remove dra7-ipu2-fw.xem4 ipc/ti_platforms_evmDRA7XX_ipu2/test_omx_ipu2_vayu.xem4 153 update-alternatives --remove dra7-ipu2-fw.xem4 ipc/ti_platforms_evmDRA7XX_ipu2/test_omx_ipu2_vayu.xem4
76} 154}
diff --git a/recipes-ti/ipc/ti-ipc.inc b/recipes-ti/ipc/ti-ipc.inc
index 69127aac..27b360df 100644
--- a/recipes-ti/ipc/ti-ipc.inc
+++ b/recipes-ti/ipc/ti-ipc.inc
@@ -8,15 +8,15 @@ TI_IPC_GIT_URI = "git://git.ti.com/ipc/ipcdev.git"
8TI_IPC_GIT_PROTOCOL = "git" 8TI_IPC_GIT_PROTOCOL = "git"
9TI_IPC_GIT_BRANCH = "3.42" 9TI_IPC_GIT_BRANCH = "3.42"
10 10
11#Corresponds to 3.42.00.02 11#Corresponds to 3.42.01.03
12TI_IPC_SRCREV = "a520969994378fb2629d7dfc25f306c3a711b5bc" 12TI_IPC_SRCREV = "dc6c5082f478225b7fbce4216173e6c5b36100b4"
13 13
14BRANCH = "${TI_IPC_GIT_BRANCH}" 14BRANCH = "${TI_IPC_GIT_BRANCH}"
15SRC_URI = "${TI_IPC_GIT_URI};protocol=${TI_IPC_GIT_PROTOCOL};branch=${BRANCH}" 15SRC_URI = "${TI_IPC_GIT_URI};protocol=${TI_IPC_GIT_PROTOCOL};branch=${BRANCH};name=ipcdev"
16SRCREV = "${TI_IPC_SRCREV}" 16SRCREV = "${TI_IPC_SRCREV}"
17 17
18S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
19PV = "3.42.00.02" 19PV = "3.42.01.03"
20INC_PR = "r0" 20INC_PR = "r0"
21 21
22PACKAGE_ARCH = "${MACHINE_ARCH}" 22PACKAGE_ARCH = "${MACHINE_ARCH}"