summaryrefslogtreecommitdiffstats
path: root/recipes-ti
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-ti')
-rw-r--r--recipes-ti/devtools/ti-cgt6x_8.1.0.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/recipes-ti/devtools/ti-cgt6x_8.1.0.bb b/recipes-ti/devtools/ti-cgt6x_8.1.0.bb
index 79b562a9..5e97927b 100644
--- a/recipes-ti/devtools/ti-cgt6x_8.1.0.bb
+++ b/recipes-ti/devtools/ti-cgt6x_8.1.0.bb
@@ -13,14 +13,14 @@ COMPATIBLE_HOST_class-target = "arm.*-linux"
13 13
14# For now we only have hardfp version for target class 14# For now we only have hardfp version for target class
15python __anonymous() { 15python __anonymous() {
16 c = bb.data.getVar("CLASSOVERRIDE", d, 1) 16 c = d.getVar("CLASSOVERRIDE", d, 1)
17 17
18 if c == "class-target": 18 if c == "class-target":
19 tunes = bb.data.getVar("TUNE_FEATURES", d, 1) 19 tunes = d.getVar("TUNE_FEATURES", d, 1)
20 if not tunes: 20 if not tunes:
21 return 21 return
22 pkgn = bb.data.getVar("PN", d, 1) 22 pkgn = d.getVar("PN", d, 1)
23 pkgv = bb.data.getVar("PV", d, 1) 23 pkgv = d.getVar("PV", d, 1)
24 if "callconvention-hard" not in tunes: 24 if "callconvention-hard" not in tunes:
25 bb.warn("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv)) 25 bb.warn("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv))
26 raise bb.parse.SkipPackage("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv)) 26 raise bb.parse.SkipPackage("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv))