diff options
Diffstat (limited to 'recipes-ti/ti-softhsmv2/ti-softhsmv2_git.bb')
-rw-r--r-- | recipes-ti/ti-softhsmv2/ti-softhsmv2_git.bb | 43 |
1 files changed, 43 insertions, 0 deletions
diff --git a/recipes-ti/ti-softhsmv2/ti-softhsmv2_git.bb b/recipes-ti/ti-softhsmv2/ti-softhsmv2_git.bb new file mode 100644 index 00000000..518508c3 --- /dev/null +++ b/recipes-ti/ti-softhsmv2/ti-softhsmv2_git.bb | |||
@@ -0,0 +1,43 @@ | |||
1 | DESCRIPTION = "TI softhsmv2 package" | ||
2 | LICENSE = "BSD-2-Clause | BSD-3-Clause | ISC | IBM-License | FSFULLR | Zlib" | ||
3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=55144a048ba54f211a1aaa38c7fd2424" | ||
4 | SECTION = "libs" | ||
5 | |||
6 | mntdir = "/mnt" | ||
7 | |||
8 | inherit autotools pkgconfig | ||
9 | |||
10 | DEPENDS = "openssl libdaemon" | ||
11 | COMPATIBLE_MACHINE = "(tci6614-evm|keystone)" | ||
12 | |||
13 | BRANCH="master" | ||
14 | SRC_URI = "git://git.ti.com/keystone-linux/ti-softhsmv2.git;protocol=git;branch=${BRANCH}" | ||
15 | #Following commit corresponds to tag DEV.SOFTHSM-01.03.00.01 | ||
16 | SRCREV = "c79d93ac2a326567a7245dda1b903ef340b5650c" | ||
17 | PV = "1.3.0.1" | ||
18 | |||
19 | S = "${WORKDIR}/git" | ||
20 | |||
21 | CFLAGS += " -mno-unaligned-access" | ||
22 | CPPFLAGS += " -mno-unaligned-access" | ||
23 | |||
24 | INITSCRIPT_NAME = "softhsm-daemon.sh" | ||
25 | INITSCRIPT_PARAMS = "defaults 10" | ||
26 | |||
27 | inherit update-rc.d | ||
28 | |||
29 | SELECTED_OPTIMIZATION := "${@d.getVar("SELECTED_OPTIMIZATION", True).replace("-O2", "-O3")}" | ||
30 | SELECTED_OPTIMIZATION := "${@d.getVar("SELECTED_OPTIMIZATION", True).replace("-ggdb2", "")}" | ||
31 | |||
32 | FILES_${PN} += "${libdir}/softhsm/lib*.so.* ${mntdir}/*" | ||
33 | FILES_${PN}-dbg += "${libdir}/softhsm/.debug" | ||
34 | FILES_${PN}-staticdev += "${libdir}/softhsm/*.a " | ||
35 | FILES_${PN}-dev += "${libdir}/softhsm/*.la ${libdir}/softhsm/lib*.so" | ||
36 | |||
37 | do_install_append() { | ||
38 | install -d ${D}${mntdir}/securedbv0 | ||
39 | install -d ${D}${mntdir}/securedbv1 | ||
40 | |||
41 | install -d ${D}${sysconfdir}/init.d/ | ||
42 | install -c -m 755 ${S}/src/bin/daemon/softhsm-daemon.sh ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME} | ||
43 | } | ||