summaryrefslogtreecommitdiffstats
path: root/recipes-ti/swtools/swtools_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-ti/swtools/swtools_git.bb')
-rw-r--r--recipes-ti/swtools/swtools_git.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/recipes-ti/swtools/swtools_git.bb b/recipes-ti/swtools/swtools_git.bb
new file mode 100644
index 00000000..425a0690
--- /dev/null
+++ b/recipes-ti/swtools/swtools_git.bb
@@ -0,0 +1,44 @@
1SUMMARY = "TI Software Tools"
2HOMEPAGE = "https://git.ti.com/ep-processor-libraries/swtools"
3SECTION = "devel"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://ti/mas/swtools/copyright.txt;md5=b1f52a1435051fdb18f8885b0384147d"
6
7require ../includes/ti-paths.inc
8
9DEPENDS = "ti-cgt6x-native \
10 ti-sysbios \
11 ti-xdctools-native"
12
13PV = "5_0_8"
14PR = "r0"
15S = "${WORKDIR}/git"
16BRANCH = "master"
17SRC_URI = "git://git.ti.com/ep-processor-libraries/swtools.git;protocol=git;branch=${BRANCH}"
18SRCREV = "881267836907de650edadc56b8e57ab45428021d"
19
20export C64PCODEGENTOOL = "${CGTOOLS_INSTALL_DIR}"
21export C674CODEGENTOOL = "${CGTOOLS_INSTALL_DIR}"
22export C66CODEGENTOOL = "${CGTOOLS_INSTALL_DIR}"
23
24PATH_append = ":${XDC_INSTALL_DIR}"
25
26XDCPATH .= "${XDCCGROOT}/include;${XDC_INSTALL_DIR}/packages;${SYSBIOS_INSTALL_DIR}/packages;"
27
28export XDCPATH
29
30do_compile() {
31 cd ${S}/ti/mas/swtools
32 xdc
33}
34
35do_install() {
36 CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership"
37 install -d ${D}${SWTOOLS_INSTALL_DIR_RECIPE}
38 cp -pPrf ${S}/* ${D}${SWTOOLS_INSTALL_DIR_RECIPE}
39}
40
41FILES_${PN}-dev += "${SWTOOLS_INSTALL_DIR_RECIPE}"
42
43INSANE_SKIP_${PN}-dev = "arch staticdev"
44ALLOW_EMPTY_${PN} = "1"