summaryrefslogtreecommitdiffstats
path: root/recipes-ti/secdev/ti-k3-secdev_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-ti/secdev/ti-k3-secdev_git.bb')
-rw-r--r--recipes-ti/secdev/ti-k3-secdev_git.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes-ti/secdev/ti-k3-secdev_git.bb b/recipes-ti/secdev/ti-k3-secdev_git.bb
new file mode 100644
index 00000000..28dbe9ee
--- /dev/null
+++ b/recipes-ti/secdev/ti-k3-secdev_git.bb
@@ -0,0 +1,36 @@
1DESCRIPTION = "Security development tools for High-Security(HS) TI K3 processors."
2HOMEPAGE = "https://git.ti.com/cgit/security-development-tools/core-secdev-k3"
3SECTION = "devel"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://manifest/k3-secdev-0.2-manifest.html;md5=f632a78870cc64550078d7b3cbac0892"
6
7# Native host tool only
8COMPATIBLE_MACHINE = "null"
9COMPATIBLE_MACHINE_class-native = "(.*)"
10COMPATIBLE_MACHINE_class-nativesdk = "(.*)"
11
12GIT_URI = "git://git.ti.com/git/security-development-tools/core-secdev-k3.git"
13GIT_PROTOCOL = "https"
14GIT_BRANCH = "master"
15GIT_SRCREV = "eb2c4d734487e5095b94cef3fd7213ee71d9e016"
16
17SRC_URI = "${GIT_URI};protocol=${GIT_PROTOCOL};branch=${GIT_BRANCH}"
18SRCREV = "${GIT_SRCREV}"
19
20S = "${WORKDIR}/git"
21
22do_install() {
23 CP_ARGS="-Prf --preserve=mode,links,timestamps --no-preserve=ownership"
24 install -d ${D}${TI_K3_SECDEV_INSTALL_DIR_RECIPE}
25 cp ${CP_ARGS} ${S}/* ${D}${TI_K3_SECDEV_INSTALL_DIR_RECIPE}
26}
27
28FILES_${PN} += "${TI_K3_SECDEV_INSTALL_DIR_RECIPE}"
29
30INSANE_SKIP_${PN} = "arch ldflags file-rdeps"
31
32INHIBIT_PACKAGE_STRIP = "1"
33INHIBIT_SYSROOT_STRIP = "1"
34INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
35
36BBCLASSEXTEND = "native nativesdk"