summaryrefslogtreecommitdiffstats
path: root/recipes-ti/netapi/netapi_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-ti/netapi/netapi_git.bb')
-rw-r--r--recipes-ti/netapi/netapi_git.bb32
1 files changed, 0 insertions, 32 deletions
diff --git a/recipes-ti/netapi/netapi_git.bb b/recipes-ti/netapi/netapi_git.bb
deleted file mode 100644
index 4427ecc2..00000000
--- a/recipes-ti/netapi/netapi_git.bb
+++ /dev/null
@@ -1,32 +0,0 @@
1DESCRIPTION = "Provides NETAPI module: TI user space network library"
2
3DEPENDS = "common-csl-ip rm-lld qmss-lld cppi-lld sa-lld hplib pktlib nwal-lld"
4
5include netapi.inc
6
7PR = "${INC_PR}.1"
8
9EXTRA_OEMAKE = "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR}"
10
11do_compile () {
12# Now build the netapi
13 for device in ${DEVICELIST}
14 do
15 for choice in ${CHOICELIST}
16 do
17 oe_runmake clean NETAPI_SRC_DIR=${S} NETAPI_INC_DIR=${BASEDIR} \
18 USEDYNAMIC_LIB="$choice" DEVICE="$device"
19 oe_runmake lib NETAPI_SRC_DIR=${S} NETAPI_INC_DIR=${BASEDIR} \
20 USEDYNAMIC_LIB="$choice" DEVICE="$device"
21 done
22 done
23}
24
25do_install () {
26 for device in ${DEVICELIST}
27 do
28 oe_runmake install INSTALL_INC_BASE_DIR=${D}${includedir} \
29 INSTALL_LIB_BASE_DIR=${D}${libdir} INSTALL_BIN_BASE_DIR=${D}${bindir} \
30 SYSCONFDIR=${D}${sysconfdir} DEVICE="$device"
31 done
32}