summaryrefslogtreecommitdiffstats
path: root/recipes-ti/multiprocmgr/multiprocmgr-rtos_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-ti/multiprocmgr/multiprocmgr-rtos_git.bb')
-rw-r--r--recipes-ti/multiprocmgr/multiprocmgr-rtos_git.bb24
1 files changed, 19 insertions, 5 deletions
diff --git a/recipes-ti/multiprocmgr/multiprocmgr-rtos_git.bb b/recipes-ti/multiprocmgr/multiprocmgr-rtos_git.bb
index 061790b2..c88f0d7f 100644
--- a/recipes-ti/multiprocmgr/multiprocmgr-rtos_git.bb
+++ b/recipes-ti/multiprocmgr/multiprocmgr-rtos_git.bb
@@ -6,22 +6,36 @@ require recipes-ti/multiprocmgr/multiprocmgr.inc
6 6
7DEPENDS = "ti-cgt6x-native" 7DEPENDS = "ti-cgt6x-native"
8 8
9PR = "${INC_PR}.0" 9PR = "${INC_PR}.1"
10 10
11export LOCAL_SYSROOT="${STAGING_DIR_TARGET}" 11PACKAGES =+ "${PN}-test"
12export C6X_GEN_INSTALL_PATH="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" 12FILES_${PN}-test = "${datadir}/ti/examples/mpm/test/filetestdemo/c66x/demo_loopback/build/bin/*.out \
13 ${datadir}/ti/examples/mpm/test/sync_test/c66x/bin/*.out"
14
15EXTRA_OEMAKE = "LOCAL_SYSROOT="${STAGING_DIR_TARGET}" \
16 C6X_GEN_INSTALL_PATH="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \
17 "
13 18
14do_compile() { 19do_compile() {
15 make c66x 20 oe_runmake c66x
16 make test_c66x 21 oe_runmake test_c66x
17} 22}
18 23
19do_install() { 24do_install() {
20 install -d ${D}${MPM_INSTALL_DIR_RECIPE} 25 install -d ${D}${MPM_INSTALL_DIR_RECIPE}
21 cp -pPrf ${S}/* ${D}${MPM_INSTALL_DIR_RECIPE} 26 cp -pPrf ${S}/* ${D}${MPM_INSTALL_DIR_RECIPE}
27
28 # Copy C66x binaries
29 install -d ${D}${datadir}/ti/examples/mpm/test/filetestdemo/c66x/demo_loopback/build/bin
30 cp ${S}/test/filetestdemo/c66x/demo_loopback/build/bin/*.out \
31 ${D}${datadir}/ti/examples/mpm/test/filetestdemo/c66x/demo_loopback/build/bin/
32 install -d ${D}${datadir}/ti/examples/mpm/test/sync_test/c66x/bin
33 cp ${S}/test/sync_test/c66x/bin/*.out \
34 ${D}${datadir}/ti/examples/mpm/test/sync_test/c66x/bin/
22} 35}
23 36
24FILES_${PN}-dev += "${MPM_INSTALL_DIR_RECIPE}" 37FILES_${PN}-dev += "${MPM_INSTALL_DIR_RECIPE}"
25INSANE_SKIP_${PN}-dev = "arch" 38INSANE_SKIP_${PN}-dev = "arch"
39INSANE_SKIP_${PN}-test = "arch"
26 40
27ALLOW_EMPTY_${PN} = "1" 41ALLOW_EMPTY_${PN} = "1"