diff options
Diffstat (limited to 'recipes-ti/matrix/matrix-gui_2.0.bb')
-rw-r--r-- | recipes-ti/matrix/matrix-gui_2.0.bb | 39 |
1 files changed, 39 insertions, 0 deletions
diff --git a/recipes-ti/matrix/matrix-gui_2.0.bb b/recipes-ti/matrix/matrix-gui_2.0.bb new file mode 100644 index 00000000..378a1f9e --- /dev/null +++ b/recipes-ti/matrix/matrix-gui_2.0.bb | |||
@@ -0,0 +1,39 @@ | |||
1 | DESCRIPTION = "Matrix GUI Application launcher" | ||
2 | HOMEPAGE = "https://gforge.ti.com/gf/project/matrix-gui-v2/" | ||
3 | LICENSE = "BSD MIT Apache" | ||
4 | SECTION = "multimedia" | ||
5 | PRIORITY = "optional" | ||
6 | |||
7 | PR = "r3" | ||
8 | |||
9 | INITSCRIPT_NAME = "matrix-gui-2.0" | ||
10 | INITSCRIPT_PARAMS = "defaults 99" | ||
11 | |||
12 | PACKAGE_ARCH = "all" | ||
13 | |||
14 | inherit update-rc.d | ||
15 | |||
16 | BRANCH ?= "master" | ||
17 | SRCREV = "c6db82baffcd96b20e67aa5cfdb4c0c98ef208b9" | ||
18 | |||
19 | SRC_URI = "git://gitorious.org/matrix-gui-v2/matrix-gui-v2.git;protocol=git;branch=${BRANCH} \ | ||
20 | file://init" | ||
21 | |||
22 | require matrix-gui-paths.inc | ||
23 | |||
24 | S = "${WORKDIR}/git" | ||
25 | |||
26 | do_install(){ | ||
27 | install -d ${D}${MATRIX_BASE_DIR} | ||
28 | cp -rf ${S}/* ${D}${MATRIX_BASE_DIR} | ||
29 | |||
30 | # Set the proper path in the init script | ||
31 | sed -i -e s=__MATRIX_BASE_DIR__=${MATRIX_BASE_DIR}= ${WORKDIR}/init | ||
32 | |||
33 | install -d ${D}${sysconfdir}/init.d | ||
34 | install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/matrix-gui-2.0 | ||
35 | } | ||
36 | |||
37 | RDEPENDS_${PN} += nodejs | ||
38 | |||
39 | FILES_${PN} += "${MATRIX_BASE_DIR}/*" | ||