summaryrefslogtreecommitdiffstats
path: root/recipes-ti/matrix/matrix-gui-clocks_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-ti/matrix/matrix-gui-clocks_1.0.bb')
-rw-r--r--recipes-ti/matrix/matrix-gui-clocks_1.0.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes-ti/matrix/matrix-gui-clocks_1.0.bb b/recipes-ti/matrix/matrix-gui-clocks_1.0.bb
new file mode 100644
index 00000000..2b5c1b3f
--- /dev/null
+++ b/recipes-ti/matrix/matrix-gui-clocks_1.0.bb
@@ -0,0 +1,37 @@
1DESCRIPTION = "Clock setting descriptions for Matrix v2"
2HOMEPAGE = "https://gforge.ti.com/gf/project/matrixguiv2apps/"
3LICENSE = "CC-BY-SA"
4PRIORITY = "optional"
5
6PR = "r0"
7
8PACKAGE_ARCH = "all"
9
10SRC_URI = "https://gforge.ti.com/gf/download/frsrelease/612/5031/clocks_1.0.tar.gz"
11
12S = ${WORKDIR}/clocks
13
14require matrix-gui-apps.inc
15
16# Make sure power submenu has been installed
17RDEPENDS += matrix-gui-submenus-power
18
19# Break out the individual files into separate packages. That way only the
20# clocks supported for each device can be installed. Prepend the list so
21# that we can get the files in ${bindir} first
22PACKAGES =+ "${PN}-300mhz ${PN}-600mhz ${PN}-800mhz ${PN}-1ghz"
23
24# Split the matrix files by clock
25FILES_${PN}-300mhz += "${MATRIX_APP_DIR}/power_set_300mhz/*"
26FILES_${PN}-600mhz += "${MATRIX_APP_DIR}/power_set_600mhz/*"
27FILES_${PN}-800mhz += "${MATRIX_APP_DIR}/power_set_800mhz/*"
28FILES_${PN}-1ghz += "${MATRIX_APP_DIR}/power_set_1ghz/*"
29
30# Split the ${bindir} files by clock
31FILES_${PN}-300mhz += "${bindir}/setopp2.sh"
32FILES_${PN}-600mhz += "${bindir}/setopp3.sh"
33FILES_${PN}-800mhz += "${bindir}/setopp4.sh"
34FILES_${PN}-1ghz += "${bindir}/setopp1.sh"
35
36SRC_URI[md5sum] = "9e76951feab2ecd9334e9c890426500f"
37SRC_URI[sha256sum] = "96dc90fffe45fc4bb499215f57c416d16ff874290d6b2f16b9e2fdbcb9c18cbe"