diff options
Diffstat (limited to 'recipes-ti/ipc')
-rw-r--r-- | recipes-ti/ipc/ti-ipc-common.inc | 2 | ||||
-rw-r--r-- | recipes-ti/ipc/ti-ipc-rtos.inc | 8 | ||||
-rw-r--r-- | recipes-ti/ipc/ti-ipc-rtos_git.bb | 12 | ||||
-rw-r--r-- | recipes-ti/ipc/ti-ipc.inc | 4 |
4 files changed, 17 insertions, 9 deletions
diff --git a/recipes-ti/ipc/ti-ipc-common.inc b/recipes-ti/ipc/ti-ipc-common.inc index aea9d278..6b156f97 100644 --- a/recipes-ti/ipc/ti-ipc-common.inc +++ b/recipes-ti/ipc/ti-ipc-common.inc | |||
@@ -1,4 +1,4 @@ | |||
1 | PV = "3.50.02.02" | 1 | PV = "3.50.03.03" |
2 | INC_PR = "r0" | 2 | INC_PR = "r0" |
3 | 3 | ||
4 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 4 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
diff --git a/recipes-ti/ipc/ti-ipc-rtos.inc b/recipes-ti/ipc/ti-ipc-rtos.inc index 7378d421..2b954c76 100644 --- a/recipes-ti/ipc/ti-ipc-rtos.inc +++ b/recipes-ti/ipc/ti-ipc-rtos.inc | |||
@@ -24,10 +24,10 @@ protocol=${TI_IPC_METADATA_GIT_PROTOCOL};\ | |||
24 | branch=${TI_IPC_METADATA_GIT_BRANCH};\ | 24 | branch=${TI_IPC_METADATA_GIT_BRANCH};\ |
25 | name=${TI_IPC_METADATA_NAME}" | 25 | name=${TI_IPC_METADATA_NAME}" |
26 | 26 | ||
27 | # Corresponds to tag: 3.50.02.02 | 27 | # Corresponds to tag: 3.50.03.03 |
28 | TI_IPC_METADATA_SRCREV = "171ed5b4cfc73fd2ebfeefe42249bec18f475613" | 28 | TI_IPC_METADATA_SRCREV = "88d4c734407f49d2edb8050b0b542e023b8750c8" |
29 | # Corresponds to tag: 3.50.01.01 | 29 | # Corresponds to tag: 3.50.03.03 |
30 | TI_IPC_EXAMPLES_SRCREV = "71f6e59a6b2c7e20c2656e5000f318339ded2f3c" | 30 | TI_IPC_EXAMPLES_SRCREV = "e2b116ab30b79d5dc855febb7dcc07179e8aef50" |
31 | 31 | ||
32 | SRCREV_ipc-metadata = "${TI_IPC_METADATA_SRCREV}" | 32 | SRCREV_ipc-metadata = "${TI_IPC_METADATA_SRCREV}" |
33 | SRCREV_ipc-examples = "${TI_IPC_EXAMPLES_SRCREV}" | 33 | SRCREV_ipc-examples = "${TI_IPC_EXAMPLES_SRCREV}" |
diff --git a/recipes-ti/ipc/ti-ipc-rtos_git.bb b/recipes-ti/ipc/ti-ipc-rtos_git.bb index ee7778a9..a276f22e 100644 --- a/recipes-ti/ipc/ti-ipc-rtos_git.bb +++ b/recipes-ti/ipc/ti-ipc-rtos_git.bb | |||
@@ -62,6 +62,12 @@ do_compile() { | |||
62 | fi | 62 | fi |
63 | } | 63 | } |
64 | 64 | ||
65 | do_install_prepend_am65xx-evm () { | ||
66 | # Trim directory name | ||
67 | mv ${S}/packages/ti/ipc/tests/bin/ti_platforms_cortexR_AM65X_false_R5F0 ${S}/packages/ti/ipc/tests/bin/ti_platforms_cortexR_AM65X_R5F0 | ||
68 | mv ${S}/packages/ti/ipc/tests/bin/ti_platforms_cortexR_AM65X_false_R5F1 ${S}/packages/ti/ipc/tests/bin/ti_platforms_cortexR_AM65X_R5F1 | ||
69 | } | ||
70 | |||
65 | do_install() { | 71 | do_install() { |
66 | CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership" | 72 | CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership" |
67 | IPC_VERSION=`echo ${PV}${RELEASE_SUFFIX} | sed -e 's|\.|_|g'` | 73 | IPC_VERSION=`echo ${PV}${RELEASE_SUFFIX} | sed -e 's|\.|_|g'` |
@@ -125,9 +131,11 @@ pkg_postrm_${PN}-fw_omapl138 () { | |||
125 | } | 131 | } |
126 | 132 | ||
127 | pkg_postinst_${PN}-fw_am65xx-evm () { | 133 | pkg_postinst_${PN}-fw_am65xx-evm () { |
128 | update-alternatives --install /lib/firmware/am65x-mcu-r5f0-fw am65x-mcu-r5f0-fw ipc/ti_platforms_cortexR_AM65X/messageq_single.xer5f ${ALTERNATIVE_PRIORITY} | 134 | update-alternatives --install /lib/firmware/am65x-mcu-r5f0-fw am65x-mcu-r5f0-fw ipc/ti_platforms_cortexR_AM65X_R5F0/messageq_single.xer5f ${ALTERNATIVE_PRIORITY} |
135 | update-alternatives --install /lib/firmware/am65x-mcu-r5f1-fw am65x-mcu-r5f1-fw ipc/ti_platforms_cortexR_AM65X_R5F1/messageq_single.xer5f ${ALTERNATIVE_PRIORITY} | ||
129 | } | 136 | } |
130 | 137 | ||
131 | pkg_postrm_${PN}-fw_am65xx-evm () { | 138 | pkg_postrm_${PN}-fw_am65xx-evm () { |
132 | update-alternatives --remove am65x-mcu-r5f0-fw ipc/ti_platforms_cortexR_AM65X/messageq_single.xe674 | 139 | update-alternatives --remove am65x-mcu-r5f0-fw ipc/ti_platforms_cortexR_AM65X_R5F0/messageq_single.xer5f |
140 | update-alternatives --remove am65x-mcu-r5f1-fw ipc/ti_platforms_cortexR_AM65X_R5F1/messageq_single.xer5f | ||
133 | } | 141 | } |
diff --git a/recipes-ti/ipc/ti-ipc.inc b/recipes-ti/ipc/ti-ipc.inc index 230c7ef8..428ad3d1 100644 --- a/recipes-ti/ipc/ti-ipc.inc +++ b/recipes-ti/ipc/ti-ipc.inc | |||
@@ -8,8 +8,8 @@ TI_IPC_GIT_URI = "git://git.ti.com/ipc/ipcdev.git" | |||
8 | TI_IPC_GIT_PROTOCOL = "git" | 8 | TI_IPC_GIT_PROTOCOL = "git" |
9 | TI_IPC_GIT_BRANCH = "3.50" | 9 | TI_IPC_GIT_BRANCH = "3.50" |
10 | 10 | ||
11 | #Corresponds to 3.50.02.02 | 11 | #Corresponds to 3.50.03.03 |
12 | TI_IPC_SRCREV = "c2bb741e4a2723155d38ede6a5a5dea8d6592089" | 12 | TI_IPC_SRCREV = "f20ff3ad29a4ca37d7a81e4fe1163d0c7b4eb3c7" |
13 | 13 | ||
14 | BRANCH = "${TI_IPC_GIT_BRANCH}" | 14 | BRANCH = "${TI_IPC_GIT_BRANCH}" |
15 | SRC_URI = "${TI_IPC_GIT_URI};protocol=${TI_IPC_GIT_PROTOCOL};branch=${BRANCH};name=ipcdev" | 15 | SRC_URI = "${TI_IPC_GIT_URI};protocol=${TI_IPC_GIT_PROTOCOL};branch=${BRANCH};name=ipcdev" |