diff options
Diffstat (limited to 'recipes-ti/ipc/ti-ipc-examples_git.bb')
-rw-r--r-- | recipes-ti/ipc/ti-ipc-examples_git.bb | 25 |
1 files changed, 17 insertions, 8 deletions
diff --git a/recipes-ti/ipc/ti-ipc-examples_git.bb b/recipes-ti/ipc/ti-ipc-examples_git.bb index 019bffac..40c3bc3b 100644 --- a/recipes-ti/ipc/ti-ipc-examples_git.bb +++ b/recipes-ti/ipc/ti-ipc-examples_git.bb | |||
@@ -12,6 +12,11 @@ INSANE_SKIP_${PN} += "arch" | |||
12 | 12 | ||
13 | ALLOW_EMPTY_${PN} = "1" | 13 | ALLOW_EMPTY_${PN} = "1" |
14 | 14 | ||
15 | PACKAGES =+ "${PN}-linux" | ||
16 | |||
17 | INSANE_SKIP_${PN}-linux += "arch" | ||
18 | ALLOW_EMPTY_${PN}-linux = "1" | ||
19 | |||
15 | IPC_INSTALL_DIR="${STAGING_DIR_TARGET}/usr/share/ti/ti-ipc-tree" | 20 | IPC_INSTALL_DIR="${STAGING_DIR_TARGET}/usr/share/ti/ti-ipc-tree" |
16 | 21 | ||
17 | do_compile() { | 22 | do_compile() { |
@@ -56,31 +61,35 @@ do_install() { | |||
56 | cd ${S_ipc-examples}/src | 61 | cd ${S_ipc-examples}/src |
57 | IPC_VERSION=`echo ${PV}${RELEASE_SUFFIX} | sed -e 's|\.|_|g'` | 62 | IPC_VERSION=`echo ${PV}${RELEASE_SUFFIX} | sed -e 's|\.|_|g'` |
58 | 63 | ||
59 | install -d ${D}/ipc_${IPC_VERSION}/examples | ||
60 | if [ "${PLATFORM}" != "UNKNOWN" ]; then | 64 | if [ "${PLATFORM}" != "UNKNOWN" ]; then |
65 | # Install directory for bios examples | ||
66 | install -d ${D}/ipc_${IPC_VERSION}/examples/bios | ||
67 | # Install directory for linux examples | ||
68 | install -d ${D}${bindir}/ipc/examples | ||
61 | oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \ | 69 | oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \ |
62 | HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples" | 70 | HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios" |
63 | oe_runmake -C examples install_rov IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \ | 71 | oe_runmake -C examples install_rov IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \ |
64 | HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples" | 72 | HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios" |
65 | 73 | ||
66 | oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \ | 74 | oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \ |
67 | LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \ | 75 | LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \ |
68 | HOSTOS="linux" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples" | 76 | HOSTOS="linux" EXEC_DIR="${D}/${bindir}/ipc/examples" |
69 | 77 | ||
70 | if [ ! -z ${ALT_PLATFORM} ]; then | 78 | if [ ! -z ${ALT_PLATFORM} ]; then |
71 | oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \ | 79 | oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \ |
72 | HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples" \ | 80 | HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios" \ |
73 | PLATFORM="${ALT_PLATFORM}" | 81 | PLATFORM="${ALT_PLATFORM}" |
74 | oe_runmake -C examples install_rov IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \ | 82 | oe_runmake -C examples install_rov IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \ |
75 | HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples" \ | 83 | HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios" \ |
76 | PLATFORM="${ALT_PLATFORM}" | 84 | PLATFORM="${ALT_PLATFORM}" |
77 | 85 | ||
78 | oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \ | 86 | oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \ |
79 | LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \ | 87 | LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \ |
80 | HOSTOS="linux" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples" \ | 88 | HOSTOS="linux" EXEC_DIR="${D}/${bindir}/ipc/examples" \ |
81 | PLATFORM="${ALT_PLATFORM}" | 89 | PLATFORM="${ALT_PLATFORM}" |
82 | fi | 90 | fi |
83 | fi | 91 | fi |
84 | } | 92 | } |
85 | 93 | ||
86 | FILES_${PN} += "ipc_*" | 94 | FILES_${PN} += "ipc_*" |
95 | FILES_${PN}-linux += "${bindir}/*" | ||