summaryrefslogtreecommitdiffstats
path: root/recipes-ti/ipc/ti-ipc-examples_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-ti/ipc/ti-ipc-examples_git.bb')
-rw-r--r--recipes-ti/ipc/ti-ipc-examples_git.bb64
1 files changed, 6 insertions, 58 deletions
diff --git a/recipes-ti/ipc/ti-ipc-examples_git.bb b/recipes-ti/ipc/ti-ipc-examples_git.bb
index 34735d29..d728983e 100644
--- a/recipes-ti/ipc/ti-ipc-examples_git.bb
+++ b/recipes-ti/ipc/ti-ipc-examples_git.bb
@@ -1,80 +1,35 @@
1DESCRIPTION = "TI Inter Process Communication (IPC) examples" 1DESCRIPTION = "TI Inter Process Communication (IPC) examples with Host running linux"
2HOMEPAGE = "http://processors.wiki.ti.com/index.php/Category:IPC" 2require ti-ipc-examples.inc
3require ti-ipc-common.inc
4require ti-ipc-rtos.inc
5
6LICENSE = "BSD"
7LIC_FILES_CHKSUM = "file://${S_ipc-examples}/src/makefile;beginline=1;endline=30;md5=fb83580b16bce88e8ed568a6005c8f02"
8 3
9DEPENDS = "ti-ipc ti-xdctools ti-sysbios ti-ipc-rtos zip-native" 4DEPENDS = "ti-ipc ti-xdctools ti-sysbios ti-ipc-rtos zip-native"
10 5
11INSANE_SKIP_${PN} += "arch" 6do_compile_append() {
12
13ALLOW_EMPTY_${PN} = "1"
14
15PACKAGES =+ "${PN}-linux"
16
17INSANE_SKIP_${PN}-linux += "arch"
18ALLOW_EMPTY_${PN}-linux = "1"
19
20IPC_INSTALL_DIR = "${STAGING_DIR_TARGET}/usr/share/ti/ti-ipc-tree"
21
22do_compile() {
23
24 cd ${S_ipc-examples}/src
25 oe_runmake .examples \
26 IPCTOOLS="${S_ipc-metadata}/src/etc"
27 7
28 if [ ! -z ${ALT_PLATFORM} ]; then
29 oe_runmake .examples "PLATFORM=${ALT_PLATFORM}" \
30 IPCTOOLS="${S_ipc-metadata}/src/etc"
31 echo test
32 fi
33 if [ "${PLATFORM}" != "UNKNOWN" ]; then 8 if [ "${PLATFORM}" != "UNKNOWN" ]; then
34 oe_runmake extract HOSTOS="bios" IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" 9 oe_runmake extract HOSTOS="bios" IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
35 oe_runmake extract HOSTOS="linux" IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
36 10
37 if [ ! -z ${ALT_PLATFORM} ]; then 11 if [ ! -z ${ALT_PLATFORM} ]; then
38 oe_runmake extract PLATFORM="${ALT_PLATFORM}" HOSTOS="bios" \ 12 oe_runmake extract PLATFORM="${ALT_PLATFORM}" HOSTOS="bios" \
39 IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" 13 IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
40 oe_runmake extract PLATFORM="${ALT_PLATFORM}" HOSTOS="linux" \
41 IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
42 fi 14 fi
43 oe_runmake -C examples all HOSTOS="bios" \ 15 oe_runmake -C examples all HOSTOS="bios" \
44 IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" 16 IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
45 oe_runmake -C examples all HOSTOS="linux" \
46 LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \
47 IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
48 if [ ! -z ${ALT_PLATFORM} ]; then 17 if [ ! -z ${ALT_PLATFORM} ]; then
49 oe_runmake -C examples all HOSTOS="bios" \ 18 oe_runmake -C examples all HOSTOS="bios" \
50 IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" PLATFORM="${ALT_PLATFORM}" 19 IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" PLATFORM="${ALT_PLATFORM}"
51 oe_runmake -C examples all HOSTOS="linux" \
52 LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \
53 IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
54 PLATFORM="${ALT_PLATFORM}"
55 echo testing
56 fi 20 fi
57 fi 21 fi
58} 22}
59 23
60do_install() { 24do_install_append() {
61 cd ${S_ipc-examples}/src
62 IPC_VERSION=`echo ${PV}${RELEASE_SUFFIX} | sed -e 's|\.|_|g'`
63
64 if [ "${PLATFORM}" != "UNKNOWN" ]; then 25 if [ "${PLATFORM}" != "UNKNOWN" ]; then
65 # Install directory for bios examples 26 # Install directory for bios examples
66 install -d ${D}/ipc_${IPC_VERSION}/examples/bios 27 install -d ${D}/ipc_${IPC_VERSION}/examples/bios
67 # Install directory for linux examples
68 install -d ${D}${bindir}/ipc/examples
69 oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \ 28 oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
70 HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios" 29 HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios"
71 oe_runmake -C examples install_rov IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \ 30 oe_runmake -C examples install_rov IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
72 HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios" 31 HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios"
73 32
74 oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
75 LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \
76 HOSTOS="linux" EXEC_DIR="${D}/${bindir}/ipc/examples"
77
78 if [ ! -z ${ALT_PLATFORM} ]; then 33 if [ ! -z ${ALT_PLATFORM} ]; then
79 oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \ 34 oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
80 HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios" \ 35 HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios" \
@@ -82,15 +37,8 @@ do_install() {
82 oe_runmake -C examples install_rov IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \ 37 oe_runmake -C examples install_rov IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
83 HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios" \ 38 HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios" \
84 PLATFORM="${ALT_PLATFORM}" 39 PLATFORM="${ALT_PLATFORM}"
85
86 oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
87 LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \
88 HOSTOS="linux" EXEC_DIR="${D}/${bindir}/ipc/examples" \
89 PLATFORM="${ALT_PLATFORM}"
90 fi 40 fi
91 fi 41 fi
92} 42}
93 43
94FILES_${PN} += "ipc_*" 44FILES_${PN} += "ipc_*"
95FILES_${PN}-linux += "${bindir}/*"
96INHIBIT_PACKAGE_STRIP = "1"