summaryrefslogtreecommitdiffstats
path: root/recipes-ti/ipc/ipc-transport-qmss-test_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-ti/ipc/ipc-transport-qmss-test_git.bb')
-rw-r--r--recipes-ti/ipc/ipc-transport-qmss-test_git.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes-ti/ipc/ipc-transport-qmss-test_git.bb b/recipes-ti/ipc/ipc-transport-qmss-test_git.bb
new file mode 100644
index 00000000..34d37086
--- /dev/null
+++ b/recipes-ti/ipc/ipc-transport-qmss-test_git.bb
@@ -0,0 +1,31 @@
1include ipc-transport-qmss.inc
2
3DEPENDS = "ipc-transport-qmss ti-ipc"
4
5#FILES_${PN}-test = "${bindir}/multiProcessTest_*.out"
6
7CHOICELIST = "yes no"
8
9DEVICELIST = "k2h k2k k2e k2l"
10
11do_compile () {
12# Now build the test code
13 for device in ${DEVICELIST}
14 do
15 for choice in ${CHOICELIST}
16 do
17 oe_runmake tests \
18 IPC_DEVKIT_INSTALL_PATH=${STAGING_INCDIR} \
19 USEDYNAMIC_LIB="$choice" DEVICE="$device"
20 done
21 done
22}
23
24do_install () {
25 for device in ${DEVICELIST}
26 do
27 oe_runmake installbin \
28 INSTALL_BIN_BASE_DIR=${D}${bindir} DEVICE="$device"
29 done
30
31}