diff options
Diffstat (limited to 'recipes-ti/dmai')
-rw-r--r-- | recipes-ti/dmai/ti-dmai.inc | 48 | ||||
-rwxr-xr-x | recipes-ti/dmai/ti-dmai/loadmodules-ti-dmai-apps.sh | 2 | ||||
-rwxr-xr-x | recipes-ti/dmai/ti-dmai/loadmodules-ti-dmai-o3530_al.sh | 2 | ||||
-rw-r--r-- | recipes-ti/dmai/ti-dmai/unloadmodules-ti-dmai-apps.sh | 2 | ||||
-rw-r--r-- | recipes-ti/dmai/ti-dmai_svn.bb | 20 |
5 files changed, 37 insertions, 37 deletions
diff --git a/recipes-ti/dmai/ti-dmai.inc b/recipes-ti/dmai/ti-dmai.inc index 50621184..c9c40865 100644 --- a/recipes-ti/dmai/ti-dmai.inc +++ b/recipes-ti/dmai/ti-dmai.inc | |||
@@ -31,22 +31,22 @@ SRC_URI = "svn://gforge.ti.com/svn/dmai/;module=${DMAIBRANCH};protocol=https;use | |||
31 | 31 | ||
32 | DEPENDS = "virtual/kernel alsa-lib ti-framework-components ti-codec-engine ti-xdctools-native" | 32 | DEPENDS = "virtual/kernel alsa-lib ti-framework-components ti-codec-engine ti-xdctools-native" |
33 | 33 | ||
34 | DEPENDS_append_dm6446 = " ti-codecs-dm6446 ti-dspbios ti-cgt6x ti-linuxutils" | 34 | DEPENDS:append_dm6446 = " ti-codecs-dm6446 ti-dspbios ti-cgt6x ti-linuxutils" |
35 | DEPENDS_append_dm6467 = " ti-codecs-dm6467 ti-dspbios ti-cgt6x ti-linuxutils" | 35 | DEPENDS:append_dm6467 = " ti-codecs-dm6467 ti-dspbios ti-cgt6x ti-linuxutils" |
36 | DEPENDS_append_omap3 = " ti-codecs-omap3530 ti-dspbios ti-cgt6x ti-linuxutils" | 36 | DEPENDS:append:omap3 = " ti-codecs-omap3530 ti-dspbios ti-cgt6x ti-linuxutils" |
37 | DEPENDS_append_dm355 = " ti-codecs-dm355" | 37 | DEPENDS:append_dm355 = " ti-codecs-dm355" |
38 | DEPENDS_append_dm365 = " ti-codecs-dm365" | 38 | DEPENDS:append_dm365 = " ti-codecs-dm365" |
39 | DEPENDS_append_omapl137 = " ti-codecs-omapl137 ti-dspbios ti-cgt6x ti-linuxutils" | 39 | DEPENDS:append:omapl137 = " ti-codecs-omapl137 ti-dspbios ti-cgt6x ti-linuxutils" |
40 | DEPENDS_append_omapl138 = " ti-codecs-omapl138 ti-dspbios ti-cgt6x ti-linuxutils" | 40 | DEPENDS:append:omapl138 = " ti-codecs-omapl138 ti-dspbios ti-cgt6x ti-linuxutils" |
41 | 41 | ||
42 | # Define DMAI build time variables | 42 | # Define DMAI build time variables |
43 | DMAIPLATFORM_dm6446 = "dm6446_al" | 43 | DMAIPLATFORM_dm6446 = "dm6446_al" |
44 | DMAIPLATFORM_dm6467 = "dm6467_al" | 44 | DMAIPLATFORM_dm6467 = "dm6467_al" |
45 | DMAIPLATFORM_omap3 = "o3530_al" | 45 | DMAIPLATFORM:omap3 = "o3530_al" |
46 | DMAIPLATFORM_dm355 = "dm355_al" | 46 | DMAIPLATFORM_dm355 = "dm355_al" |
47 | DMAIPLATFORM_dm365 = "dm365_al" | 47 | DMAIPLATFORM_dm365 = "dm365_al" |
48 | DMAIPLATFORM_omapl137 = "ol137_al" | 48 | DMAIPLATFORM:omapl137 = "ol137_al" |
49 | DMAIPLATFORM_omapl138 = "ol138_al" | 49 | DMAIPLATFORM:omapl138 = "ol138_al" |
50 | DMAIPLATFORM ?= "UNDEFINED_DMAIPLATFORM" | 50 | DMAIPLATFORM ?= "UNDEFINED_DMAIPLATFORM" |
51 | 51 | ||
52 | # Need to set this for other platforms as well | 52 | # Need to set this for other platforms as well |
@@ -55,8 +55,8 @@ DMAIPLATFORM ?= "UNDEFINED_DMAIPLATFORM" | |||
55 | #GPPOS ?= "UNDEFINEDGPPOS" | 55 | #GPPOS ?= "UNDEFINEDGPPOS" |
56 | 56 | ||
57 | # Need to re-define this for OMAP-L137/L138 | 57 | # Need to re-define this for OMAP-L137/L138 |
58 | DSPSUFFIX_omapl137 = "x64P" | 58 | DSPSUFFIX:omapl137 = "x64P" |
59 | DSPSUFFIX_omapl138 = "x64P" | 59 | DSPSUFFIX:omapl138 = "x64P" |
60 | DSPSUFFIX ?= "x64p" | 60 | DSPSUFFIX ?= "x64p" |
61 | 61 | ||
62 | # This is needed for dm355/dm365 targets in order to find ti.sdo.codecs.g711 | 62 | # This is needed for dm355/dm365 targets in order to find ti.sdo.codecs.g711 |
@@ -145,18 +145,18 @@ do_install () { | |||
145 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 145 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
146 | 146 | ||
147 | PACKAGES += "ti-dmai-apps" | 147 | PACKAGES += "ti-dmai-apps" |
148 | FILES_ti-dmai-apps = "${installdir}/ti-dmai-apps/*" | 148 | FILES:ti-dmai-apps = "${installdir}/ti-dmai-apps/*" |
149 | INSANE_SKIP_ti-dmai-apps = "1" | 149 | INSANE_SKIP:ti-dmai-apps = "1" |
150 | 150 | ||
151 | RDEPENDS_ti-dmai-apps_dm6446 += "ti-codecs-dm6446-server ti-cmem-module ti-dsplink-module" | 151 | RDEPENDS:ti-dmai-apps_dm6446 += "ti-codecs-dm6446-server ti-cmem-module ti-dsplink-module" |
152 | RDEPENDS_ti-dmai-apps_dm6467 += "ti-codecs-dm6467 ti-cmem-module ti-dsplink-module" | 152 | RDEPENDS:ti-dmai-apps_dm6467 += "ti-codecs-dm6467 ti-cmem-module ti-dsplink-module" |
153 | RDEPENDS_ti-dmai-apps_omap3 += "ti-codecs-omap3530-server ti-cmem-module ti-dsplink-module ti-lpm-module ti-sdma-module" | 153 | RDEPENDS:ti-dmai-apps:omap3 += "ti-codecs-omap3530-server ti-cmem-module ti-dsplink-module ti-lpm-module ti-sdma-module" |
154 | RDEPENDS_ti-dmai-apps_dm355 += "ti-codecs-dm355 ti-cmem-module ti-dm355mm-module" | 154 | RDEPENDS:ti-dmai-apps_dm355 += "ti-codecs-dm355 ti-cmem-module ti-dm355mm-module" |
155 | RDEPENDS_ti-dmai-apps_dm365 += "ti-codecs-dm365 ti-cmem-module ti-dm365mm-module ti-edma-module ti-irq-module" | 155 | RDEPENDS:ti-dmai-apps_dm365 += "ti-codecs-dm365 ti-cmem-module ti-dm365mm-module ti-edma-module ti-irq-module" |
156 | RDEPENDS_ti-dmai-apps_omapl137 += "ti-codecs-omapl137-server ti-cmem-module ti-dsplink-module" | 156 | RDEPENDS:ti-dmai-apps:omapl137 += "ti-codecs-omapl137-server ti-cmem-module ti-dsplink-module" |
157 | RDEPENDS_ti-dmai-apps_omapl138 += "ti-codecs-omapl138-server ti-cmem-module ti-dsplink-module" | 157 | RDEPENDS:ti-dmai-apps:omapl138 += "ti-codecs-omapl138-server ti-cmem-module ti-dsplink-module" |
158 | 158 | ||
159 | pkg_postinst_ti-dmai-apps () { | 159 | pkg_postinst:ti-dmai-apps () { |
160 | ln -sf ${installdir}/ti-codecs-server/*.${DSPSUFFIX} ${installdir}/ti-dmai-apps/ | 160 | ln -sf ${installdir}/ti-codecs-server/*.${DSPSUFFIX} ${installdir}/ti-dmai-apps/ |
161 | } | 161 | } |
162 | 162 | ||
diff --git a/recipes-ti/dmai/ti-dmai/loadmodules-ti-dmai-apps.sh b/recipes-ti/dmai/ti-dmai/loadmodules-ti-dmai-apps.sh index 7120b744..2bfd03c2 100755 --- a/recipes-ti/dmai/ti-dmai/loadmodules-ti-dmai-apps.sh +++ b/recipes-ti/dmai/ti-dmai/loadmodules-ti-dmai-apps.sh | |||
@@ -34,4 +34,4 @@ modprobe dsplinkk | |||
34 | 34 | ||
35 | # insert Local Power Manager driver | 35 | # insert Local Power Manager driver |
36 | # | 36 | # |
37 | modprobe lpm_omap3530 | 37 | modprobe lpm:omap3530 |
diff --git a/recipes-ti/dmai/ti-dmai/loadmodules-ti-dmai-o3530_al.sh b/recipes-ti/dmai/ti-dmai/loadmodules-ti-dmai-o3530_al.sh index 076af072..094d23d1 100755 --- a/recipes-ti/dmai/ti-dmai/loadmodules-ti-dmai-o3530_al.sh +++ b/recipes-ti/dmai/ti-dmai/loadmodules-ti-dmai-o3530_al.sh | |||
@@ -38,5 +38,5 @@ mknod /dev/dsplink c `awk "\\$2==\"dsplink\" {print \\$1}" /proc/devices` 0 | |||
38 | 38 | ||
39 | # insert Local Power Manager driver | 39 | # insert Local Power Manager driver |
40 | # | 40 | # |
41 | modprobe lpm_omap3530 | 41 | modprobe lpm:omap3530 |
42 | 42 | ||
diff --git a/recipes-ti/dmai/ti-dmai/unloadmodules-ti-dmai-apps.sh b/recipes-ti/dmai/ti-dmai/unloadmodules-ti-dmai-apps.sh index 793d727f..81d00af8 100644 --- a/recipes-ti/dmai/ti-dmai/unloadmodules-ti-dmai-apps.sh +++ b/recipes-ti/dmai/ti-dmai/unloadmodules-ti-dmai-apps.sh | |||
@@ -1,7 +1,7 @@ | |||
1 | # Unload modules - DMAI - OMAP3530 | 1 | # Unload modules - DMAI - OMAP3530 |
2 | 2 | ||
3 | # remove lpm module | 3 | # remove lpm module |
4 | rmmod lpm_omap3530 | 4 | rmmod lpm:omap3530 |
5 | 5 | ||
6 | # remove DSP/BIOS Link driver | 6 | # remove DSP/BIOS Link driver |
7 | rmmod dsplinkk | 7 | rmmod dsplinkk |
diff --git a/recipes-ti/dmai/ti-dmai_svn.bb b/recipes-ti/dmai/ti-dmai_svn.bb index 3cc54b91..fb7ff3c3 100644 --- a/recipes-ti/dmai/ti-dmai_svn.bb +++ b/recipes-ti/dmai/ti-dmai_svn.bb | |||
@@ -12,32 +12,32 @@ LIC_FILES_CHKSUM = "file://dmai_${PV}_License.html;md5=3302f728a5a42f97cabc26a54 | |||
12 | 12 | ||
13 | # This package has high dependence on kernel, use kernel PR as base and append a local version | 13 | # This package has high dependence on kernel, use kernel PR as base and append a local version |
14 | PR = "${MACHINE_KERNEL_PR}" | 14 | PR = "${MACHINE_KERNEL_PR}" |
15 | PR_append = "p" | 15 | PR:append = "p" |
16 | 16 | ||
17 | DMAIBRANCH_dm6446 = "trunk" | 17 | DMAIBRANCH_dm6446 = "trunk" |
18 | DMAIBRANCH_dm6467 = "branches/GITPSP_INT_101009" | 18 | DMAIBRANCH_dm6467 = "branches/GITPSP_INT_101009" |
19 | DMAIBRANCH_omap3 = "trunk" | 19 | DMAIBRANCH:omap3 = "trunk" |
20 | DMAIBRANCH_dm355 = "branches/GITPSP_INT_101009" | 20 | DMAIBRANCH_dm355 = "branches/GITPSP_INT_101009" |
21 | DMAIBRANCH_dm365 = "trunk" | 21 | DMAIBRANCH_dm365 = "trunk" |
22 | DMAIBRANCH_omapl137 = "trunk" | 22 | DMAIBRANCH:omapl137 = "trunk" |
23 | DMAIBRANCH_omapl138 = "trunk" | 23 | DMAIBRANCH:omapl138 = "trunk" |
24 | DMAIBRANCH ?= "UNDEFINED_DMAIBRANCH" | 24 | DMAIBRANCH ?= "UNDEFINED_DMAIBRANCH" |
25 | 25 | ||
26 | SRCREV_dm6446 = "482" | 26 | SRCREV_dm6446 = "482" |
27 | SRCREV_dm6467 = "441" | 27 | SRCREV_dm6467 = "441" |
28 | SRCREV_omap3 = "642" | 28 | SRCREV:omap3 = "642" |
29 | SRCREV_dm355 = "424" | 29 | SRCREV_dm355 = "424" |
30 | SRCREV_dm365 = "570" | 30 | SRCREV_dm365 = "570" |
31 | SRCREV_omapl137 = "482" | 31 | SRCREV:omapl137 = "482" |
32 | SRCREV_omapl138 = "570" | 32 | SRCREV:omapl138 = "570" |
33 | SRCREV ?= "UNDEFINED_SRCREV" | 33 | SRCREV ?= "UNDEFINED_SRCREV" |
34 | 34 | ||
35 | SRC_URI_append = " file://omap3530-r642-remove-include-videodev.diff;striplevel=3 \ | 35 | SRC_URI:append = " file://omap3530-r642-remove-include-videodev.diff;striplevel=3 \ |
36 | file://r642-fix-config-bld.diff;striplevel=3 \ | 36 | file://r642-fix-config-bld.diff;striplevel=3 \ |
37 | file://remove-unneeded-includes.patch \ | 37 | file://remove-unneeded-includes.patch \ |
38 | " | 38 | " |
39 | 39 | ||
40 | INSANE_SKIP_${PN} = "installed-vs-shipped" | 40 | INSANE_SKIP:${PN} = "installed-vs-shipped" |
41 | 41 | ||
42 | COMPATIBLE_HOST ?= "null" | 42 | COMPATIBLE_HOST ?= "null" |
43 | COMPATIBLE_HOST_ti-soc = "(.*)" | 43 | COMPATIBLE_HOST:ti-soc = "(.*)" |