summaryrefslogtreecommitdiffstats
path: root/recipes-ti/devtools/ti-cgt-pru_2.1.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-ti/devtools/ti-cgt-pru_2.1.4.bb')
-rw-r--r--recipes-ti/devtools/ti-cgt-pru_2.1.4.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/recipes-ti/devtools/ti-cgt-pru_2.1.4.bb b/recipes-ti/devtools/ti-cgt-pru_2.1.4.bb
new file mode 100644
index 00000000..5667ea2c
--- /dev/null
+++ b/recipes-ti/devtools/ti-cgt-pru_2.1.4.bb
@@ -0,0 +1,49 @@
1DESCRIPTION = "TI PRU Code Generation Tools"
2HOMEPAGE = "https://www-a.ti.com/downloads/sds_support/TICodegenerationTools/download.htm"
3LICENSE = "(TI-TSPA & Thai-Open-Source-Software-Center) & BSD-3-Clause & BSL-1.0 & Hewlett-Packard & AFL-3.0 & MIT & BSD-2-Clause & PD"
4
5LIC_FILES_CHKSUM = "file://ti-cgt-pru_${PV}/PRU_Code_Generation_Tools_2.1.x_manifest.html;md5=d7fea45a7968939ff953ae8a1e6719f4"
6LIC_FILES_CHKSUM_class-target = "file://usr/share/doc/ti/cgt-pru/PRU_Code_Generation_Tools_2.1.x_manifest.html;md5=d7fea45a7968939ff953ae8a1e6719f4"
7
8require recipes-ti/includes/ti-paths.inc
9require recipes-ti/includes/ti-unpack.inc
10
11BINFILE = "ti_cgt_pru_${PV}_linux_installer_x86.bin"
12BINFILE_NAME = "cgt-pru-x86"
13TI_BIN_UNPK_ARGS = "--prefix ${S}"
14TI_BIN_UNPK_CMDS = ""
15
16BINFILE_class-target = "ti_cgt_pru_${PV}_armlinuxa8hf_busybox_installer.sh"
17BINFILE_NAME_class-target = "cgt-pru-arm"
18
19SRC_URI = "http://software-dl.ti.com/codegen/esd/cgt_public_sw/PRU/${PV}/${BINFILE};name=${BINFILE_NAME}"
20
21SRC_URI[cgt-pru-x86.md5sum] = "496b32b9804cf5b5b293dd938f7c5339"
22SRC_URI[cgt-pru-x86.sha256sum] = "c80dbf35e7401f4c122ff25cc2f6b5db496607782fb4583cee8663a2763f4472"
23
24SRC_URI[cgt-pru-arm.md5sum] = "b13bf0cdf484102cdfcb92a81b8092a2"
25SRC_URI[cgt-pru-arm.sha256sum] = "c125bbe4e805b830e5d746ade929dc1f202f25a6863d5005ed97cc5a82e26754"
26
27do_install() {
28 install -d ${D}${TI_CGT_PRU_INSTALL_DIR_RECIPE}
29 cp -r ${S}/ti-cgt-pru_${PV}/. \
30 ${D}${TI_CGT_PRU_INSTALL_DIR_RECIPE}/
31}
32
33do_install_class-target() {
34 ${WORKDIR}/${BINFILE} --prefix ${D}
35}
36
37FILES_${PN} += "${datadir}/ti/*"
38
39FILES_${PN}-dbg = "${TI_CGT_PRU_INSTALL_DIR_RECIPE}/bin/.debug \
40 ${TI_CGT_PRU_INSTALL_DIR_RECIPE}/lib/.debug \
41"
42
43INHIBIT_PACKAGE_STRIP = "1"
44INHIBIT_SYSROOT_STRIP = "1"
45INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
46
47INSANE_SKIP_${PN} += "arch staticdev already-stripped"
48
49BBCLASSEXTEND = "native nativesdk"