summaryrefslogtreecommitdiffstats
path: root/recipes-ti/devtools/ti-cg-xml_2.61.00.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-ti/devtools/ti-cg-xml_2.61.00.bb')
-rw-r--r--recipes-ti/devtools/ti-cg-xml_2.61.00.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/recipes-ti/devtools/ti-cg-xml_2.61.00.bb b/recipes-ti/devtools/ti-cg-xml_2.61.00.bb
new file mode 100644
index 00000000..e618af5a
--- /dev/null
+++ b/recipes-ti/devtools/ti-cg-xml_2.61.00.bb
@@ -0,0 +1,40 @@
1DESCRIPTION = "TI CG_XML"
2HOMEPAGE = "http://software-dl.ti.com/ccs/non-esd/releases/other/applications_packages/cg_xml/index.htm"
3SECTION = "devel"
4LICENSE = "BSD"
5
6require recipes-ti/includes/ti-paths.inc
7require recipes-ti/includes/ti-staging.inc
8require recipes-ti/includes/ti-unpack.inc
9
10PV = "2.61.00"
11PE = "1"
12S = "${WORKDIR}/cg_xml_${PV}"
13
14SRC_URI = "\
15 http://software-dl.ti.com/ccs/non-esd/releases/other/applications_packages/cg_xml/cg_xml_v${@'${PV}'.replace('.','_')}/cgxml-${PV}-linux-installer.run;name=cgxmlbin_linux \
16"
17LIC_FILES_CHKSUM = "file://cg_xml_${PV}_Manifest.pdf;md5=fc02a39748ba50373f32b2f4a5e3a684"
18
19SRC_URI[cgxmlbin_linux.md5sum] = "6ce60caa97bbf15158d806fb062fadff"
20SRC_URI[cgxmlbin_linux.sha256sum] = "da77cb10bd3d5de89e27e4ce8f4408a2e50775c8980225f9a828ddc242bb81f9"
21
22BINFILE="cgxml-${PV}-linux-installer.run"
23TI_BIN_UNPK_CMDS=""
24TI_BIN_UNPK_ARGS="--prefix ${S} --mode unattended"
25
26do_install() {
27 CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership"
28 install -d ${D}${CG_XML_INSTALL_DIR_RECIPE}
29 cp ${CP_ARGS} ${S}/* ${D}${CG_XML_INSTALL_DIR_RECIPE}
30}
31
32FILES_${PN} += "${CG_XML_INSTALL_DIR_RECIPE}"
33
34INSANE_SKIP_${PN} = "arch ldflags file-rdeps"
35
36INHIBIT_PACKAGE_STRIP = "1"
37INHIBIT_SYSROOT_STRIP = "1"
38INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
39
40BBCLASSEXTEND = "native nativesdk"