diff options
Diffstat (limited to 'recipes-ti/beagleboard/beaglebone-tester.bb')
-rw-r--r-- | recipes-ti/beagleboard/beaglebone-tester.bb | 56 |
1 files changed, 0 insertions, 56 deletions
diff --git a/recipes-ti/beagleboard/beaglebone-tester.bb b/recipes-ti/beagleboard/beaglebone-tester.bb deleted file mode 100644 index 66b98a4c..00000000 --- a/recipes-ti/beagleboard/beaglebone-tester.bb +++ /dev/null | |||
@@ -1,56 +0,0 @@ | |||
1 | DESCRIPTION = "BeagleBone tester scripts" | ||
2 | HOMEPAGE = "http://beagleboard.org/support" | ||
3 | |||
4 | LICENSE = "GPLv2" | ||
5 | LIC_FILES_CHKSUM="file://gpl.txt;md5=5b122a36d0f6dc55279a0ebc69f3c60b" | ||
6 | |||
7 | # only scripts and data | ||
8 | inherit allarch | ||
9 | |||
10 | PR = "r20" | ||
11 | |||
12 | SRC_URI = "git://github.com/koenkooi/validation-scripts.git;protocol=git \ | ||
13 | " | ||
14 | SRCREV = "487a13e2e4faaafa40ba5430600e6aeecf9581a8" | ||
15 | |||
16 | S = "${WORKDIR}/git" | ||
17 | |||
18 | do_install() { | ||
19 | install -d ${D}${localstatedir}/lib/bone-tester/component/data/ | ||
20 | install -d ${D}${localstatedir}/lib/bone-tester/init-scripts/ | ||
21 | install -d ${D}${localstatedir}/lib/bone-tester/lib | ||
22 | install -d ${D}${base_libdir}/systemd/system/multi-user.target.wants/ | ||
23 | install -d ${D}/boot/ | ||
24 | install -m 0755 ${S}/bone-tester/init-scripts/uEnv.txt ${D}/boot/uEnv.txt | ||
25 | |||
26 | # systemd configuration | ||
27 | ln -s ../bone-tester.service ${D}${base_libdir}/systemd/system/multi-user.target.wants/bone-tester.service | ||
28 | install -m 0755 ${S}/bone-tester/init-scripts/bone-tester.service ${D}${base_libdir}/systemd/system/bone-tester.service | ||
29 | install -m 0755 ${S}/bone-tester/init-scripts/init.sh ${D}${localstatedir}/lib/bone-tester/init-scripts/init.sh | ||
30 | |||
31 | for i in $(find ${S}/bone-tester/component/ -maxdepth 1 -type f) ; do | ||
32 | install -m 0755 ${i} ${D}${localstatedir}/lib/bone-tester/component/ | ||
33 | done | ||
34 | for i in ${S}/bone-tester/component/data/* ; do | ||
35 | install -m 0755 ${i} ${D}${localstatedir}/lib/bone-tester/component/data/ | ||
36 | done | ||
37 | for i in ${S}/bone-tester/lib/* ; do | ||
38 | install -m 0755 ${i} ${D}${localstatedir}/lib/bone-tester/lib/ | ||
39 | done | ||
40 | |||
41 | install -d ${D}${bindir} | ||
42 | install -m 0755 ${S}/testaudio ${D}${bindir} | ||
43 | |||
44 | } | ||
45 | |||
46 | |||
47 | FILES_${PN} += "${base_libdir}/systemd \ | ||
48 | /boot \ | ||
49 | " | ||
50 | |||
51 | RDEPENDS_${PN} = "alsa-utils-aplay sox iputils memtester" | ||
52 | RRECOMMENDS_${PN} = "kernel-module-g-zero \ | ||
53 | kernel-module-g-mass-storage \ | ||
54 | kernel-module-g-file-storage \ | ||
55 | kernel-module-smsc95xx" | ||
56 | |||