diff options
Diffstat (limited to 'recipes-security/optee/optee-os/0007-allow-setting-sysroot-for-clang.patch')
-rw-r--r-- | recipes-security/optee/optee-os/0007-allow-setting-sysroot-for-clang.patch | 29 |
1 files changed, 0 insertions, 29 deletions
diff --git a/recipes-security/optee/optee-os/0007-allow-setting-sysroot-for-clang.patch b/recipes-security/optee/optee-os/0007-allow-setting-sysroot-for-clang.patch deleted file mode 100644 index 5c0d0a56..00000000 --- a/recipes-security/optee/optee-os/0007-allow-setting-sysroot-for-clang.patch +++ /dev/null | |||
@@ -1,29 +0,0 @@ | |||
1 | From 3167f2c0dba4db59d61b60a8fe66f969d20aafa9 Mon Sep 17 00:00:00 2001 | ||
2 | From: Brett Warren <brett.warren@arm.com> | ||
3 | Date: Wed, 23 Sep 2020 09:27:34 +0100 | ||
4 | Subject: [PATCH] optee: enable clang support | ||
5 | |||
6 | When compiling with clang, the LIBGCC_LOCATE_CFLAG variable used | ||
7 | to provide a sysroot wasn't included, which results in not locating | ||
8 | compiler-rt. This is mitigated by including the variable as ammended. | ||
9 | |||
10 | Upstream-Status: Pending | ||
11 | ChangeId: 8ba69a4b2eb8ebaa047cb266c9aa6c2c3da45701 | ||
12 | Signed-off-by: Brett Warren <brett.warren@arm.com> | ||
13 | --- | ||
14 | mk/clang.mk | 2 +- | ||
15 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
16 | |||
17 | diff --git a/mk/clang.mk b/mk/clang.mk | ||
18 | index 0f48c836..47465523 100644 | ||
19 | --- a/mk/clang.mk | ||
20 | +++ b/mk/clang.mk | ||
21 | @@ -27,7 +27,7 @@ comp-cflags-warns-clang := -Wno-language-extension-token \ | ||
22 | |||
23 | # Note, use the compiler runtime library (libclang_rt.builtins.*.a) instead of | ||
24 | # libgcc for clang | ||
25 | -libgcc$(sm) := $(shell $(CC$(sm)) $(CFLAGS$(arch-bits-$(sm))) \ | ||
26 | +libgcc$(sm) := $(shell $(CC$(sm)) $(LIBGCC_LOCATE_CFLAGS) $(CFLAGS$(arch-bits-$(sm))) \ | ||
27 | -rtlib=compiler-rt -print-libgcc-file-name 2> /dev/null) | ||
28 | |||
29 | # Core ASLR relies on the executable being ready to run from its preferred load | ||